Number page on proportal?
#1 02-06-2012 
Hello, always I Big Grin
I would like to ask if you know how to operate the page number on proportal.
I changed the default portal and it worked, then I put Proportal and page number doesn't work.
The guide for page number portal is on and it still not working Sad

#2 02-06-2012 
The portal paging is part of the announcements block on pro_portal. You need to change it in pro_portal/portal settings in your ACP.

Number of announcements to show per page
Please enter the number of announcements to show per page on the main page.

Set that to the number per page and it should paginate.

The site don't jive? PRESS F5 Flower

#3 02-06-2012 
Not number of announcements but number of page, navigation (?), as in image attachments


But I don't find your php code, I don't have portal.php, my index.php is ex-portal.php, I believe Confused

Attached File(s) Thumbnail(s)

#4 03-06-2012 
Yes, this is the way pro_portal is made. You set the number of announcements you want to see in the centre block and then you will get pages based on that - inside the block where the announcements are. Then when you click on next page only the centre "div" is paged - rest is static.

The code in the tutorial from Zinga is for standard MYBB portal - like I have. You cannot use it on pro_portal. Your forums is your old index page.
The site don't jive? PRESS F5 Flower

#5 03-06-2012 
Ok, I have tried but if I chose for example 100 announcements, proportal doesn't divide annoucements in page number, it is all on index and it takes a long time to load the page

#6 03-06-2012 
I think you must choose 5 announcements (for example) and then those 5 will show on the first page, the rest will be in the later pages.

The number you choose in the settings is the number PER PAGE, not the total number of announcements.
The site don't jive? PRESS F5 Flower

#7 03-06-2012 
Put in block_announcements.php:

$multipage = multipage($annnum, $proportal->settings['numannouncements'], $pagenum, $mybb->settings ['/index.php']);


Sorry, that is a members only option