Halp! I've lost a button and can't find it!
#1 19-02-2013 
This is extremely ridiculous, I know, but I'm really at my wits' end here. Huh

When you view a BHAV (by hitting "view BHAV" next to the op code in plugin view), you have a button called "import into package" in the lower right-hand corner, right? At least I've always had one... until yesterday, when it suddenly had disappeared. I have no idea why; I haven't changed any settings in SimPE and everything else looks normal, I still have all the special buttons - it's just "import into package" that's gone. What's worse, I don't know how to get it back, and I really need that button. Undecided (Of course I know I can import BHAVs from the "import semi globals" menu as well, but it's so much easier to just hit the "import" button when viewing the BHAV.)

I've tried resetting the layout, but no luck. And I can't really think of anything else to do, especially since I don't know what I did to make the button go away in the first place.Halp?
[Image: nixedbuttongreen5.jpg]

#2 19-02-2013 
Would you believe I don't remember ever seeing that button?

#3 19-02-2013 
I've always assumed it's there by default, but maybe it isn't. I just know it's always been there in my SimPE - well, as long as I've been poking at BHAVs, anyway.

I just wish I knew what it is I've done to make it go away, so that maybe I could undo it, but I have absolutely no idea what it might be. Sad
[Image: nixedbuttongreen5.jpg]

#4 20-02-2013 
I just had a look at my SimPE and it's not there.

I've pressed the help button to see what it says if anything - and discovered it's not listed there either although all the other buttons are.

HOWEVER... when I did this:

Extra -> Preferences -> Custom

Change Display 'Special Buttons' Panel from False to True.

When I click on View at the top, I get just a close button down below.

If I select a line, and click the view next to the opcode - I get 3 buttons - Import as Private, Import Unchanged, and Close.

Is that what you're thinking of?

ETA: I'm not sure if it does fix it. Can you have a try and see?

#5 20-02-2013 
Okay, I checked it out too, I didn't change anything like Kiri did but I do have the 3 buttons - Import as Private, Import Unchanged, and Close. No, "import into package" sorry!

You can find more of my work at Mod The Sims and Plumb Bob Keep.

#6 20-02-2013 
Thanks for your help, ladies! And I'm sorry, I did mean the "import as private" button; I couldn't remember exactly what is was called (and it wasn't there for me to check). Sorry!

@Kiri, I already had "display special buttons" set to true - but I tried setting it to false and then back to true, and guess what, that did it! Big Grin My precious little button is back!

I still don't know why the heck it disappeared in the first place, especially since all the other buttons were still there, but I don't really care. It's back now and I know what to try if it disappears again.

Thank you so much for your help! Consider this solved. Smile

Edit: Hah, I didn't remember it wrong after all - in my SimPE the button really is called Import to package (we probably have different versions). But no matter what it's called, I have it back and it makes me happy. Big Grin Again, thanks!

Attached File(s) Thumbnail(s)


Sorry, that is a members only option