Smooth Edges - Graphics
#1 19-02-2013 
Since my motivation has come back. I thought I would work on some Sims 2 stuff today.

So loaded up Sims 2. Since this is the first I have loaded up Sims 2 since I got a new graphics card and monitor. I had to change the resolution. However, for some reason the in-game graphic options will not allow me to enable or use smooth edges.

Does anyone have any suggestions on how to fix this?
Sailfindragon, proud to be a member of LeeFish since Aug 2012.

#2 19-02-2013 
Well that sucks. It sounds like you'll need to edit your graphics card settings to make that option available. I'm no expert on the matter, but this google search leads to some promising threads which you can investigate.

#3 19-02-2013 
Thank you. Smile Quite a few things on the search you provided that I can try.
Sailfindragon, proud to be a member of LeeFish since Aug 2012.

#4 19-02-2013 
Check out the posts by Kiri on this very topic - she changed some stuff in the ini file thing.

I will see if I can find the link.

The site don't jive? PRESS F5 Flower

#5 19-02-2013 
Thank you for the link. Unfortunately for the first part, I have no numbers in the chip type of my graphics card adapter properties. Smile

I will continue to see what I can find. Smile
Sailfindragon, proud to be a member of LeeFish since Aug 2012.

#6 19-02-2013 
In your Graphics rules file, try a search for enumerateMultisampleLevels and change false to true where you find it.

#7 20-02-2013 
Hi Sailfin - there is actually another way of getting the chip number when it's not listed there. I was helping out another girl where it wasn't displayed there, and we discovered it in a different place.

Via the Control Panel, if you go into System -> Device manager -> Display Adapters - Choose the graphics card and select properties. Then select the details tab, and in the drop down change it 'Matching Device ID' The last 4 numbers will be your card number Stick a '0x' on the front and you've got the complete id.

e.g. Mine is listed as pci/ven_1002&dev_6819, My graphics ID = 0x6819.

Also what type of card are you using? Different cards have different problems. I was sorting out a Radeon card for me and Honeywell, but an Intel card for this other girl - and there was code in the Graphics Rules card that had to change (mostly because they assumed that Intel couldn't cope with the graphics at all).
celebkiriedhel, proud to be a member of LeeFish since Dec 2010.
amazon wishlist because Lee said so.

#8 20-02-2013 
I have the Nvidia Geforce GTX 670 (4GB) I upgraded from the GTX 560 TI, never had a problem with that one. Smile

YAY. I found my Graphics ID: 0x1189
Sailfindragon, proud to be a member of LeeFish since Aug 2012.

#9 20-02-2013 
Putting in the Graphics ID may not automagically fix your graphics problem.

I'm looking at the code and I can see a couple of places where the anti-aliasing is turned off, and not turned on again unless it conforms to certain versions.

eefje is correct, "boolProp enumerateMultisampleLevels false" does turn off your anti-alias. So changing those all to true wherever they are will force it on.

The question is whether other things are turned off as well - so it's probably a good idea to find out how it's getting there and re-routing it.

If the graphics ID fixes your problems, great. If it doesn't try eefje's suggestion. If that doesn't fix it - let me know and I'll post up an sgr with trace in it to find out what's happening. Also if you go into your logs folder of your game (that's in the My Documents/EA Games/The Sims 2/Logs/ folder) and have a look for the -config-log.txt it will tell us some useful information. If you post up that, after the trace it will tell us what's happening.

It will tell us whether it's using Hardware or software rasterization (Hardware is the good one) with "boolProp activeDeviceUseSoftwareRasterizer false" and whether "enumateMultisampleLevels" is true or false - that's at the bottom of the text file.

My guess is that your game is set to medium resolution, rather than high - so missing anti-aliasing isn't going to be your only problem.

Lee - Should I put the updated information and the original information into a tutorial so that we can stick it in the wiki and it won't get lost again?

#10 20-02-2013 
I'm having problems with this as well. I an intel graphics card, not sure of the type or anything I know it uses GMA. Anyway, I set the values to true but only on my latest EP (M&G under Fun With Pets). Should I be doing this for all of the EPs, SPs, and the base game? And how do I change it from 'medium' to 'high'?


Sorry, that is a members only option