Slots need moveobject on cheat turned on
#1 03-06-2014 
So, new mesh- a table. One side of the table is table height, the other is counter height. I added 21 slots to it and none of them work without moveobjects on. I've tried adding the slots the joint and the practical in the CRES. Still need to use the cheat. I've added them to both SLOT files. No change. I've changed the F3 and I7 values in the SLOT file (added/removed 4 from F3, changed I7 to just about every value you can use.) No change. I added lines to the BHAV for support strength and allowing object intersection. No change. I'm aware of the line "Prevent Place in slot" in the OBJF- it returns true, which is what I think it should do? I did change the Y and Z values for the existing 2 non-eat slots- because they're on the higher side of the table. (But those slots work just fine.)

I guess this is probably a question more for Lee and Nix: WHY won't my slots work without cheats? Everything is fine with Model-Bones and the SLOT. If the CRES had errors, my game would crash. I've checked for typos and other errors and can't find a dratted thing wrong with the package. Sad Since I can usually add slots in my sleep without anything going wrong, I'm beginning to think I'm cursed, lol. I don't mind having to use the cheat for my own use, but if i want to share the blasted table I'd like it to work the way it should.

Oh! Yeah- I thought maybe it was the table I cloned. Can't remember which it was, it was the first in the list in SimPE. So I cloned your Generations table, Lee. I thought since you added a deco slot.. but no, that slot doesn't even work without the cheat. Is there some kind of "added slots" package I'm missing or something? (I think I have all of Lord Darcy's..) Or some other kind of mod?
(This post was last modified: 12-08-2014 09:01 PM by leefish.)

#2 03-06-2014 
sounds like something else is the issue MLC. That table of mine does not need any extra cheats etc to have the slot, so if it doesn't work its a "Something in your game" issue. Have you tried without your userstartup file in?

#3 03-06-2014 
Userstartup? The text file you can make that has cheats, etc., that loads when you start the game? I have never made one of those.

Also, the slots for the under stairs set all worked. And I haven't added anything to my downloads folder (or any other folder, lol) except for this table since I finished that set.

#4 03-06-2014 
can you attach the file? If you dont want it in the open put it on box or mf and pm me the link.

#5 03-06-2014 
I give you both. Version 2 is a clone of your table with no extra slots added, your added slot is there- that's it. The other is version135893827493856 of the original table and I forget where the slots are added, but they won't work without the cheat.

Attached File(s)
.rar  Tables.rar (Size: 561.01 KB / Downloads: 69)

#6 03-06-2014 
Unfortunately, I'm not at home right now and am on my non-simming netbook (Win 8 and Intel graphics... yeah, I'm not even going to try), so I'm afraid I won't be able to be of any assistance (not unless you want to wait until Saturday, anyway). Sad It's all yours, Lee.

#7 03-06-2014 
That's ok, Nix. <3

Um. Question. Would having an old version of the table that's being used affect the new version at all? By being used, I mean there are sims sitting at an old version eating breakfast. I know that making changes to the CRES means you have to rebuy an object- I always leave the old version on the lot so I can see the changes. But I've never done that with an object that's being used.. like a table. I ask this because I just put the Lee-clone on a new lot and the extra slot works. (If that was the problem this entire time, I'm going to roar. Yes, roar, not scream. I iz a cat after all.)

#8 03-06-2014 
It may well be...

* leefish cowers away from roaring cat

[Image: h13532DA0]

#9 03-06-2014 
Rofl. Big Grin

Well, I still need to put the old version on a new lot and see. But if that's what it was? I'll have to add that to the "Oh, well. Now you know list". That I don't actually KEEP, it's all in my head. (And that explains a wholeeeeeee lot about me, doesn't it.)

#10 03-06-2014 
*nudge nudge* No. Slots don't work on the old version without cheats. *cries* So I'll just add 20 more slots to the Lee-clone since the extra slot on that table DID work. I would like to know why, oh why, why me?!? those slots don't work but as long as the newest table works I guess I can just let the old one float away and join the rest of my borked creations.

* mustluvcatz avoids adding all those slots by going to the grocery store

ROAR!! Grrrr. OMG! Have I completely lost my mind? I may have. Lee- could you test the old version and see if those slots work for you? If they do I probably just need to edit the I7 value- I think it's at 3. I tried a different object and the slots worked now. I'm still going to the store because I'm sick of my stomach rumbling in hunger but if the slots work for you I'll be editing the package yet again later on. Note: there IS one slot that doesn't work, I must've missed something on that one when re-adding them.


Sorry, that is a members only option