Milkshape not exporting .5an joint data
#1 13-06-2014 
So lately I've been reading up on poseboxes and how to make them because I need a couple of unique poses for an object set I'm making. I've watched THIS tutorial from start to finish, as well as parts 1 and 2 of the hack creation tutorial. I followed the instructions to the letter; the BHAVs, TTAs and TTAB were all according to Hoyle, but the posebox still wasn't playing the pose. So I opened an anim import that I knew worked in SimPE and compared it to mine. The working anim has a bunch of data/coordinates for every joint in the cAnimResourceConst tab; mine is empty. I don't get it. I'm using Milkshape 1.8.4 with DrPixel's extracted skeleton for animation, making sure that in the Animate dropdown Operate On Selected Joints Only is checked, making sure the Anim button on the bottom write is selected, and entering 1, 1, 30 and 30 in the little keyframe doohickey at the bottom right. I have Wes H's Animesh exporter .dlls in my Milkshape folder, and to export I select Body Overlay for the ANIM type and pose for the Locomotion type, keeping the default length of 4000 ms. But for some reason it's exporting an empty .5an. Is there something I'm missing or doing wrong?
ocelotekatl, proud to be a member of LeeFish since Nov 2013.

#2 13-06-2014 
Hello, old friend (to quote Jeffrey Sinclair). Smile I think I'm the only posebox person here, so I'm afraid you're stuck with me for this one as well. Tongue

Hmm, to me it sounds like you're doing everything you should be doing. But you're quite right, on the AnimResource tab, there should be data for every single joint in the skeleton (at least if you're doing a full body animation), so something's definitely gone wrong. Are you exporting in animation mode? Because that's a BIG no-no, it can turn your animation into a big fiery ball visible from space. Or at least bork it badly. Undecided

BTW, if you're making a full body animation, you don't have to have Operate On Selected Joints Only checked, that's mostly important if you're making an overlay animation that only affects part of the Sim's body (like with my medical accessory posebox, that I just realised I never reuploaded after SimTrek went down. Will have to do something about that). It doesn't hurt anything if you have it checked when you're making a full body anim, but it's not absolutely necessary like it is for an overlay.

#3 13-06-2014 
Hi, Nix!

I think I understood that correctly, but to exit animation mode you click on the little Anim button on the far right, yes? When I do that, the skeleton pops back into its original position.

I don't know if it makes a difference but the way the skeletons load in the tutorial, there's a little blue wireframe down the middle and when you click on a joint, it highlights and you can rotate it. My skeleton looks like a big bundle of bailing wire, with one big blue hoop around each joint (as you would see in Unimesh). That's the only other thing I can think of.

#4 14-06-2014 
Before I go into anything else, it just hit me that there is one extremely important thing you never said you did. Did you set a keyframe before exporting (Animation -> Set Keyframe = skeleton turns yellow)? Because without a keyframe, there's no animation to export - which would explain why there's no data on the AnimResource tab.

#5 14-06-2014 
I think that's what it was. I don't think the tut mentioned this, but I tried it this way with a regular old unaltered skeleton and it worked. I've got to mess with it a bit more, but I think this may be resolved. Once again, thanks. I can always rely on you for sound modding advice.

Edit: It worked! For some reason the poses I made are a bit higher than I need them even when I used an imported .obj as a template, but that I can hammer out on my own. The main thing was getting the damn thing to work.
(This post was last modified: 14-06-2014 04:16 AM by ocelotekatl.)

#6 16-06-2014 
Yay! So glad it worked! Big Grin In case you haven't figured it out already (and your tute didn't mention it, it seems to have left out some important things Confused), to make the pose(s) lower you move the root_trans joint; that's the one you use to move the entire body up/down/back/forth/left/right.

BTW, to turn the big blue joint hoops into a pretty little wireframe skeleton, you need to change the joint size (that Milkshape for some reason thinks needs to be humongous). File -> Preferences -> Misc tab -> change the joint size to 0.01. That should make the skeleton more manageable. Smile


Sorry, that is a members only option