Sims2 Ultimate Collection not working.
#1 25-07-2014 
  • Registered
  • 0
  • 2
hELLO!! I've just installed The sims 2 Ultimate Collection from origin, on to my ASUS laptop which runs on windows 8 and has Intel pentium Graphics (I think). But everytime I open cas, move a premade family in or even just open a save it crashes!

Does anyone know how to make it work? or if it will work??

Thankyou xxx
(This post was last modified: 26-07-2014 03:17 AM by leefish.)

#2 25-07-2014 
Hello - lets move your post to sims discussion.

#3 25-07-2014 
  • Registered
  • 0
  • 2
Uhuh Ok! xD and thankyou

#4 25-07-2014 
Open a save? What kind of save? Did you already have the game before installing Ultimate? We'll need more info in order to help. For instance, apparently if you had Sims 2 Store Edition installed your old savedgames are not compatible with Ultimate. Could that be your issue?

#5 26-07-2014 
And a config-log.txt from your log folder where you play your game would be helpful as well.

#6 26-07-2014 
You need to read this excellen guide at MTS :

#7 26-07-2014 
Hi there, I've just installed The Sims 2 Ultimate Collection from Origin on my Sony Vaio with Processor Intel® Core™ i5-3210M CPU @ 2.50GHz, 2501 Mhz.

The game ran smoothly the graphics seem clean and smooth, however when I click to go into a sims house (any) the game crashes at the loading screen. Any idea why?
KimberlyTanith, proud to be a member of LeeFish since Jul 2014.

#8 26-07-2014 
No idea - have you read this guide?

#9 26-07-2014 
Yes I have, wasn't helpful unfortunately since my system is pretty new and I didn't have any preinstalled Sims, nor any issues downloading.

The game boots up and runs fine until i try to actually play in a neighborhood. It just crashes after it loads the Sims house.

#10 26-07-2014 
Did you check out the changing the TM thing kiri posted?

(This is from EA via Marka93 and MMJJSense)

1. Check to make sure the language you are installing it as, and the language of the account is the same.

2. It may be that your PC can't cope with the 'TM' symbol. This is EA's fix for it:
Just incase it is needed for some windows don't know how to handle the "TM" and it needs to be removed.
Only do this if you have a problem with your game.

Try this! I got it from a different forum at (credit goes to MMJJSense) with someone who had a similar issue:
you need to open regedit (Window+R) and open HKEY_LOCAL_MACHINE then SOFTWARE

For 32 - Bit : Find EA GAMES folder and open the sims 2... change the Display Name... Delete the ™ out... and the problem is solved...
For 64- Bit : Open Wow6432Node then.. Find EA GAMES folder and open the sims 2... change the Display Name... Delete the ™ out... and the problem is solved...

Before it's should look like this : The Sims 2™ Ultimate Collection
After : The Sims 2 Ultimate Collection


Sorry, that is a members only option