PROBLEMS load mods and packs in folder download
#1 28-07-2014 
  • Registered
  • 0
  • 5
Before im have just sims2 + 3 packs not the ultimate edition i just put all stuff download from modthesims in My Documents\EA Games\The Sims 2 (Now is sims 2 ultimate edicion)\Downloads and work... now even i use Sims2Pack Clean Installer still dont work.

and i do the fix of black box issue shadow but work when im out of houses when i enter in houses black box shadows come again...

Any ideas how fix?

#2 28-07-2014 

1. You need to go to MTS to deal with why Sims2PackClean Installer isn't working - that's a Delphy tool.
2. Set your shadows to medium and the black box issue will go away.

#3 28-07-2014 
@celebkiriedhel, I think what @huntersouls is trying to say is that before, when he (?) installed CC he just put it in the Downloads folder and it worked, but since installing the UC he can't get his CC to work (appear in game?), not even when he uses the CI to install it. I don't think he's saying the CI doesn't work.

huntersouls, please correct me if I'm wrong. Smile

#4 28-07-2014 
  • Registered
  • 0
  • 5
@celebkiriedhel correct sorry if explan bad ..but today technology wish f@!k my head...its sims ultimate, my smartphone viber and youtbe become crazy...damn Sad even in sims 2 i fix pc and die when repair with 4 mech ahahah omg bad day today

#5 28-07-2014 
Ahhh ok.
the reason why is probably because you look in the wrong place, and are adding things in the wrong place.

What folder are you adding your CC in?

The folder it should be is

\My Documents\Origin Games\The Sims 2\Downloads\

I don't know whether Clean Installer works with the Ultimate Collection, but if it isn't putting it into that location, then I suspect not.

#6 28-07-2014 
  • Registered
  • 0
  • 5
C:\Users\HunterSouls\Documents\EA Games\The Sims™ 2 Ultimate Collection\Downloads

#7 28-07-2014 
You might have the problem with the ™. this is from the first post of the Graphics Thread.

(This is from EA via Marka93 and MMJJSense)

1. Check to make sure the language you are installing it as, and the language of the account is the same.

2. It may be that your PC can't cope with the 'TM' symbol. This is EA's fix for it:
Just incase it is needed for some windows don't know how to handle the "TM" and it needs to be removed.
Only do this if you have a problem with your game.

Try this! I got it from a different forum at (credit goes to MMJJSense) with someone who had a similar issue:
you need to open regedit (Window+R) and open HKEY_LOCAL_MACHINE then SOFTWARE

For 32 - Bit : Find EA GAMES folder and open the sims 2... change the Display Name... Delete the ™ out... and the problem is solved...
For 64- Bit : Open Wow6432Node then.. Find EA GAMES folder and open the sims 2... change the Display Name... Delete the ™ out... and the problem is solved...

Before it's should look like this : The Sims 2™ Ultimate Collection
After : The Sims 2 Ultimate Collection

#8 28-07-2014 
@huntersouls, I don't have the Ultimate Collection, but a problem I've been having with the Clean Installer, that I know other people have had as well, is that it sometimes won't put the downloads into the real Downloads folder, but will instead create a new one in the EA Games folder and put them there. So, instead of putting the downloads in the EA Games/The Sims 2/Downloads folder, like it should, it puts them in EA Games/Downloads - where the game can't find them. I suggest you check to see that something like that isn't happening when you use the Clean Installer to install your downloads.

#9 28-07-2014 
  • Registered
  • 0
  • 5
thanks for all support give, but its see not only me have problems a people say can be problem in ultimate to not cheack ep´s
like in that link say "If a mod is not working, the first thing to do is make sure you have Smarter EP Check in your Downloads folder...
"NEWS July 25, 2014 - My official statement about my mods and the Ultimate Collection: I don't care. I've been screwed enough by EA that...I have seen no evidence to support the community's claim that the UC uses AL/M&G code so I have no idea if my mods will work, and no interest in finding out."
i think need this "Smarter EP Check" (

#10 28-07-2014 
The EP check is not the issue. The issue is that the Clean Installer is not putting your downloads in the correct place. Please read the MTS thread; there is no point us repeating all the excellent information that is already on MTS about the Clean Installer.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option