Photo Recolors are not showing in game
#1 21-09-2014 
Hi there!

It's me again. ha ha

Okay, so I've been trying to make some photo recolors for the last 2 days and it's starting to drive me mad.

I've tried using the Photostudio in SimPE, I've tried using Object Workshop in SimPE, I've even tried Wizards of SimPE. I've tried using maxis meshes and custom meshes and none of it is working.

Well, actually, in all cases the very first recolor showed up. Then the other 8 I made didn't show up in the game. And then when I ran the game again none of the recolors showed up.

This has driven me almost mad. I've never had this happen. Does anyone know what I can do to fix it? I've even tried to remove all the custom content from the Downloads folder except for the custom mesh and my recolors and it still didn't help.


#2 21-09-2014 
Hi Puppetfish,

Have you installed CEP? Without that the recolours are not going to show up.

Also when you are making the recolours, are you recolouring the mesh each time? Or are you taking a copy of the recolour? Because the second method won't work. You need to recolour the mesh each time.

I'm happy to have a look at your recolours and see if its a problem with them. You can send it through to my email. (remove the #)

#3 21-09-2014 
Hi! Yes, I've got the CEP, and uninstalled and reinstalled it. I've also used the mesh. sigh.

Thanks! I will zip them and send them posthaste! Wink

#4 22-09-2014 
1. I don't think Wizards of SimPE works with Ultimate Collection. It's easy to use SimPE to do recolours using object workshop, so I think you're better off doing it that way. If you need a walkthrough on how to do that, let me know. Smile

2. Ultimate Collection has problems with SimPE and vice versa. So SimPE needs a fix to be able to do recolours, etc with Ultimate Collection.

First up - it does seem to me to be a problem that it can't find the Base Game exe, when it has the file path.

what we're going to need to do is make sure all the file paths are set up correctly.

Can you double-check that the path you have listed there, and the actual path are the same? My suspicion is that you've got a 'TM' missing.

#5 22-09-2014 
Here's the path that's listed in SimPE

C:\Program Files (x86)\Origin Games\The Sims 2 Ultimate Collection\Double Deluxe\Base\TSBin\Sims2.exe

Here's what mine looks like:

C:\Program Files (x86)\Origin Games\The Sims 2 Ultimate Collection\Double Deluxe\Base\TSData

It appears I am missing the "TSBin\Sims2.exe" part


I did a little looking and it appears that the only folder that contains a TSBin folder is Fun with Pets\SP9

#6 22-09-2014 
That would do it.

Slig's post here is how to fix it SimPE fix for Ultimate Collection

I know that Lunie looked into it - I might check with her whether anything more needs to be done.

In the meantime - connect up your simpe file table to the one in the Fun with Pets\Sp9 that should help.

#7 23-09-2014 
I'm not quite sure how to do that. LOL I've never had to before.

Where is the SimPE file table located?



I think I'm giving up on recoloring pictures ever again. I did the 'fix' from the link you gave me (Thank you so much!! Smile ) did a few more recolors, but when I went into the game only one recolor showed up, the other two are nowhere to be found.

I'll just have to paste my pictures on wallpapers because at least those will show up.

I just hope this only affects the pictures, because I want to do some furniture recoloring and it will be super sad if I can't get those to work either.
(This post was last modified: 23-09-2014 03:32 AM by Puppetfish.)

#8 23-09-2014 
Puppet, how exactly are you making the recolours? Perhaps you've got some step of the process messed up that we can help with. Can you tell us exactly the process you're using?

#9 23-09-2014 
Oh sure. Shy

For Photostudio (I use this one mainly for my maxis picture recolors)
1. I open up SimPE.
2. Click on Tools/Object Creation/Photo Studio
3. Once the files are loaded I click Preview File, uncheck Flip Image, then scroll to whichever picture mesh I’m going to use.
4. I click Open…navigate to the image I’m going to use (which has been scaled ahead of time to whatever size the picture mesh is)
5. Once I make sure it looks okay in the Preview, I click Create, give it a snazzy name, and let the DDS do its thing.
6. Then I close the file and move on to the next.

For Object Workshop: (used mostly for custom meshes)
1. I open up SimPE
2. Go to Window/Object Workshop (I usually have to do this twice because it doesn’t open up the first time.)
3. Click Open
4. Navigate to the file I’m recoloring in my Downloads folder, click Open.
5. Leave it on Recolor, click Start, wait for it to load
6. Give my recolor a snazzy new name, click Save
7. Click on Texture Image, then tap Plugin View
8. Right click on Image, choose Export to get the png file, save it to the same folder my package file is in. (I don’t bother renaming it)
9. Go edit that png file.
10. Right click on Image in SimPE again, choose Build DXT
11. I usually don’t change anything here, except for the Sharpen. I’ve read in the official tutorial on MTS its best to change it to None, so that’s what I do.
12. Click on Open Image…select edited image, click Open again.
13. Click Build, let DDS do its thing.
14. I usually click on the other image files just to make sure they’ve all been changed before I click Commit/OK and File/Save.
15. Then I close it.

Before the UC it worked without a hitch! But now only one recolor shows up, sometimes none at all. Sorry for my sad state, LOL, but I’ve been trying to get these recolors to work for 3 days now and it’s just gotten a bit frustrating. Slap

#10 23-09-2014 
Hmm, it sounds like you're doing everything right. Definitely sounds like it's a UC issue if it all worked fine before. So. What would make only 1 recolour show up in game? If you have, say, 5 files in your download folder and only 1 shows up, maybe they're somehow overriding each other? Not getting a unique identifier, like how meshes all have to have a unique GUID, and ...what do recolours have? TGI? Fix Integrity thingie? Could it be something like that?


Sorry, that is a members only option