Walking through Fountains?
#1 26-12-2014 
Is there a way to alter the CRES so that my sims don't walk through a custom fountain when interacting with it? They don't walk through the fountain when there are no interactions because I've adjusted the footprints and updated the BHAVs. I think the issue is that animations are linked to the original smaller footprint.

BTW: Happy boxing day! Is anyone taking advantage of the sales?

Edit: I just tested again and they are walking through the fountain even though I have 7: Do NOT Use Maya Model Footprint in the BHAV init files. Hmm... sorry to bother you guys, it looks like I need to spend more time testing this out. If anyone has worked with custom fountains before and has any tips for me, I'd be grateful if you'd share them. I'll keep at it in the meantime Smile
nanashi, proud to be a member of LeeFish since Aug 2013.
(This post was last modified: 26-12-2014 07:29 PM by nanashi.)

1
#2 26-12-2014 
Try not allowing person intersection. You set this in the init as well, by clearing the flag "allow person intersection". (I'm on my netbook right now that has neither Sims nor SimPE installed, so I can't give you the exact line, but if you use the wizard I *think* you find it in the same drop-down menu as "do not use Maya model footprint". Check the other flag fields if you don't.)

2
#3 27-12-2014 
(26-12-2014 10:02 PM)NixNivis Wrote:  Try not allowing person intersection. You set this in the init as well, by clearing the flag "allow person intersection". (I'm on my netbook right now that has neither Sims nor SimPE installed, so I can't give you the exact line, but if you use the wizard I *think* you find it in the same drop-down menu as "do not use Maya model footprint". Check the other flag fields if you don't.)

Thank you I tested this.

I checked all of the BHAVs for that flag and couldn't find it. I can only add the flag, not clear it. Thanks for the tip though, I will use that going forward when I want my sims to walk through things!

0
#4 27-12-2014 
The allow person intersection is in the OBJD nanashi, I think? edt. Nope. Sad

2
#5 27-12-2014 
Nanashi, if you can wait a few hours, I'll be back on my simming computer later today and I can tell you exactly what the line is supposed to look like. Sounds to me like you aren't quite looking in the right place.

@celebkiriedhel, no, it's a BHAV and it goes in the init. Please trust me on this - it's something I do all the time.

4
#6 27-12-2014 
I do trust you Nix. I had it confused with something else - but that's why I added the nope on the end.

3
#7 27-12-2014 
Okay, I'm back home and on my simming computer.

You need to add a line to the init (with the "ins/true" button) that reads like this:
[prim 0x0002] Expression (My 0x0008 (flags) Clear Flag flag# Literal 0x0005 (allow person intersection))

Which looks like this in the wizard:
[Image: intersection.jpg]

Or, you could simply open the raw entry box (the " button next to the operands) and replace the string of numbers with this:
08000500000A03070000000000000000

I hope that's enough.


@celebkiriedhel, glad to hear it. Wink

4
#8 27-12-2014 
Hmm... I've updated it but still no luck. Can I ask you a huge favour? I'll upload my recent changes to the package file with your suggestions here and if you have the time and inclination, would you review what I've done in the OBJD, OBJF, CRES, and BHAV sections? Perhaps I'm missing something else besides the BHAVs?

I've always used the following tutorial: http://wiki.thesimsresource.com/images/5...tprint.pdf and learned about setting the Set Flag Literal 0x0008 Maya BHAV from here, and I never had problems before until now. However, to be fair this is the largest number of extended tiles I have ever created and my first time working with a fountain, so I could have messed up something without realising it.

If you are too busy, no worries, I totally understand! This request is really for anyone in the mood for troubleshooting Smile


.zip  nanashi-central_park_fountain-animated.zip (Size: 858.24 KB / Downloads: 82)

0
#9 28-12-2014 
Sure, I'd be happy to take a look. Smile Will dissect it and report back.

1
#10 28-12-2014 
Double-posting to make sure @nanashi sees it - plz don't ban me. Wink

So, I've looked and couldn't find anything wrong with it, BHAV, OBJD, OBJf-wise. The one thing that stood out to me is that you have "extend footprint" under Mesh & Graphics set to 1 when it's usually 0 (and was in the in-game fountains I checked for reference as well), but I tried changing it to 0 and it didn't help.

So I'm wondering if things might have gone wrong when you edited the CRES. You see, none of the tutes I've followed have said anything about changing the footprint in the CRES, and I've never touched it when adding tiles - and my items have worked just fine anyway. And the CRES can be extremely unforgiving if anything is wrong in it, so usually it's safer not to mess with it unless you're 150% sure what you're doing.

Will you hate me forever if I suggest you try it again, but skip all of item #2 in the tute? 'Cause that's really all I've got at this point. Sad

3


Sorry, that is a members only option