I did something really, really stupid
#1 23-04-2015 
Blush I clicked on lighting in C:/Program Files (x86/EA GAMES/The Sims 2/TSData/Res/Lighting and said open with notepad, before I realised it was the wrong file, then all the little icons in my downloads folder changed to notepad icons. I mentioned this to someone who said "that's easy to fix just click on any of them and say open with SimPE". I did that, now they all have the SimPE icon and every time I click on something it opens another SimPE window. Does anyone know if there's any way I can get everything back the way it was, without uninstalling and reinstalling everything, or if that would even work?

ETA: I should have mentioned I have windows 7 and it's the .package files that now open with simPE instead of "unknown application".

Thank you for reminding me Oeselian.

[Image: screenshot_zpsnvc0m6k6.jpg]
You can find more of my work at Mod The Sims and Plumb Bob Keep.
(This post was last modified: 23-04-2015 02:23 PM by Michelle.)

#2 23-04-2015 
Uninstalling and reinstalling would be a futile exercise, unless you started from scratch and reinstalled Windows itself as well. I don't recommend that, really.

For the only sure way *I* know of to fix this, you would have to go into the windows registry (using the "regedit" command), find the file association for the specific tile type, and remove it. However, I would *not* recommend this to anyone who has no experience with editing the registry, because the tiniest mistake can make a full reinstall of Windows necessary after all!

So I hope that either you know how to deal with regedit, OR that someone else knows another - and hopefully simple - way to help.

#3 23-04-2015 
Thanks BO baby, think I better wait to see if someone knows another way because I have no idea about "regedit" or the windows registry.

#4 23-04-2015 
Did i understand corretly - all your .txt files open now with simpe? Then you should set notepad your default opener for txt files

#5 23-04-2015 
@Oeselian, it's not the .txt files it's all the .package files that use to be "unknown application" that are now opening with simPE.

#6 23-04-2015 
@Michelle if you have Win 7
I found this link: http://www.sevenforums.com/general-discu...ation.html
which uses cmd command - scrap that,it's not going to work in this circumstance
and this little program(works for vista and 7): http://www.winhelponline.com/blog/unasso...s-7-vista/ - it does registry edit for you

Off-topic:Why I can't spell today?Sad
(This post was last modified: 23-04-2015 03:39 PM by Oeselian.)

#7 23-04-2015 
Ooh the program Oeselian linked to sounds like a good one to me.

* fanseelamb downloads for possible future use

Or you could just associate them with notepad or Clean Installer or something that wouldn't take eons to open if you accidentally double-click them. Personally my package files are associated with SimPE and I don't have a problem with that.

#8 23-04-2015 
(23-04-2015 02:04 PM)Michelle Wrote:  @Oeselian, it's not the .txt files it's all the .package files that use to be "unknown application" that are now opening with simPE.

Is it only the .package files? So what's the problem then? I set my system up like that on purpose, because SimPE *is* after all the ideal program to open .package files.

#9 24-04-2015 
@BoilingOil, Oh! I didn't know you could do that...but I never open then by clicking on them. So it's okay to zip the files and upload them, they're not corrupted and it's safe for people to download and install them in their game?
(This post was last modified: 24-04-2015 07:22 AM by Michelle.)

#10 24-04-2015 
Ohhh that's what you were worried about? Yes it's perfectly safe. Changing the file association doesn't change the actual files at all, it only changes what program your own computer uses to open them. In fact most people who create Sims 2 content probably have SimPe associated with their package files.

I had assumed the reason you wanted to change it was because you were constantly double-clicking the files and having to wait 20 minutes for SimPE to open or something like that. Big Grin


Sorry, that is a members only option