Maxis hat hair
#1 22-07-2015 
Hello fish friends! I'm posting this here because I think fansee is our best Maxis hair smartie but I gladly welcome anyone's help Smile
I retextured/recolored a hair, very uncharted territory for me Blush

[Image: hathair_brown_zpslmst9pyr.jpg]
It's the FT bolero hat...

[Image: hathair_brownswim_zps4soeciqa.jpg]
and hat hairs automatically add a swim/sleep non-hat 'companion' hair

Replacing the above texture with the correct hair texture is not the problem. I just want to remove the swim-sleep hair entirely. (I know simmers w/o Seasons will have their sim sleeping and showering in their hat, apologies to them.)

When I remove the CASIE_amhairclosecrop resources from the Property Set, I end up with this sad result:
[Image: hathair_black_zpsiaeaiypz.jpg]

I have searched online and even SimPE-peeked at other maxis hat hair recolors to see if whoever did them knew how to do this, I can't find any info! Maybe no one recolors Maxis hat hairs for this very reason?

Would using Cat's Hair Binner be part of the problem? I use it to remove toddler-teen and link grey to black (the elder hat hair has the correct texture after removing the property set by the way). Would removing the CASIE_amhairclosecrop before binning them make a difference?

Any help is greatly appreciated, thank you! Heart

#2 22-07-2015 
Ummm.... yeah. Maxis hat hairs are weird. I tried making my own recolour of that hat for testing purposes just now and instead of the swim hair disappearing when I binned it (with the SimPE binner) the hat disappeared instead. Hahahaha yeah.

But I think it's either one of two things. Either the hat is looking for a texture you deleted OR the hat is looking for a bumpmap you deleted. Or maybe even both.

If so you can fix that in the Material Definition (TXMT). First try deleting the reference to the bumpmap. It's the line called "stdMatNormalMapTextureName" in the Material Definition. Just select that line and press "delete" on the right. Commit and save. See if that fixes anything.

If not, try changing which texture the hat is looking for. It's the line called "stdMatBaseTextureName" in the Material Definition. There's a code next to it that refers to the texture. You want to change that code so it matches the code of the proper texture. Look for the proper code in the Texture Image (TXRT) of the right texture. Copy the whole "##0x5f1ea166!0xfb71d642" looking part but leave out the "_txtr" ending, and paste that code into the Material Definition. Commit, save, test.

I hope that makes a little bit of sense? It's probably confusing. If you need more clarification or pictures or want me to have a look at the file, just let me know. Smile

#3 22-07-2015 
Ah that makes sense, I thought it must be something like that! I will work on it this evening, thank you very much for taking the time to tell me what to do and how to do it! (I suspect you figured out stuff like this on your own thru trial-and-error since there's like zero information on it anywhere?) Celebrate Thanks again vamp

#4 22-07-2015 
Ah yes, all trial-and-error-error-error, and sometimes posting questions on MTS or leefish when more help was needed. I also learned stuff in the MTS chat rooms.

Your hat texture looks nice BTW. I hope you get it worked out, and if you need more help just ask! vamp

#5 22-07-2015 
FANSEEEEEEEE! It worked first try deleting the bumpmap reference Celebrate I knew you were a smartie, thank you so much!
*adds very creative and technologically advanced border to gif*


[Image: tumblr_n8qzylOJss1tg9y5go1_500_zpsnigwrdmw.gif]


#6 22-07-2015 
EEEEEEEEEE!!!! AWESOME SHASTA!!!!!! CelebratevampCelebrate

And thank you for the very special gif (with advanced border) OMG. Heart Heart Heart

#7 23-07-2015 
* leefish raises an eyebrow at the border Tongue


Sorry, that is a members only option