Correct SimPE Downloads?
#1 24-09-2015 
Hi there! My computer died so I've been gone for a while but recently my Hubby bought me a new one so I am back again!

I am in the process of re-downloading all of my Sims 2 stuff and went to the SimPE page here:

Unfortunately the link for the Microsoft.NET framework version 2.0 is invalid, so after a google search I found this: Is this the correct one to use? I don't want to put a bad or wrong version on the new computer.

Also, I noticed there is now a new version of SimPE on the downloads page, a SimPE Light. What are debugging tools and do I really need them? Any help sure would be appreciated!

Smile Thanks!


#2 24-09-2015 
Chances are your new computer already has what it needs to run SimPE. I would just try installing SimPE without the extra .NET framework and see if it works. Mine did.

I don't think you need any debugging tools. The "QA" version is the latest one. I believe it's the only one that's compatible with Mansion & Garden Stuff.

#3 24-09-2015 
Debugging tools may be useful if you're going to do your own modding, but only *then*. Otherwise, I wouldn't bother with it.
And @fanseelamb is right: the QA version is the recommended version to get for any game, but if you have Mansion & Garden Stuff, then the QA version is *REQUIRED*. Smile

#4 25-09-2015 
Thanks! I downloaded the light version. But now it's giving me this message when I run it.


SimPE detected a new Expansion Pack for "The Sims 2".

This SimPE Version does only work with Game Versions up to "The Sims 2 - Celebration Stuff". Newer Game Files might cause Errors when opened with this Version of SimPE!

Didn't there used to be a patch for Mansions & Gardens?


#5 25-09-2015 
You have to get the QA version.

#6 25-09-2015 
Thankfully I am a packrat and managed to find the QA version on a disc. Someone sent it to me, I think. Do you happen to have the link to where it's at?

In the mean time, I am so excited! My SimPE runs without the .NET framework! Thanks so much for answering Fanseelamb and BoilingOil! Smile

#7 25-09-2015 
@Puppetfish, oh Puppetfish... We all tell you to get the QA version, and then you THANK us, implying that you understood. And *then* what do you do? You go and download the LIGHT version... Why?? Of course that was not going to work, my dear silly-fish Tongue

Have you not tried asking google about SimPE? When I entered "SimPE" in the search-bar, Google immediately sent me to And the TOP item on that page is the SimPE 0.73.44 QA !!!. EXACTLY what we advised you to get. I hope you're going to get it to work correctly this time, dear. Tongue

#8 25-09-2015 
Back on my old computer simPE always gave me that message. I was told to uninstall it and re-download it, which I did at least 3 times with the same result. I also put the patch on 3 times. Then I moved to my 'new' computer, installed the same version and patch and never got that message, so I don't think it's always user error.

#9 26-09-2015 

I double checked the link I had and apparently it was NOT to the correct download! ha ha

That's what I get for trying to download stuff late at night!! Wink

Thanks again!


Sorry, that is a members only option