Problem with Screen Capture software, Windows 10, and Sims 2
#1 08-01-2016 
Hello! I recently upgraded (I use the term loosely) to Windows 10 and got my graphics and smooth edges working (thankyouverymuch) but am having an issue getting screen caps with my capture programs. I play in full screen but when I am running my game and attempt a screen shot, all I get is my desktop. I have tried Gadwin print screen (verson 4.7 and the latest 5.4 which is supposedly Win8 compatible). I also tried Greenshot. I'm wondering if anyone has experience resolving this? I could probably use windowed mode and have tried that but the only way I am going to get a shot without capturing the background or the window itself is to capture it with the rectangle and I am far too spoiled and lazy to have to do that Wink

TL;DR Has anyone found a program or way to capture full screen game shots that capture the game and not the desktop?
gfitz, proud to be a member of LeeFish since Jan 2016.

#2 08-01-2016 

I'm always in windowed mode, and I just use printscreen when I'm testing. ALT-Printscreen captures just the active window. However when I'm playing I use SimCamera which is similiar to Gadwin and Fraps and have had no trouble with full screen captures. So I'm not sure why you're having a problem. Sorry.

Maybe someone else who takes screen prints in a more sophisticated way can help.

#3 08-01-2016 
I'm having similar problems even in Win7. No matter what creen capture program I use, none will ever take fullscreen shots of TS2. Gadwin fails, Greenshot fails, and another one I tried two weeks ago (I forgot the name) failed as well. Three years ago, Gadwin would still work, if you switched off the Aero theme and some other function that I don't remember the English name of.
But that no longer works now. I might like to look at SimCamera, see if that performs...

#4 08-01-2016 
@celebkiriedhel I hadn't thought about Fraps...and I hadn't heard of SimCamera. I can try those out and see.

I used to use an older version of Gadwin with Windows 7 so I had options for full screen, active window, client window or rectangular area. If I could get the new version to not include the menu bar or background I would go back to windowed. I just haven't figured it out yet.

Thank you for the suggestions though!

@BoilingOil I was able to use Gadwin 4.7 with Windows 7 and it worked beautifully. Somehow a friend of mine got the game to disable aero when the game launched but I don't know how. It did occasionally capture the desktop so I always check before happily snapping away. I'll have to find out what that setting was...
(This post was last modified: 08-01-2016 07:24 AM by gfitz.)

#5 08-01-2016 
If you are using a laptop, hold down Fn key and then press Print-Screen key and it should take the capture.

If you are using a desktop, right click on the game icon (depending on whichever latest expansion/stuff pack you have, right click on the one that you use to open up the game normally), open properties,go to Compatibility tab and disable desktop composition. After that the Print-Screen should work.

#6 08-01-2016 
Desktop composition! That's the translation of the function that I meant but couldn't remember the English name of; its dutch name is "Bureaublad Samenstelling".

Anyway, because I didn't know how to adjust the shortcut, I've always manually disabled Desktop Composition as well as the Aero theme. And still - with the latest version of either Gadwin or Greenshot - no dice. But I'll try the proposed adjustment to the shortcut, and see if that does any good. Thanks to you both, @leefish and @gfitz. :-)

#7 08-01-2016 
Yea, I failed to read correctly, the"fix" is for windows 7, but I think it will be the same in windows 10. Maybe. It would be good to know, as I remember this driving me mad when I first got Windows 7.

#8 08-01-2016 
I have Windows 10. I use FRAPS and play in windowed mode. FRAPS takes a pic/vid of the game window and nothing else - no title bar, nothing behind the window, just the game itself. Works great.

#9 08-01-2016 
Yeah, THAT is the problem: In windowed mode, everything works as advertised. But I do NOT want to play in windowed mode. I *exclusively* play in full screen mode to avoid distractions. And thus, my screen shots must also be taken in full screen mode. I'm very particular about this.

#10 08-01-2016 
Oh, yeah, sorry BO! My post was aimed at gfitz who said they'd play in windowed mode if the screenshot program worked. I don't use FullScreen mode myself. Have you tried FRAPS? It might work in FullScreen mode. I've tried a couple other screenshot programs and didn't like them, but I love FRAPS. It's designed specifically for games and is easy to use.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option