Graphics problem on max resolution with TS2UC
#1 11-01-2016 
Hello everyone! I'm having a problem with the graphics in The Sims 2 Ultimate Collection. I have Windows 10 Home 64.

I have dual GPU NVIDIA 860M and Intel Graphics 4600. I installed the Graphic Rules Maker with max resolution 1920x1080 with the texture fix (and without it) but when I load up the game and change it to 1920x1080 the game won't save the change so I have to press the win key to exit the game and when I go back it accepts it but it does not change the resolution (it just asks me if I want to save the changes and I press yes but it's still in low resolution). When I load up the game again It is in 1920x1080 but it's stuck in the middle of the loading screen and I have to press the win key again to exit the game and it crashes with "This application has crashed. It will now be terminated."

I tried to do it manually with the texture fix and without texture fix, followed this guide but it's still the same. I make sure that the game is run with my NVIDIA card but nothing seems to be working.

The only way that it is working in 1920x1080 is if I load the game with my Intel Graphics and it is all fine except it's slower and I want to use my NVIDIA card to play it. It works with my NVIDIA card if I delete the userProps.xml from EA GAMES folder but I have to do it every time so my neighborhoods are reset every time. Strangely If I set my resolution to be 1600x900 the game works and does not have any issues but I really want to make it work in 1920x1080. I'd really appreaciate your suggestions. Thank you in advance!

I repaired the game via origin so it brought back my original Graphic Rules and Video Cards files and deleted EA GAMES folder from My Documents.
VoodooBG, proud to be a member of LeeFish since Jan 2016.
(This post was last modified: 11-01-2016 02:50 PM by VoodooBG.)

#2 11-01-2016 
Please provide your config log txt

#3 11-01-2016 
Hey, thanks for the quick reply! Here is my vanilla file (without changing anything to the Graphic Rules and Video Cards files)

Attached File(s)
.txt  DRAGOMIR-config-log.txt (Size: 9.5 KB / Downloads: 35)

#4 11-01-2016 
Ok, see if you can follow this :

That will show you how to make a video sgr file and where to put it.

For screen size try this :

#5 11-01-2016 
Ok so I did it and loaded up the game I had the options for 1920x1080. Changed it but it didn't change (it was just loading) I pressed the win key to go back to the desktop and went back to the game and it asked me whether I wanted to save the changes and I clicked yes but it was still in 800x600. I exit the game and loaded it back and it is in 1920x1080 it's all good but now the Smooth Edges options and the Shadows one are in grey. Here are my files with the changes
Graphic Rules.sgr
Video Cards.sgr

.txt  DRAGOMIR-config-log.txt (Size: 10.31 KB / Downloads: 47)

#6 11-01-2016 
are those options in grey when you are in lot? As far as I know you have to be in lot to make those changes. Also, make sure you run the game as admin.

#7 11-01-2016 
Yes, they are greyed in a Lot as well. I just run the game as admin and it's still the same. Sad

EDIT: Actually Shadows options are enabled, only Smooth Edges is in grey.

#8 11-01-2016 
It could be that your edges are already smooth. Please take an ingame screenshot with all your settings at high and post it here.

#9 11-01-2016 
I'm pretty sure they're not.

[Image: image.jpg] [Image: image.jpg]

#10 11-01-2016 
Hmm,no they are not. Please provide a screenshot of your graphics settings.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option