Sims 2 UC Crashing Windows 10
#1 18-01-2016 
  • Registered
  • 2
  • 3
Hi there!

I just made an account here today because I literally have nowhere else to turn to. I had no problems with TS2 UC on Windows 10 back on my old laptop, as I would just follow the steps and change my GraphicsRules, but ever since I got a new laptop playing TS2 UC is becoming impossible. I have a dual card (Intel/Nvidia), and I have no idea what to do. I tried forcing the game to run on Nvidia like the dual card fix said to do, but I can't play it in Windowed Mode or else I get this message "Direct3D returned an error: E_INVALIDARG! The Application will now terminate". I prefer playing in windowed mode, so I forced the game to go back to playing with Integrated Graphics. I installed the Intel GraphicsRules, edited it to be able to play in 1920x1080 resolution, and it seemed to be okay. Anti-aliasing was turned on, the texture memory was 32MB but I got it to change to 2048MB. Game ran smoothly until I tried to go into Family Bin. It'll load but then the music will start to loop, and it'll tell me that the game has crashed. I've tried as much as I can to try to fix this, but I'm on the verge of giving up. I'm not very good with tech stuff, so this dual card thing is really confusing me. Bodyshop also doesn't open at all either. I thought it was because of my Downloads folder, but my game was working fine before with the same folder on my old laptop, so that couldn't be it.

I'm attaching my config-log.txt and it's the latest one that I have. Just ran the game so it's fresh. If anyone can help me out with this, I would be eternally grateful!

Attached File(s)
.txt  DESKTOP-TPQ8AQR-config-log.txt (Size: 10.43 KB / Downloads: 65)

1
#2 19-01-2016 
@trumannb Hi there TrumanB

Your graphic rules is fine - however your Video Cards.sgr needs to be set up.

Video Cards.sgr - INTEL - 0416

Download this, and un-zip it into

WHERE TO INSTALL FIXES:
In the Program folders:

\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\CsConfig\
MUST BE INSTALLED IN BOTH FOLDERS

For some reason UC and Windows 10 for most people requires the Video Cards.sgr to be set up or it causes the error that you have.

Regarding the windows/full error - that's something I haven't found a solution for.

0
#3 20-01-2016 
  • Registered
  • 2
  • 3
Yay! I can open Bodyshop and CAS now! I have the black bar under my sims in CAS, and I know that I have to turn Shadows on 'Medium', but the option is greyed out for some reason. Any way to get around that?

0
#4 20-01-2016 
@trumannb Yup - there is! You can leave the shadows where they are - and go to MTS, there is a fix for the sim shadows so you can leave them on. Smile

Go to MTS - [UPD 2JAN16] Sim Shadow Fix by NOPKE

Download that fix, and put it in your Download folder, and you're set! Smile

Alternatively - this is the thread that addresses the Black Shadow Box

0
#5 24-01-2016 
  • Registered
  • 2
  • 3
Yay they work!

The game runs great now, but occasionally I'll get this weird pop up that says "Display driver Intel HD Graphics Drivers for Windows 8® stopped responding" and then it proceeds to say the issue was resolved. I've had this pop up for awhile now ever since I had Windows 10, and it's becoming annoying at this point. I don't really know what to do. I'm assuming it has something to do with my Intel drivers, but I'm not too sure and I don't want to fiddle with something that isn't causing too much problems. Any idea what this could be?

1
#6 24-01-2016 
@trumannb

Is it exclusively with Sims 2? or the whole system.

That could be a few things -
1. It could actually be a problem with your Graphics card - have you updated the drivers since you got Windows 10? Or it could be a problem with your hardware - a heat problem.
2. It could be a problem with Windows 10 and your graphics card talking to each other - getting out of sync. I have no idea how to fix that one - except maybe update your graphic card drivers.
3. It could be a problem with your game - that the card is running too fast for the game, so it's getting out of sync - although that message sounds more like it's a graphics card/os problem.

So - what I'd do if it was me -
1. Update the drivers for the Graphics Card.
2. Run a dxdiag to check that it's all good.
3. google that message and see if other people have been getting it, and what they've done.

0
#7 24-01-2016 
I did some googling and came up with this:

http://www.drivethelife.com/windows-driv...vista.html

I have no idea what that "driver talent" thing is and feel wary about it. However, there are a lot of comments and replies and I would suggest a good read through.

1
#8 04-02-2016 
It's been two weeks since Trumanb has been back to this thread. I'm going to call it resolved until they return.

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option