No shadows avaliable,weird flickering, no smooth edges
#1 27-01-2016 
  • Registered
  • 3
  • 3
Hello there,
First of all, I'm really dumb when it comes to technology and stuff so please, bear with me. I looked into FAQ topic and I checked my config-log file, which can be find enclosed down below. It seems pretty okay to me so I don't get where the problem is. OR MAYBE IM JUST BLIND ;_;
My graphic device is Intel R HD Graphics, no number, nothing that I know of (probably the worst device ever? is it even possible for it to run the sims with smooth edges enabled on?)
no other options when it comes to graphic card.. this is all i have Dodgy
I don't use the origin special edition.
Recent AP: Mansion and Garden stuff
Recent graphics driver version
My operating system: Windows 8.1 64-bit (after so many years of using Win 7 on my older laptop, this has been HELL so far)
Futher specification:
Processor: Intel R Celeron R CPU N2840 @ 2.16 GhZ 2CPUs ~ 2.2 GhZ
Memory: 4096 MB RAM
Okay, second, English is not my first language, so then again, maybe I missed something important?
My problems are, like I mentioned in the title:
No shadows option avaliable
Weird flickering (like a weird shadow or something, happens when i move the camera around, happens in the neighbourhood and as well as on the parcel)
No smooth edges either
I tried to fix some issues with Graphic Rules but nothing works. Now that I think of it, I had to open it via notepad and when i tried to save it, it told be it can be only saved as a "txt" file but when i look at it, it's still a sgr file but with a notepad icon. But it can't be that easy, can it? -.-
I'm so sorry if I missed something but I think i tried everything? Sorry if missed something important T^T Also thanks in advance. It's a blessing I even found this forum.

EDIT: Also i noticed some weird black squares when sims are inside their house like what??

Attached File(s)
.txt  LENOVO-PC-config-log.txt (Size: 10.32 KB / Downloads: 33)
.rar  Graphics Rules.rar (Size: 7.16 KB / Downloads: 26)
(This post was last modified: 27-01-2016 02:56 AM by leeari.)

#2 27-01-2016 
Hi @leeari

Looking at this you need the following things:

Download Intel Graphics Card fix
Download Video Card - Intel - 0f31

You need to put them in the following 2 folders:

\Program Files (x86)In the Program Folders\EA\The Sims 2 - Mansion & Gardens\TSData\Res\Config\
\Program Files (x86)\\EA\The Sims 2 - Mansion & Gardens\TSData\Res\CSConfig\

That should fix it.

Opening and closing the graphic rules.sgr with notepad is also what I do. If you have 'hide extensions for known types' unticked (i.e. turned off) - you'll see if it's really a txt or sgr file. if your extensions are hidden. Then it's likely that it's been saved as a graphic rules.sgr.txt which displays as a graphic rules.sgr, but it's type is txt - which means that it won't get picked up.

The Intel ® HD is perfectly capable of doing Sims 2 in High Resolution. However, in the days when Sims 2 was first started, they weren't so Maxis put in coding that stopped the Intel cards from even being considered for High Resolution. What I have done in mine, is turn off that coding, and have them decided on their merits.
This is probably why no matter what you did, it didn't change anything.

#3 27-01-2016 
  • Registered
  • 3
  • 3
Dear Kiri,
I want to thank you so,so, so, soooo, so much. When I went to the game, at first it looked like it didn't work, I was in the neighbourhood view and the weird flickering-thing still happened but then I picked my family and went to graphic options and guess what, smooth edges and shadows option is now avaliable Celebrate
Thank you so, so much again! Also, what confuses me is that when I picked the smooth edges option and set it to high, the flickerings immediately dissappeared... Huh
But there is still one thing that bothers me,
those ugly black square-things that appear when a sim is standing on the floor (note: it only happens inside the building)

I enclose you a screenshot for a better look
[Image: image.png]

#4 27-01-2016 
#5 27-01-2016 
The flickering stopping when smooth edges on max is a known thing - we like to think of it as a fix. Smile

If you go where Lee has pointed you, it will point you to a fix that you include in your downloads folder that will fix the shadow box.

#6 28-01-2016 
  • Registered
  • 3
  • 3
Thanks Leefish! Everything's solved now!
Again, thank you so much for your help, Kiri!
You guys are awesome! Smile


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option