Sims 2 and Windows 10 crashes
#1 01-02-2016 
Hi everyone! I installed Windows 10 on my desktop a couple days ago, and I have realized that after 10-15 minutes of gameplay, the game just crashes. The graphics are just fine, great resolution, shiny pools and lakes etc...just can't play for more than 10-15 minutes...which is frustrating when it takes nearly 30 minutes for the game to start up and go to the neighborhood. I have updated my graphics card drivers, deleted the cache and thumbnails from before, but nothing helps. Thanks so much for your help!

Attached File(s)
.txt  SARRA-PC-config-log.txt (Size: 10.22 KB / Downloads: 56)
Spiky_Kitty, proud to be a member of LeeFish since Jan 2015.

0
#2 01-02-2016 
Download VideoCards-Radeon-683d

You don't mention which version of Sims 2 you've got - ultimate collection or from the DVDs

For some reason, Windows 10 needs the Video Cards to be set up with the correct value. So anyway - this is a corrected version of Video Cards.sgr with your card in it.

That should help.

1
#3 01-02-2016 
Oops sorry Smile I have all of the sims 2 CD Roms up to Mansion and Garden Stuff. I will try this file and get back to you with the results. Thanks so much!

ETA: I just realized, I'm not sure where to place this file. Sorry for being a dunce, but could you direct me on how to install the file? Thanks again! :-)

0
#5 01-02-2016 
Thanks leefish! I installed them and I will go test out my game. I will be back later on with my results :-)

1
#6 02-02-2016 
Update: Ok so I was able to play for an hour with no issues! No crashing or anything! Thanks so much :-)

3

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option