Graphics Rules Maker force texture memory
#1 08-02-2016 
  • Registered
  • 2
  • 4
I posted this over at MTS and was told to come here.

Just reinstalled Ultimate Collection and would like to get back into playing it on my new PC with a GTX 980 Ti. Of course, I downloaded the wonderful Graphics Rules maker tool and used that to add my card to the database, disable sim shadows, and force my resolution. But should I change the "Force texture memory" section? The website says you can do this for high quality graphics, and set it to the Texture Memory listed under the Device Info tab, which for me is 4095 Mb. Right now I have it set to Do Not Force. Should I set it to my full 4085 Mb or is that pointless/harmful? I read somewhere that if you use a card that isn't originally in the database it'll force it to 32 Mb, and that'll result in low quality textures. Thing is, I don't know how to tell whether it's doing this for me. Help would be appreciated

Also is there anything I should do outside of Graphics Rules maker to keep Sims 2 from doing anything bad to my GPU/enhance the experience?

I read a post here that said to do the CPUCOUNT:1 thing. DxDiag says I have 8 CPUs. I assume that's the same as Cores, and that means I should use this fix?

Final question: in my config file it shows me as having 1024 memory and 1024 free memory. I have 16 GB. What's the deal there?

Windows 10 64 bit


.txt  DESKTOP-G6TPL7C-config-log.txt (Size: 10.28 KB / Downloads: 54)
(This post was last modified: 08-02-2016 03:03 AM by xcascam.)

0
#2 08-02-2016 
@xcascam

Hi - you don't need the force texture memory fix. You don't really need to anything else.

If you have a look at your config-log.txt and go down to the line called 'Texture memory' it will tell you if you need it or not.
Texture memory: 4095MB <-- this is yours, if you needed the texture memory fix it would say 32Mb.

What the person told you is incorrect - it has nothing to do with if it was a new card or not. It has everything to do with what version of Windows you are using and how up to date it is.
Microsoft made a change to the operating system which meant that the texture memory was located in a different place. Some graphic cards can find them, some can't.

With the CPU Count, you *may* need to do it - but test your game first for lag before you do it. If you don't have lag, you don't need it.

Don't worry about the memory thing. Although it says 1G, that doesn't have anything to do with how much the game actually uses. As a 32-bit program, Sims 2 can only use up to 4G. So for your 8G, it's only using half of it. There is no way of updating it to make it more RAM, apart from re-writing it into a 64-bit program. Which is out of my expertise.

0
#3 08-02-2016 
  • Registered
  • 2
  • 4
Thing is, that config file was generated after I already used the override. sorry, I should've been more clear on that. Without the overridea it says 32 Mb. I just wasn't sure whether to set the override to my full GPU memory or something like what the creator of the Graphics Rules Maker did, 1024.

I will take the rest of what you said and run with it. I do actually have 16 Gb of RAM, but I guess that doesn't matter for Sims 2.

1
#4 08-02-2016 
@xcascam That's fine then. It's done the right thing.

The full graphics is fine as is the 1024 - as long as it's over 32Mb, it will be set to hi-resolution. Mine is set to 1744Mb which was what mine was before the Windows O/S change was made on my older graphics card. What these values do is set up the things like whether it is hi or lo resolution, whether there is shadows, etc. It doesn't actually specify what memory the program has to use. Hence the reason why we don't worry about the RAM being set to 1G. All that tells the program is that there is enough RAM to do hi-res. Not that the game can only use 1G.

0
#5 08-02-2016 
  • Registered
  • 2
  • 4
Wonderful, thank you. Sorry to keep bombarding you with questions and this isn't really related to graphics, but do you know if there was any kind of recent update that changed the executable for the ultimate collection? mine sits on my desktop as it always has but there is no tab for compatibility, so I have to troubleshoot it to get it in administrator and windows xp sp3 mode. I don't seem to remember it being this way before.
otherwise, thank you for relieving one headache. Now to work on getting ts3 to work right.

0
#6 08-02-2016 
That's a windows 10 O/S change. They did it in the last few updates I think. It doesn't happen with all programs, just with 32-bit ones *I think*.

Doing the Troubleshoot compatibility is the only way to get to it nowadays.

I don't have Windows 10 - just Windows 7, and that still works with a compatibility tab.

When I see what they do with Windows 10, I hug my Windows 7 tightly and promise to never let it go.

1
#7 08-02-2016 
  • Registered
  • 2
  • 4
Ah yes, that would make sense.
10 isn't as bad as 8 IMO, it's more refined and less fugly. But I sometimes long for my old Windows 7 as well.
Thank you for your help.

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option