Major graphic card issues, game only runs in windowed mode
#1 19-02-2016 
  • Registered
  • 4
  • 6
Hello wave

first a big thank you, I'm really glad I found this great place, lots of information available. Smile I already made some progress with my issues, but I have come to a point now, where I don't know, what else to try.

But maybe I start at the beginning... I have a brand new desktop computer (i5-6400, 2,7 Ghz (4x), 8 GB RAM) with Windows 7 and a Geforce GT 730 graphics card. I installed all EPs, 2 SPs + M&G, plain old disk versions from back in the day. Fresh OS install, fresh game install, no CC, nothing. At the very frist start of the game I get a black screen, no cursor, no keyboard reactions, no errors, no possiblities to get back into windows. The only option is to press the power button and restart the system.

What I did so far:
Graphic card drivers are updated, I set the 3D options for the game in the Nvidia control panel, so that it uses the graphics card. Various options in compatibility mode, Vista, SP Service Pack 2, XP Service Pack 3, set to run as administrator. No change.
When I found this site, I first used the graphics rules maker to add the card to the data base. I didn't change anything else. Now, no black screen, but error about DirectX9c compatibility. Seems like the problem is indeed my graphics card and not anything else.
I followed further instructions and installed the graphic rules fix found here on the site. Result: Black screen, back to square one...
I ran the game in windowed mode. Sucess! It's running for the first time.

I start Pleasantview, everything seems fine, the generates pets, weather and so on. Then I enter a household and after a couple of moments - Crash! Power off, automatic system restart. The crash was so bad, that it couldn't even load windows on the first attempt. After the second reboot, Windows runs again. Second try for the game. It start, it loads Pleasantview, but then there is the introduction video, and not at once but after a couple of moments - crash again, power off, automatic reboot. This time I can start Windows at once, though.

I try the game again and this time everything works fine. I can play video sequences (the neighbourhood introduction and during play). I played two households for a bit, no further crashes. Still, I'm not sure, if that is not just accidental. The graphics card does seem problematic. Plus, I really really don't like, no, I hate playing in windowed mode. Are there any possibilities to make the game run full screen? Do you have any idea, what's going on the the graphics card at all? Can it be better configured to prevent crashes in the future? Any ideas much appreciated. Thank you for your help!

Attached File(s)
.txt  config-log.txt (Size: 10.3 KB / Downloads: 37)

0
#2 19-02-2016 
@asoivel

The running only in windowed mode/only in full-screen mode problem is something we haven't found a solution for. If it's running in windowed mode, that's kind of what you're stuck with.

With your brand new computer - it sounds like you need to update your graphics driver - that would be a good start.

Also - in the folder where your config-log.txt (which looks perfect, btw) there may be some text files with "exception" in the title. If you do have one of those - could you upload it for me. That's going to help find what the problem is.

I'd also like you to run system check, on your computer.

To do this - open up File Explorer - -select the drive that you have your sims on, Right Click on it and choose properties, select the tab 'tools' and click on 'Check now' in the Error-checking section.
It will take quite a while, and you can't do anything else while it's happening.

My suspicion with it happening and causing a reboot, is that you've got a corrupt sector that is being selected on your hard drive when the game goes. The error-checking will find it if it's there and mark it so that it doesn't get used again.

0
#3 20-02-2016 
  • Registered
  • 4
  • 6
Thanks for your reply!

No full-screen mode, oh no Sad I was really hoping, there is something to be done... still, at least I got the game to run at all. I really regret, that my laptop died. It never had any problems running the game.

Graphic drivers are up to date, that was the first thing I did.

I couldn't find any .exception files in /logs. Maybe I need to play the game longer for something to be generated? Any other place I can look for?

I'll set the drive check to run tomorrow, when restarting. I formated and partitioned the drive (SSD) before I installed the OS, I wouldn't have expected any problems there. But you're right, it's always best to check that there are no errors...

1
#4 20-02-2016 
If there's no exception log, that means it wasn't the game that shut it down, it was the operating system.

Since it was the operating system, there may be a log text file in the root drive. If it was because of the graphics card, a log file may be in the graphics folder. (I'm using Radeon, so I have an AMD folder). You will probably have an NVidia folder floating around somewhere, and if you're lucky there'll be a log folder or an exception file in there.

With the full screen/windowed thing - you can change your windowed mode to windowed with the full size of your screen - I use that, and find it's pretty much like full screen.

0
#5 20-02-2016 
  • Registered
  • 4
  • 6
Unfortunately, I couldn't find an exception log anywhere on the computer. I check the NVIDIA and the Windows folders and also used the search function. The NVIDIA folder didn't have any log folder at all, no idea, where errors are dumped. Huh

Ah, I didn't know, you could change the size of the window in windowed mode. I had tried to tick the maximise option in the properties tab, but that didn't do anything, so I thought I was stuck with that small window. Apparently, you have to change the resolution in game, so now it's really full screen size. That's much better, I can definitely live with that. Just edge scrolling doesn't seem to work in windowed mode, but I hope that after some time I will get used to it.

2
#6 21-02-2016 
@asoivel

Hmmm ok. Well see how you go with the crashing issue, let me know if it keeps crashing. In the meantime I'm going to do some research. I can't promise anything because some problems don't come up on google, but I will do my best.

0
#7 21-02-2016 
The first thing that popped into my mind after reading every post: PSU. Is it possible that it's simply not powerful enough?

2
#8 21-02-2016 
It can happen, @mustluvcatz. Too many unneeded items drawing power from it is a possibility as well. Or even a single item with a slightly wobbly power cord that causes output to fluctuate. All these things can cause random crashes. However in *most* cases - though not all - these would cause the entire system to reboot.

1
#9 22-02-2016 
  • Registered
  • 4
  • 6
Hm, how can I check if the issue is connected to the PSU? I do keep on having issues, but that was in Sims 3. The crashes behave in the same way, though. Black screen, reboot. Sometimes I have to reboot twice for Windows to work again (most of the times this happens automatically). I also cannot find a common trigger. Sometimes during lot load, sometimes during game play, once it happend when the game was paused and I wasn't doing anything at all (that was also Sims 3).

0
#10 22-02-2016 
I had three or four extra fans in my system, the decorative kind with neon lights. I ended up disconnecting them all, and the problems ended. I'm still not certain if it was a wobbly cable or too many devices that caused the problem.

Some devices you could temporarily disconnect to see if that improves system stability. But either way, it won't be an easy process to find the culprit.

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option