Sims 2 not compatible...
#1 17-03-2016 
  • Registered
  • 4
  • 5
Hello, I am having some trouble starting up my Sims 2. When I start up the game it says 'This application is not compatible with the installed operating system. Please upgrade to Windows 98SE, Windows 2000 or better.' I wonder if changing the video card is causing this (I was trying to fix Sims 2 graphics for Windows 10. I have the CD/DVD). The only solution I can think of is uninstalling everything (ugh for the 100th time) and try again but I'm trying to avoid that solution.
Thank you.

Attached File(s)
.txt  DESKTOP-UOS4K8P-config-log.txt (Size: 7.68 KB / Downloads: 86)

0
#2 17-03-2016 
@Ciaosu Is your windows windows 10? It says Windows NT 6.2 which I haven't seen before.

In the meantime - It looks like the last thing that was run was bodyshop back on the 8 Feb. So I can't tell from the config-log.txt what expansion packs you've got. You say you are running it from the CD/DVD - Do you have any compilation disks? What's the latest EP that you've got?

Before I can help you, I'll need to know that.

There are a few things we need to do once I know which spot the program is running from -

1. We need to change the compatibility on the SimsEPn.exe to fix compatibility issues.
2. We need to update the Sims2EPn.exe to run as admin.
3. You need to use a new graphic rules.sgr and video cards.sgr put in the place where the program is running from.

I will link those once we know where to put them and walk you through everything you need to do.

0
#3 17-03-2016 
  • Registered
  • 4
  • 5
I have windows 10 and I have the Sims 2, University, Nightlife, Open for Business, Pets, Seasons and Bon Voyage being my latest expansion (they're individual, not a ultimate collection).

0
#4 17-03-2016 
  • Registered
  • 1
  • 6
Stupid question: will BodyShop run?

0
#5 18-03-2016 
@miros1 if it's the error I think it is - the answer is no, bodyshop will not run.


@Ciaosu

Step 1: Download corrected Graphic Rules and Video Cards files.

Download Radeon Graphic Rules - Texture Fix
Download Video Cards.sgr - Radeon - 6810

Download these two files, unzip them and put them into the following folders:

\Program Files (x86)\EA\The Sims 2 - Bon Voyage\TSData\Res\Config\
\Program Files (x86)\EA\The Sims 2 - Bon Voyage\TSData\Res\CSConfig\

MUST BE INSTALLED IN BOTH FOLDERS

Step 2: Set the program to run as admin and change compatibility.

[Image: attachment.php?aid=2064]

Go to -
\Program Files (x86)\EA\The Sims 2 - Bon Voyage\TSBin\Sims2EP6.exe

Right Click on it - and select 'Troubleshoot Compatibility' - that will set the compatibility to something better.
Change the settings for all users, and select run as admin.

Step 3: Run the game

Go into Graphics/Performance Options, and set Smooth Edges to max.

If you have any problem with any of these steps, come back and let me know.

0
#6 19-03-2016 
  • Registered
  • 4
  • 5
Ok, I followed the steps...and they work! It's up and running now. Thank you so much!! Smile

2

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option