TS2 UC only runs on integrated graphics
#1 18-03-2016 
Hello! I received a new laptop yesterday (Windows 10 64-bit - 2.3 GHz Intel Core i5 6300HQ - 8 GB DDR3L SDRAM - Nvidia GeForce GTX 960M 4GB GDDR5) and installed the Sims 2 Ultimate Collection through Origin in the hopes of moving my game from my desktop. When I loaded the game, I encountered the issue with the greyed-out smooth edges slider and 800x600 as my only resolution choice. So I edited the graphicsrules.sgr file as follows: I replaced every instance of "enumerateMultisampleLevels false" with "enumerateMultisampleLevels true," and I also edited the "seti low 1" and "seti medium 2" to read "seti low 3" and "seti medium 3."

These steps solved those issues for me, but the game crashes when I attempt to run it with the Nvidia GPU instead of the integrated Intel HD graphics. It plays the intro video, then on the initial loading screen it makes to the 3rd or 4th scrolling sentence, freezes, and crashes. When I run the game with integrated graphics, it loads fine, but of course I would prefer to use the graphics card that I paid for. I tried running the game in compatibility mode with the Nvidia graphics card, and when I do that I receive the "Direct 3D returned an error: E_INVALIDARG! The application will now terminate" message.

I should also mention that I am running the game with no CC at this point.

Did I mess something up by manually editing the Graphics Rules file? I have been reading forums for most of the day trying to determine a solution to my problem, but nothing yet has worked. Any help or guidance in the right direction is greatly appreciated. Thanks for reading!

Edited to add that I also tried the Graphics Rules Maker program and am still encountering the same issues.

Attached File(s)
.txt  PADDYOLAPTOP-config-log.txt (Size: 10.31 KB / Downloads: 62)
sbabs, proud to be a member of LeeFish since Mar 2016.
(This post was last modified: 18-03-2016 10:45 PM by sbabs.)

0
#2 19-03-2016 
@sbabs I wouldn't be using the graphic rules maker since Windows 10. It seems that gives a problem a lot.

The problem with manually editing the graphic rules, is that you need to know exactly what to do. Unfortunately, you've really only dealt with one half of the problem with your edit.

Now, if you just want to use the NVidia card with your game - I can provide you with the fix for that.

Step 1: Correct Graphic Rules and Video Cards.sgr

Download 'Graphic Rules - Nvidia - Texture Fix - Max 1920x1080
Download Video Cards.sgr - Nvidia - 139b

WHERE TO INSTALL FIXES:
In the Program folders:

\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\CsConfig\
MUST BE INSTALLED IN BOTH FOLDERS

Step 2: Set the program to run as admin and change compatibility.

[Image: attachment.php?aid=2064]

Go to -
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSBin\Sims2EP9.exe

Right Click on it - and select 'Troubleshoot Compatibility' - that will set the compatibility to something better.
Change the settings for all users, and select run as admin.

Step 3: Run the game

Go into Graphics/Performance Options, and set Smooth Edges to max.

If you have any problem with any of these steps, come back and let me know.

1
#3 19-03-2016 
@celebkiriedhel, thanks so much for your help. Unfortunately I am still encountering the same issues - freezing and crashing at the same point on the load screen, and receiving the Direct 3D error when I run the compatibility troubleshooter (oh how I miss the compatibility tab from Windows 7!).

I did get the game to run last night (before I saw your reply) by running the Graphics Rules Maker (which I know now not to use) and then manually removing Securom. However, opening the game through the normal .exe causes Securom to reinstall, and I can't get the game to run through an alternate (no-cd) .exe as I have seen others describe on this forum. I'm still tinkering around and hope I can find a solution.

Edited to add that out of frustration, I uninstalled and reinstalled the Ultimate Collection through Origin. No luck. I then uninstalled the Ultimate Collection, cleaned the registry, and installed the complete Sims 2 CD collection. Same problem! It loaded fine the first time I ran the game (using the NVidia card with the graphics fixes in the correct folders), but after exiting and restarting, my game still freezes at the "over-waxing banisters" line of the loading screen. When I run the game with Intel graphics, it loads all the way.

Attached File(s)
.txt  PADDYOLAPTOP-config-log.txt (Size: 10.39 KB / Downloads: 62)
(This post was last modified: 19-03-2016 10:14 PM by sbabs.)

0
#4 26-03-2016 
Sorry for the double post, but I wanted to update since I seemed to narrow down the issue somewhat - if nothing else, as a way for myself to keep track of what I've tried. I uninstalled the disc version (I know, too many uninstalls and reinstalls...I was frustrated and desperate Confused), scrubbed the registry, and reinstalled the Ultimate Collection. I removed Securom and launched the game through an alternate .exe to avoid reinstalling it on my system. The game will run on the dedicated GPU on max resolution (1920x1080) and smooth edges set on low. But as soon as I slide the smooth edges bar to high, exit and restart the game, I encounter the same problem; the game will load up to the "over-waxing banisters" line on the loading screen, freeze, and then crash when I tab out. There is no reason why my graphics card shouldn't be able to run the game at max settings...I just have to figure out what to tweak to make this work. Undecided

Attached File(s)
.txt  PADDYOLAPTOP-config-log.txt (Size: 10.39 KB / Downloads: 56)
.txt  Sims2Exception 2016.03.26 09.43.58.txt (Size: 13.13 KB / Downloads: 60)

0
#5 26-03-2016 
Hi sbabs, with a week having passed since your previous post, you can't really call it a double-post anymore. And nobody will blame you for it, either. Don't you worry. Smile

2
#6 27-03-2016 
@sbabs you are running as Admin right?

0
#7 27-03-2016 
@leefish Yes I am. Smile However, when I try to run in compatibility mode - whichever system I choose - I receive the "Direct 3D returned an error: E_INVALIDARG! The application will now terminate" message.

0
#8 27-03-2016 
@sbabs This doesn't happen with the Intel Graphics card?

0
#9 27-03-2016 
No, with the Intel it loads smoothly.

Edit: I should also mention that when the game is loaded with the Intel graphics, the smooth edges bar is greyed out.
(This post was last modified: 27-03-2016 10:01 PM by sbabs.)

0
#10 28-03-2016 
@sbabs OK. Lets swap it back to Intel, and get Intel working - so then at least you have a fall-back position if I can't get the Nvidia working.

Swap it back to Intel. Go into the game, then post up the new config-log.txt - I can give you a video card and graphics rules that will make the Intel have smooth edgges.

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option