TS2 UC only runs on integrated graphics
#11 28-03-2016 
Sure thing. Here you go.

Edit: Well, it seems that once the game is loaded (with smooth edges set to 'less') I can slide the smooth edges up to high and actually play the game. As long as I remember to slide it back to low before I close the game, it seems to work and load without crashing. So that's kind of a tedious way to work around the problem, but a solution nonetheless if nothing else pans out!

Attached File(s)
.txt  PADDYOLAPTOP-config-log.txt (Size: 10.49 KB / Downloads: 347)
(This post was last modified: 28-03-2016 08:40 PM by sbabs.)

1
#12 29-03-2016 
@sbabs

OK. So it looks like you've put in the Intel version of the Graphic rules, and the Video Cards.sgr as well, which is why you're able to get the smooth edges moving with the Intel.

The Intel shouldn't crash if you leave the smooth edges up. But lets test that.

Step 1: Rename your 'The Sims 2' folder in \My Documents\EA Games\ to something else
I generally stick a ' - save' or something similiar on the end of the name.
That way we don't mess up your game.

Step 2: Start up the game. It will take a while because it will be regenerating a new Sims 2 folder.
Go into the game. All the settings will be on default.
Raise the smooth edges to max and save.
Come out of the game.

Step 3: Go back into the game.
Does it crash?

Let me know.

Intel seems to be a stable thing for Sims 2, so to be honest I'd be surprised if it does crash. For some reason, there are some cards that don't seem to want to work with the game, and it's hard to know which ones they are.

0
#13 29-03-2016 
@celebkiriedhel, I'm sorry, I should have been more specific - I am actually able to load the game with the Nvidia graphics card as long as I leave smooth edges set on low. I am able to set the slider to high once the game loads, and as long as I make sure to slide it back to low before I exit, I don't have any problems. So odd! But I'm not going to complain. Smile

The Intel graphics are very stable - definitely not as good in terms of quality. The slider for smooth edges is still greyed-out when I run the game through Intel.

0
#14 06-04-2016 
@sbabs How did you get your game to start again when you realized that it was the smooth edges setting causing the problem? I am stuck in crash loop and tried to use the intel to lower it and that didn't fix it.

0
#15 07-04-2016 
@hirikosaunders I have to open the Nvidia control panel and set the integrated graphics as the default for loading the game. Then I have to start the game and actually open the Graphics Options panel. The Smooth Edges bar is greyed out for me, so I can't actually change anything, but for some reason the action of opening the options panel seems to reset everything. Then I can close the game, use the Nvidia control panel to switch back to the dedicated GPU, and the game will load.

Once I am in the game, I can set Smooth Edges on high and play as normal. As long as I remember to slide the bar back to "less" before I close the game, I will be able to load normally again next time. However, sometimes I forget and have to repeat the whole process described above.

It is definitely an inconvenient way to play, but it's the only thing I've found that works. I have no idea why it works, either. I hope that helps you figure things out!

Oh and I forgot to add that I do run in admin mode.

0
#16 07-04-2016 
@sbabs Sadly that doesn't work for me. Still in crash mode so I'm not sure what to do.

I've taken every suggestion possible, even contacted nvidia. The only thing I haven't done is clean out securom.

0
#17 07-04-2016 
@hirikosaunders: The only thing you haven't done, is the thing where I'd say you should start! SecuROM is horrible, and will most certainly cause all kinds of trouble. Getting rid of that first, often makes a lot of other problems go away automagically.

0
#18 07-04-2016 
@BoilingOil That didn't work. I'm getting desperate here. I just want to play my game on the dedicated card. I've tried everything I can think of alone.

0
#19 07-04-2016 
I'm sorry I can't help with the graphics part, alas. But did you at least get rid of SecuROM, though?

0
#20 07-04-2016 
As far as I know I did. I thought I screwed my game to heck because the screen stayed black. I got it back though. I hope that doesn't happen again.

Thank you for trying to help!
(This post was last modified: 07-04-2016 10:20 PM by hirikosaunders.)

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option