Black Neighbourhood Screen!
#1 09-04-2016 
  • Registered
  • 0
  • 2
Hi there,

I just brought a new ASUS X553S laptop with Windows 10 and I downloaded a Sims 2 AIO. Anyway, the game installed fine and everything is great until I load a neighbourhood. The neighbourhood is just a black screen but I can still see the Sims 2 cursor. When I alt+tab out and in, the neighbourhood reappears, but the screen turns black again as soon as I click on anything. I've been through so many of your threads and tried so many fixes, but I just can't seem to fix it! Here's my config log. I have the Intel® HD Graphics Card.


.txt  SORICA-config-log.txt (Size: 9.44 KB / Downloads: 37)
(This post was last modified: 09-04-2016 03:10 PM by beccajuster.)

0
#2 10-04-2016 
  • Registered
  • 2
  • 6
@beccajuster I might possibly know a temporary fix for this, but first I must ask what is your in-game screen resolution set at, as compared to your screen size resolution?
(This post was last modified: 10-04-2016 06:53 PM by noodlement.)

0
#3 10-04-2016 
@beccajuster You don't have the Intel Graphics Card - game is set to Nvidia card. This is a problem that we've come across with other NVidia cards. If you swap to your Intel Graphics card, and install the Intel Graphic Rules and appropriate Video Cards.sgr your game will show up again.


@noodlement What's your possible fix? Please share your information as we have a number of people who have an issue with the NVidia card, and I'm looking for an answer at the moment.

0
#4 10-04-2016 
  • Registered
  • 0
  • 2
@celebkiriedhel I don't know how to do that Sad
I don't know what I did, but it now works! My new issue is that when I am in buy/build mode, the house I am building keeps glitching out and disappearing. It'll come back in a few seconds, but random bits of wall and floor seem to just temporarily disappear whenever I click or move. Occasionally, I get the flicker in-game, but my smooth edges thing is greyed out. I really want my game to work! Any help would be greatly appreciated.

@noodlement I have it running in 1366x760 or whatever the last resolution option is. I found that when I opened my game, if I had set the resolution to lower when I last closed it, I could alt+tab out and in and then change the resolution to the highest one and it would then run fine. But I'm now having the issues I just mentioned to Kiri above.

0
#5 10-04-2016 
  • Registered
  • 2
  • 6
@celebkiriedhel The possible fix was to lower the in-game screen resolution, just as beccajuster did. My theory is that when I have my computer display set to 125% so that text and desktop icons would be bigger, so having my Sims game set at max resolution would then become "too big", although I'm not certain if this is actually the true cause or not. This problem might also me due to the specific AIO the beccajuster is using though, as my friend used to have the same problem but it disappeared when they uninstalled it and switched to Sims UC.

@beccajuster The flickering screen issue can be solved through the method described in this link: http://simscompletecollection.tumblr.com...-sims-2-on . As to smooth edges, it isn't necessary to play but it can be fixed with this: http://stsims.weebly.com/smooth-edges-greyed-out.html .

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option