UC Will No Longer Load
#1 15-04-2016 
  • Registered
  • 4
  • 7
I get about 3/4th through the loading screen before I get an "application will terminate" error and have to restart my laptop.

I had it working which is the weirdest part, I restarted and then it seemed to stop working. From what I remember, I didn't add anything or change a thing.
I have the edited graphic rules because I have a new card, before that I had edited it myself and had weird issues. I have the texture fix as well, and it seems to be recognizing my card. I was experiencing lackluster gameplay which is why I didn't leave well enough alone, it was lagging a little. This whole thing is making me wish there were a way to revert to windows 8. I have a laptop with dual cards, starting in compatibility mode throws the ARG dialog error. Starting in normal admin mode gets me through most of the loading screen then crashes. Debating if I should just reinstall?

EDIT: I deleted every file in the documents and moved my downloads out, game started and played. Couldn't change the screen resolution, changing the options just left an hour glass unless I alt-tabbed and went back in. Game didn't crash but the resolution didn't change. Restarted the game and the resolution changed but it won't load past half way and then crashes. This is with no CC.
editedit: it seems it starts until I change anything in the graphic options. It will allow me to save smooth edges and play fine in game, but once I restart it won't start again. This is weird.
from my dxdiag:
System Model: Alienware 15
Processor: Intel® Core™ i5-4210H CPU @ 2.90GHz (4 CPUs), ~2.9GHz
Memory: 8192MB RAM
Available OS Memory: 8078MB RAM
Intel® HD Graphics 4600
Card name: NVIDIA GeForce GTX 965M
Manufacturer: NVIDIA
Chip type: GeForce GTX 965M
DAC type: Integrated RAMDAC
Device Type: Render-Only Device
Device Key: Enum\PCI\VEN_10DE&DEV_13D9&SUBSYS_06851028&REV_A1
Display Memory: 6010 MB
Dedicated Memory: 1971 MB
Shared Memory: 4038 MB

this is what my config says

Name: The Sims 2 EP9
Build: ReleaseSRT
=== Machine info ===
OS version: Windows NT 6.0
CPU: 4057.199951Mhz, Name:GenuineIntel, FPU:1, MMX:1
Memory: 2048MB
Free memory: 2048MB
User: -
Computer: -
=== Sound device info ===
Name: Unknown
Driver: Unknown
=== Graphics device info ===
Number: 0
Name (driver): NVIDIA GeForce GTX 965M
Name (database): GeForce GTX 965M
Kiri: Hardware rendering is enabled
Vendor: NVIDIA
Chipset: Vendor: 10de, Device: 13d9, Board: 06851028, Chipset: 00a1
Driver: nvd3dum.dll, Version:, GUID: D7B71E3E-5099-11CF-D06A-88261CC2C735
Driver version: 6472
Monitor: \\.\DISPLAY1
Monitor aspect: 1.773195, 16:9
Screen mode: 1920x1080x32BPP,60Hz
Texture memory: 1744MB
HW T&L: Fixed function:1 Programmable:3.0
Pixel program: 3.0
Texture stages: 8
AppControlledAA: 1
Kiri: memory hi cpu hi max vertex > 1 not force low not integrated
(This post was last modified: 15-04-2016 08:34 PM by Dockamorphed.)

#2 15-04-2016 

Ah! Another NVidia with this problem. OK. The bad news is that NVidia have changed something with their graphics card, not entirely sure how to fix it apart from rolling back a long way.

If you have dual cards, the easiest way to deal with this, is to switch to your Intel card. (Nowadays it's good enough for Sims 2).

One of the other guys who has this problem has found that to play the game, you have to reset the edges to min before you finish, if you want to be able to start up your game again.
Which is annoying especially if you don't remember. And irritating to have to change the settings every time.

I'm researching into this to see if I can find a cure, but I'm not promising anything.

#3 15-04-2016 
  • Registered
  • 4
  • 7
sure enough intel does work, it's just kind of slow-motiony? Is my processor too weak for the 3000ghz one? I'd be fine with the smooth edges, my main issue is that the resolution refuses to go any higher, I tried changing the default minimums and it still stayed at 800x600. So strange lol. Wouldn't be a sims game if it weren't broken, I guess! Tongue

#4 15-04-2016 

If you upload a config-log.txt file - I think we can fix that.

#5 16-04-2016 
  • Registered
  • 4
  • 7
Here it is, would it be because I haven't added it into the video cards?

Attached File(s)
.txt  config-log.txt (Size: 9.57 KB / Downloads: 20)

#6 16-04-2016 
This is the Video Card you will need

Your config log says that your screen is 1920x1080, and your defaults and maxes are

uintProp maxResWidth 1600
uintProp maxResHeight 1200
uintProp defaultResWidth 1024
uintProp defaultResHeight 768

So if you want the screen to get up to 1920x1080, that's a change to maxResWidth maxResHeight. I can pop you up a new Intel Graphic Rules if you're not confident to change them yourself.

Regarding the lag - that can either be the securom giving you a problem, or the CPU is too fast and gets out of sync with the game. I'd go with the securom being the problem, as that can be removed and played with a nocd hack, and then you get the whole going fast thing. If the securom doesn't fix it - then you need to actually throttle your cpu so that it doesn't go too fast.

Securom fix Comes from Dathoc's Thread Kindly provided by VoodooBG.

Read hear for reducing the number of Cores to throttle your CPU

#7 16-04-2016 
  • Registered
  • 4
  • 7
it runs better a little after the securom, I think. I'm gonna put in a camera mod and see if that helps too, because the default camera is pretty bad after using TS4 for so long. Previously I had already had that core throttler added to my origin thing. Is that the right way to do it? I get lag in the rain and snow, although I'm not sure if that'll continue now that this is sorted out more.

Thank you so much for your help, though! It's awesome that this game still has a following that will try their best to pick up the pieces as it begins to show it's age more and more. At least it hasn't reached Sims 1 black box everywhere levels yet haha.

#8 16-04-2016 

You'll need to add it to your NoCD hack, you can't use the origin thing anymore.
But yeah, that's the right way to do it.

#9 23-04-2016 
  • Registered
  • 4
  • 7
Would downgrading to windows 8 fix this?

#10 23-04-2016 

It might, but you'll probably need to roll-back the NVidia drivers to prior to your windows 10, then install the drivers from the NVidia site rather than what has already been done because Windows 10 stuffs up the NVidia drivers, and the drivers aren't rolled back swapping back to Windows 8.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option