Flickering after various fixes
#1 22-04-2016 
  • Registered
  • 3
  • 6
I'm trying to run Sims 2 Ultimate Collection as downloaded from Origin on my Surface Pro 4 running Windows 10. I've tried various fixes including adding my graphics card, changing various numbers in the configs, running as admin and compatibility modes. I got around the low resolution and black square shadow things, but I'm still dealing with the weird flickering. Any help would be much appreciated.

Attached File(s)
.txt  DESKTOP-P1FM4F1-config-log.txt (Size: 10.36 KB / Downloads: 42)

0
#2 22-04-2016 
@needhalp
To stop it from flickering, apart from running in admin and compatibility - you need to move the 'smooth edges' to max.

Everything else looks fine. Smile

0
#3 23-04-2016 
  • Registered
  • 3
  • 6
I think I had already put the edges all the way down but I'll double check it. Thanks.

Edit: Yep, still flickering at max edges.
(This post was last modified: 23-04-2016 09:33 PM by needhalp.)

1
#4 24-04-2016 
@needhalp

Hmm.... this is new flickering problem then.

what compatibility is it set to in Windows 10? (Also you did set it on the exe rather than the shortcut, yes?)

0
#5 24-04-2016 
  • Registered
  • 3
  • 6
I used the compatibility troubleshooter on the exe because there was no compatibility tab in the properties. It's on Windows 8 mode right now.

1
#6 24-04-2016 
@needhalp

Can you try it back Windows 7 using the compatibility troubleshooter?

Yeah - the compatibility tab doesn't turn up for all exes in Windows 10 for some unfathomable reason.

Also, I know it probably doesn't matter, but could you also do a reboot on your machine after you change the exe, and before you try running it.

That's a just in case they load the details in some sort of cache - I never know what Windows 10 changes.

0
#7 25-04-2016 
  • Registered
  • 3
  • 6
@celebkiriedhel
Tried all those things. Any other ideas?

0
#8 25-04-2016 
  • Registered
  • 3
  • 6
Turns out I was only checking snowy lots. There is no flickering in times with no snow. No idea why or how that works.

1
#9 25-04-2016 
@needhalp

OK. That's a shaders problem. If you turn off the invisible radar in the snow, that flickering should go away on the snowy lots.

0
#10 25-04-2016 
  • Registered
  • 3
  • 6
@celebkiriedhel
Invisible radar? Could you explain a little further, please? I've not heard of that.

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option