Game unable to detect Nvidia card - possible fixes?
#1 25-06-2016 
  • Registered
  • 3
  • 3
Hello everyone!

Basically ths issue I have with my TS2 installation is that it doesn't want to detect and use Nvidia card I have on board of my laptop sticking to use the Intel one instead, even after I change the settings in Nvidia control panel to force the game to do so.
I can get decent non-edgy graphics with Intel card by using fixed GraphicRules file but I'd love to play with Nvidia chip. I did some research together with Delphy @ MTS chat, his conclusion basically was "your video card is unsupported because it's too new".

Any possible solutions to work around this?
Find the config log attached.

My specs are:

OS Win8 64bit

Graphic cards:

Intel® HD Graphics 4000
Nvidia Geforce GT 750 M

Attached File(s)
.txt  FLIPPER-config-log.txt (Size: 9.53 KB / Downloads: 20)

#2 04-07-2016 

Setting the game to use the NVidia card is all about the NVidia control panel, the game uses the graphics card that its told to. The age of the card is not the problem, the NVidia GT 820M has been in use with the Sims 2 with other users (same graphic card family).

So the question is more about what you're doing in the NVidia panel.

You are completely correct about the INTEL card - and if we can't get the NVidia working, we can fine tune that to give best-case resolution and working. Which will be an improvement on your current configuration.

To be honest, the INTEL tweaked and the NVidia are not that big a difference.

You need to tweak both the Graphic rules and the Video cards.sgr for optimum performance.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option