Solved- Game loads to black screen after Securom Removal
#1 04-07-2016 
I have Windows 10 and UC. I removed SecuROM from my computer, then started the game to check it out. After I choose a neighborhood to load, the game loads to a black screen. I have to minimize the game, then maximize it again in order to view the neighborhood. Everything works fine after the minimizing and maximizing, but I would like to remove this new extra step, if possible.

Attached File(s)
.txt  PC-config-log.txt (Size: 10.34 KB / Downloads: 24)
semio, proud to be a member of LeeFish since Apr 2016.
(This post was last modified: 17-07-2016 12:41 AM by semio.)

#2 04-07-2016 

You need this video cards.sgr file -

Video Cards.sgr - Radeon - 9851

\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\CsConfig\

Quick question. When you updated your graphic rules - did you use mine or the Graphic Rules Maker? The reason why I ask is that your texture memory is 2047Mb, which suggests that it's the GRM (mine is always set to 1744Mb) and the Graphic Rules Maker can do stuff slightly differently to mine so there may be some discrepancy in the graphic rules I need to look for if the video cards definition doesn't fix it.

#3 04-07-2016 
Thanks for the link. I'm sorry, I don't remember which graphics rules I was using, since I updated it quite awhile ago, and everything had been working perfectly until today. I tried the video card fix along with my current graphics rules and it didn't work. So, I just swapped my graphics rules for for the graphics rules download in the sticky thread in here, but it didn't solve the issue.

#4 04-07-2016 

Can you post up your config-log.txt since you've changed the graphic rules and video cards.sgr? That will let me know if the changes took, and what other information is going on.

#5 04-07-2016 
@celebkiriedhel here's the new log.

Attached File(s)
.txt  PC-config-log.txt (Size: 10.16 KB / Downloads: 19)

#6 06-07-2016 

Got it - there's a bit of work to do here - I'm away from my computer for the rest of this week so I won't be able to get back to you about this until next Monday.

#7 06-07-2016 
Okay, thanks for your help, @celebkiriedhel.

#8 15-07-2016 
Hello, I had this same issue in the past, the neighbourhood screen was always black when it loaded but if I went out of the game and back in it was fine. The solution I found was that I had to set compatibility mode to windows 7 and then it loaded fine, though I'm not sure why. Just thought I'd mention it, in case this is the same problem, though there might be a better solution. Smile

#9 16-07-2016 
Thanks for the tip, @TheDarkLady . I'll try it out.

#10 17-07-2016 
Sorry for double posting, but I wanted to say that putting it in Windows 7 compatibility mode solved the issue. Thanks again.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option