Crashing-A Series of Unfortunate Events
#1 24-11-2016 
I've been struggling to fix my game crashes and at this point may have completely corrupted things. celebkiriedhel suggested I post in this forum. Before I bite the bullet and re-install I am making a last ditch effort to see if it is salvageable. Sorry for the long post but I want to provide as much information as possible.

Hardware/Software
Windows 10 Home 64 bit
Intel Quad core i5-4430 @3.00 GHz
16 gigs RAM
nVidia GEForce GTX 660 (tweaked with graphic rules maker to fix in-game fugliness)

As of early 2015 I was running my game in Windows 7 with no issues. As of early 2016, I updated to Windows 10 and was able to run the game with no issues. Up until early this spring I didn't play a lot when I got back into regular playing. I think the last time my game was stable was around July. My game was created with clean and empty hoods.

When My Problems Began
I had terrible lag and some graphics issues so I applied various fixes. I used CFF Explorer to get my game to run with more than 2 gigs. I tweaked my graphics per the mention above. I added -CPUCount:1 to my shortcut to deal with the quad core issue. I run my game with a no-DVD crack. I made my .package files in the Program Files folder Read Only. I regularly delete the Groups.cache (as in before each game load). I recently removed SecuROM (which I was unaware I had. It may or may not be important but things got worse with my game after I did this). Unfortunately, I indiscriminately downloaded a bunch of CC over the period of July to the present. I had an issue where all my NBs were fine except my storytelling NB which crashed constantly when sims attempted to come home from work (or any other random reason it would seem). Now they all randomly crash.

I have done the 50/50 method multiple times with my downloads to see if I could figure out what causes the crash. I ran the HCDU and don't see any issues there that I think would be causing the problem. I ran the GUID conflict detector and fixed all those issues that were not in my Program files (I was afraid to touch those). I've been playing around with different combinations of CC. Depending on what it is my downloads, it either crashes in the Misc Catalog or the Build catalog, or any other catalog. At this point I have removed what I can determine as the newest downloads since I got to a point where I thought it wasn't crashing. I went into a blank lot in a test NB and ran through the catalogs with no issues. I went to RBH to test an inhabited lot that I haven't packaged yet. I place the move out object stayer thingy so I could package the lot. Before I saved I thought I would replace a bed. I moved it and went to place a new bed exactly like it (by holding the shift key when I moved it) and the game crashed.

Riverblossom Hills was always stable. There are 2 families in lots and 23ish townies that I created. There is a family of 6, a family of 2, and a family of 1 in the bin. The last time this NB was stable, I was decorating a lot. I can no longer enter this uninhabited lot without the game crashing. That started when I downloaded 1 tile pianos and recolors. The last time I could enter the lot, I was trying to replace the piano. It would crash. I removed the 1 tile piano and I can't get in the lot at all. I should also mention that my game started crashing after I installed the chickens, crops, and harvestable trees from plumbbob keep. I have since removed the chickens and crops although I kept the trees and they worked just fine.

Other Stuff You Should Know
I did not install sims 2 on this PC. It was given to me with the game installed by the person I collaborate with on our sims story. She was careful to install everything by following a lot of posts to prevent corruption, etc. It worked great. After I "upgraded" to Windows 10, it worked great. Until it didn't. I think this may totally be my fault because I probably compounded the issues by trying to fix it myself. I usually back up everything before I start messing around but at this point I have so many backups I'm not sure what worked and what didn't. I have replaced some of my Program Files with her working files (things like the catalog bins, scripts, CEP Extra files, her downloads). I've pulled things out and put them back. I've taken my Sims 2 folder out of the Documents, recreated it and then replaced my NBs, etc. I have slowly added my CC to hers so I can get back the things in the lots I want to salvage. It just doesn't work. I have a lot of default replacements, hiders.

I have nearly 15 gigs of CC (and this does not include things I pulled out to test CC). I know that is a lot. I've tried to cull. It's hard when I can't look at stuff in the catalog to figure out if I need it or not or just to figure out what it is. I have over 52K files worth of downloads. I don't know if there is a ceiling for CC and I don't know if it's size or number of files that causes a problem. I have a lot of disabled packages in my DL folder and I don't know if they affect anything. I have images of CC in folders to identify it. It takes around 10-12 minutes for my game to load and it can take 5+ minutes for an inhabited lot to load. I think that is excessive.

I am attaching my config-lot file and my most recent exception files along with some older ones for reference. I really think I've made my game unstable to the point of needing to re-install because I moved and replaced files all over the place. I hope not. If it's CC, it's weird because the CC was working until it stopped. I am hoping to learn what I should look for in my downloads. Should I pull out disabled packages and the image files? Is it size of the downloads folder or number of files I should worry about?

Finally, if this is the wrong place to post, I'm sorry. I wasn't sure. And again, sorry for the long post.

ETA: I have all EPs and SPs through M&G. I do not use UC.


.txt  Sims2Exception 2016.11.23 14.29.26.txt (Size: 11.74 KB / Downloads: 106)
.txt  ADMIN-PC-config-log.txt (Size: 10.31 KB / Downloads: 90)
.txt  Sims2Exception 2016.11.23 13.12.09.txt (Size: 11.74 KB / Downloads: 91)
.txt  Sims2Exception 2016.11.20 10.29.45.txt (Size: 11.72 KB / Downloads: 124)
.txt  Sims2Exception 2016.05.22 10.14.50.txt (Size: 12.07 KB / Downloads: 105)
.txt  Sims2Exception 2016.06.15 16.45.44.txt (Size: 12.47 KB / Downloads: 98)
gfitz, proud to be a member of LeeFish since Jan 2016.

1
#2 24-11-2016 
@gfitz Hi gfitz,

Your graphics card set up is fine. There are some things I want you to do, so we can work out where the problem is.
There is a CC download limit, and there is a very good chance you've hit that limit - but we'll work out the other problems first.

First up - we need to see if it's a problem in your program files or in your my document area. To do this, we need to rename your game in your my documents folder, and have the game regenerate a blank one.
Tutorial on creating a vanilla game space

Then you need to go into the game, and go into any lot, play around for a while in both vacant lots and lots with sims - and see if you get lag and crashing.

If you don't - then the good news is that you don't need to reinstall the game.
If you do - then you're going to have to reinstall the game. If you need to reinstall, that's ok - we can do it together with all the things that need to be done.

Regardless of whether you need to reinstall or not, we will need to test your CC as well. And I think we need to go through the fixes that you've done - because looking at them, I think you've done some that are not needed and will have caused trouble rather than fixed it.

tl;dr - testing cycle first. Don't panic - we will fix it. Smile

1
#3 24-11-2016 
OK I will start with the vanilla game space. Just to let you know, I have a bit of vertigo today so I may be slow to respond.

ETA (sort of) I followed the Creating a Vanilla Game Space per the tutorial but I didn't install CEP. Should I?

I created a blank lot, built 4 walls, added floor, window, door, plant, roof and then left without saving it. I put down a cheap house, made a sim and moved him in. Humble showed up. Garden Lady showed up. Matchmaker showed up. I got him a job and a blind date. I sent him to work. He came home with a promotion. Everything was smooth, fast, and simple. I clicked through all the catalogs.

One thing I noticed is that the awful blue blur at the top of the hills in the distance was gone but the black box when he walked around was there.

1
#4 24-11-2016 
@gfitz

OK. That's good, you don't need to reinstall your game! Big Grin

To fix the black box - install Nopke's [UPD 2JAN16] Sim Shadow Fix

Now, because this is just a change of hood - the changes that you did are all still included. So we can see that it wasn't your changes that was the problem.

You have quad cores with 3MHz which would suggest that you're getting 12MHz, your game is reporting that you get 4.2MHz, so that would suggest that you don't need the CPU count set to 1.
So we'll start by removing that one.

Then I want you go back into your vanilla game and test it again, with the shadow fix, and the CPU count removed. You will need to go in and check that the lag is not back - if it is, then I was wrong, and you will need the CPU count set to 1. And the shadow should be fixed as well.

Once you've done that - can you upload the config-log.txt for the vanilla game. It will tell me if there are any differences between the running of your full game settings and your vanilla game settings. That will let me know if there's anything specific to the full game that I need to watch out for.

1
#5 24-11-2016 
@celebkiriedhel I added the shadow fix and played fairly quickly in the inhabited lot along with the catalogs. No lag, no crashes after removing the CPU count. To be clear in my understanding, this is a vanilla game, no CC, brand new NB per the tutorial you linked to. Should I have added my CC in there?

Attaching the latest config file. I won't be around much until later tonight so no hurry on this. And thank you so much.

Attached File(s)
.txt  ADMIN-PC-config-log.txt (Size: 10.27 KB / Downloads: 99)

0
#6 25-11-2016 
@gfitz Fabulous. Yup - we've just proved you don't need the CPU count change. Your CPU is 4.2 MHz - and that's a good rate for Sims 2.

That's correct - we're still in the vanilla hood, with no CC. We're staying with the no CC, while we're fine tuning the fixes.

So the fixes that you have in are:

1. CFF Explorer
2. Removed Securom
3. Using no-CD.
4. Read-only in the Program Files
5. Removed the caches.

OK - we need to check the following things.

1. Have you got the game set up so that it runs as admin?
2. Have you run compatibility?

If you haven't then that's ok - we can do that next -
Go into Program Files folder and find Sims2EP99.exe, right click, and choose properties:

[Image: attachment.php?aid=2064]

If you've got the compatibility tab - then you can follow the above image (choose Windows 8). If you don't - don't panic, cancel out.

If you don't have the compatibility tab, right click on Sims2EP99.exe and choose 'troubleshoot compatibility' - that will do it as well. There should also be a 'Run as admin' option as well.

1
#7 25-11-2016 
@celebkiriedhel I probably should have mentioned I use Game Booster to shut down as many processes as I think are ok to shut down. I don't use it to launch the game however.

I'm not sure I am following your instructions correctly. This is what I see:

[Image: 3C28f5e.png]
[Image: Zs4MUdd.png]
[Image: P67R5CL.png]

Then it asks me to test it. I don't see anywhere to tick the Run as Administrator.
(This post was last modified: 25-11-2016 08:32 AM by gfitz.)

1
#8 25-11-2016 
@gfitz

I don't know why your images don't work either - the bb code was set up correctly, so I'm thinking it's probably a forum setting. I changed them to url's and I can see them no problems there.

The compatibility change looks fine.

When you click into properties - can you do me a screenshot of what you see ? (I have Windows 7, and am not upgrading anytime soon). And each tab as well.

0
#9 25-11-2016 
@celebkiriedhel OK. So I chose Windows 8 for the compatibility and ran the game. It loaded full screen (I usually play windowed because I can't get full screen screen caps - it only grabs my desktop). I also noticed smooth edges was set to Less so I slid that to Max. I checked my shortcut and it somehow lost the extra text to run it windowed. I fixed that.

[Image: gUw0pWc.png][Image: BwKpfX6.png][Image: Xh6iPNh.png][Image: cdGFp7D.png]

0
#10 25-11-2016 
Sorry for butting in, but I currently have access to a Win 10 computer and thought maybe I could help a little. Smile

For me, when I right-click on a program on the Start menu (is it still called that in Win 10? The menu you get when you click on the Windows symbol in the lower-left corner, anyway) and choose "More", for some (but not all) programs I get "run as administrator" as an option. When I right-click on the actual program file, I've got a "run as administrator" checkbox at the bottom of the Compatibility tab.

@gfitz comparing your screenshots to my Win 10, to me it looks as if you've right-clicked on the program shortcut, not on the actual program file - is that right? If so, what do you see if you click on the "Advanced..." button on the General tab? Me, I've got "run as administrator" there.

(The Win 10 computer doesn't have any software for screenshots installed, I'm afraid, and even if it did, it speaks Swedish, so it wouldn't be much use anyway.)

2

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option