Win10 and graphic card's nightmare that doesn't seem to go away
#1 22-12-2016 
Hello!
I've been trying to fix the same win10 problem that pretty much everyone has had by myself, but I just don't seem to put my finger on where I mess up, so maybe someone can help me a bit.
The problem is as usual - the whole screen goes black in neighborhood view, the graphics are lousy, the game's laggy, can't change the resolution (800x600 is the only opinion), everything's flickering when moving around. I have The Sims 2 and all EPs.

First of all, my config-log seems to be tad different from the usual ones as it doesn't seem to have too much information in it.
My computer has 2 graphic cards - nVidia GeForce GTX 950M and Intel HD Graphics 520, so I'm not sure if I should've downloaded the nVidia fix or the Intel fix. I've actually tried both (and also writing both of the grapics card in the same video cards.sgr), but neither of them has worked. I did change the global nVidia settings so that it'd always be the preferred graphics card when playing sims, but I'm not sure if it even helped or maybe it's just an unimportant piece of information in this case.
I did the "-w -CPUCount:2" too as I have a dual-core processor, but I'm not sure if it helped with the laggying problem as it's hard to compare when the game's minimized to 800x600. I have tried Graphics Rules Maker, writing my own Graphics Rules.sgr and Video Cards.sgr a thousand times already, but nothing seems to work.

Any ideas what to do next?

Attached File(s)
.txt  DESKTOP-5LD0O3M-config-log.txt (Size: 1.01 KB / Downloads: 23)
(This post was last modified: 23-12-2016 04:31 AM by buttersauce.)

0
#2 23-12-2016 
@buttersauce

Hi - that's the config log you get when the game crashes before it gets too far in.

When you say you have the Sims 2 and all EP's, does that mean you have the CD DVD's? I'm going to assume it does for the replies below.

OK. Win 10 is a dog, and while Sims 2 can work in Win 10 it can be a bit tricky making it work.

So first up - we're going to set your game up with Intel and laggy, so I can see a working config-log.txt with more info. I'm also going to stick some trace in the graphics rules so I can see what's happening.

Step One: Use a NoCD hack for the game.

We're also going to do some fiddling outside the game. First up - are you running from the CD or from a noCD hack?

If you aren't - I want you to download this file - Sims 2 Mansions and Gardens No CD
(This is the one I use, and it is completely safe).

Go to \Program Files (x86)EA\The Sims 2 Mansion and Gardens\TsBin\

Rename your existing Sims2EP9.exe to Sims2EP9-old.exe

Unzip the file in this folder which will install a new Sims2EP9.exe in the folder.

Regardless of whether you have installed Sims 2 No CD hack, or you had it already ->

Step Two: Setup Compatibility on the program and the shortcut that you use.
  • Right Click on the new Sims2EP9.exe and choose 'Troubleshoot Compatibility' - follow the dialog. If it asks you for an operating system to set compatibility to, choose Win 8.
  • Right Click on the new Sims2EP9.exe and choose 'Create New Shortcut'. This is going to be to be the shortcut that you use.
  • Right Click on the new shortcut and choose Properties. It *should* have a compatibility tab. In the compatibility tab, set it up based on this image - but choose Windows 8 for the program. And definitely make sure you set up 'for all users' and 'Run as administrator'.

    [Image: compatibility.jpg]
  • Stick the shortcut on your desktop, so it's easy to get to.

Step Three: Install basic graphic cards and video cards

Download these two files:
Graphics Card with test
Video Card master

Install it in the Program folders:

\Program Files (x86)\EA\The Sims 2 - Mansion and Gardens\TSData\Res\Config\
\Program Files (x86)\EA\The Sims 2 - Mansion and Gardens\TSData\Res\CSConfig\
MUST BE INSTALLED IN BOTH FOLDERS

NOTE: I am not expecting that these will fix your problem. What they will do is allow me to see what the problem is.

Step Four: Run the game and check the logs folder

In your My documents folder - Rename your current 'The Sims 2' folder so the game generate a new blank one. Rename it to anything you like - I generally add a dash and a description like '- play'
This will take out one level of complexity, so we can fix just your game, and then worry about any CC or gameplay that may be causing problems as well later.

Once that is done - Run your game from the shortcut we created in Step Two. It will take a while to run because it is generating a new set of folders.

Go into a hood, and a lot. Check to see if you can change the 'smooth edges' to max. (It doesn't matter if you can't, it's just worth a check for me).

Come back out of the game.

Go into the logs folder and find the (your pc name)-config-log.txt.

Then post it up here for me to have a look at and also let me know about the smooth edges.

Hopefully it should be able to tell me what's happening at that point, and we can do a proper fix for you.

1
#3 23-12-2016 
Oh I wasn't expecting such a quick reply, thanks a bunch!

I totally forgot to mention that, but yes, I'm using a no-cd hack. I did everything as you said and this was the first time I didn't have that black screen in neighborhood view. I couldn't change the smooth edges though.

Attached File(s)
.txt  config-log.txt (Size: 9.46 KB / Downloads: 16)

0
#4 23-12-2016 
@buttersauce

Keep the Master Video Cards file - that seems to be working for you - It actually has all the bits and pieces that you need for your Intel card, which is what it's using. Lets not worry about NVidia yet. Intel is actually good enough for Sims 2, once we're using the right graphic rules cards.

I got lots of good information from this config-log. So big pluses.

Keep using the shortcut we created in Step 2. That's going to be your preferred shortcut, Feel free to put that wherever you like.

OK You need to use this card

Graphic Rules INTEL - Texture Fix

It goes in the same place as where the Graphic Rules test went.

Install it, and go into the game again - you *should* be able to change the smooth edges and the screen size.

Regardless of whether you can or not - can you post your new config-log.txt up.

It may need an extra tweak, but I'm loath to put it in until I know that you need it.

1
#5 23-12-2016 
Yes! I indeed was able to change the smooth edges and the screen size!

I didn't have the time to test the game just yet, so I'm not sure if the flickering still remains (it didn't seem to, but I'll test it in a few hours).

EDIT: The flickering's also gone, the game's still a bit laggy, though.

Attached File(s)
.txt  config-log.txt (Size: 9.44 KB / Downloads: 15)
(This post was last modified: 24-12-2016 03:34 AM by buttersauce.)

1
#6 24-12-2016 
@buttersauce

The lagging will be because of securerom (unless you've already removed it?)

Follow the instructions here - Securom and Windows 10 to remove it.

But it sounds like all the other changes have fixed the bulk of the problems. yay.

1
#7 24-12-2016 
Thank you so much! I can't express my gratitude enough, your helpfulness is above all limits. :')

One question though - would trying to get my nVidia graphics card to work be pointless (as in wouldn't improve neither gameplay nor graphics much from what I get from the Intel graphics card)?

1
#8 24-12-2016 
@buttersauce

Getting Intel to work is two-fold

(1) it is good for a backup because that's what your machine naturally wants to play the Sims with. So if that works, and all else fails you can still play the sims.
(2) Getting the Sims to play with the NVidia card is problematic. It needs to be set up that way outside the game in the video card console - I'm not conversant with making that work.
Also Windows 10 and NVidia seem to have particular problems with Sims 2 and it's very likely that a lot of your original problem was simply because your system was trying to use the NVidia card. The Windows 10 automatic update stuffed up the card - there's a thread about it in the forum (It's called Windows 10 and NVidia ... I think).

So getting back to your question - Intel gives good Sims 2, nVidia wouldn't improve it very much for the amount of hair tearing and complexity that it would require to get it working. The nVidia card is a better card so we can set that up. A lot of that work is outside the Sims game - it would require rolling back the graphics drivers for nVidia and applying them manually, apart from anything else.

I'm up for trying to get the nVidia working, but most of the work is on you as I can only point you to the tutorials, etc. So yeah, if it sounds slightly discouraging that's because I don't think the gain is worth the effort.

1
#9 25-12-2016 
Okay yeah, I was just curious. :')

But really, thanks a bunch, could have never done it without you! Sending many virtual hugs your way!

1
#10 25-12-2016 
@buttersauce

No worries at all. You're very welcome. Smile

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option