Sims 2 Error Message - Graphics Card
#1 13-01-2017 
  • Registered
  • 1
  • 5
Hi all. I got The Sims 2 Ultimate Collection this morning, and I was so excited to download it. I received a free copy, and it was added into my Origin library. Once it was done downloading, I rushed to open it. The game didn't even start, and I was greeted with this message: "Failed to find any DirectX 9.0c compatible graphic adapters in this system! Please make sure you have a DirectX 9.0c compatible graphics adapter and have installed the latest drivers provided by the manufacturer. The application will now terminate".

I read somewhere that making a shortcut of the SP9 launcher, then adding "-w" fixes it, and it did. I also downloaded the Graphic Rules folder and put that in it's correct folder, which made the game faster. I would like to be able to play in full screen mode though, but without the "-w" there, my game does not seem to work. I have read through multiples threads on here and have tried a lot of recommendations, but none have [/php]seemed to fix my issue.

Config List:

Attached File(s)
.txt  Full Config.txt (Size: 10.37 KB / Downloads: 60)
(This post was last modified: 13-01-2017 07:15 AM by alex.)

0
#2 13-01-2017 
@alex

I can't tell what's happening, because there's only half the config log.txt there -

The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.

Can you attach your full config-log.txt so I can have a look at it? Thanks.

As for the full screen/windowed thing - unfortunately we don't know why this happens, so if you have to play windowed there's currently no way of being able to play full screen.

0
#3 13-01-2017 
  • Registered
  • 1
  • 5
Thank you for such a fast reply! I just added the full config-log.txt!

0
#4 13-01-2017 
  • Registered
  • 1
  • 5
@celebkiriedhel

Sorry for double posting. I'm not sure if you'd get my post notification if I did not mention you with an @.

0
#5 13-01-2017 
@alex

OK. We can't make the game play in full screen. What we can do is make the windowed screen the same size as the full screen.

You need to use the graphic rules with the 1920x1080 sizing.
Graphic Rules NVidia - Max 1920

Install it where you installed the previous one.

When you go in game you will be able to set the screen size to 1920x1080 which is your full screen size.

0
#6 13-01-2017 
  • Registered
  • 1
  • 5
@celebkiriedhel

The Graphics Rules go into my SP9 folder, correct?

I just changed them and it's still only giving me one option and it's the small window.

0
#7 14-01-2017 
@alex

That sounds like the right place, but you're getting the wrong thing. Sad Are you putting it in both folders? Also can you post up another config-log.txt? I can tell what's happening from that.

WHERE TO INSTALL FIXES:
In the Program folders:

\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\CsConfig\
MUST BE INSTALLED IN BOTH FOLDERS

0
#8 14-01-2017 
  • Registered
  • 1
  • 5
@celebkiriedhel

I fixed it! Just re-added the graphic rules into the folders. Thank you so much, you are truly amazing! Smile

1
#9 15-01-2017 
You're welcome Alex. Smile

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option