DirectX 9.0c compatible graphics
#11 27-01-2017 
Hello @asimwen ,
I wish I could help you out but I'm having problems with my sims too. Anyway, I've got the DirectX error too but I reinstalled the sims all over again and it's gone, I don't know why or what happened, I bought new laptop as well so I guess it's common error with Windows 10 compatibility?! Don't know if it could help you though. Maybe rather wait for @celebkiriedhel , Kiri is amazing, is trying to help me with my game as well. I just hope we're going to fix it because I am trying to make it work for a week now and it's driving me crazy a bit :-) But I don't lose faith!

--
Nomi

0
#12 27-01-2017 
@nomi

What's the ep number in the double deluxe folder?

You need to look in this folder:
C:\Program Files (x86)\EA GAMES\Double Deluxe\TSBin\

0
#13 27-01-2017 
@celebkiriedhel

I don't even have TSBin in Double Deluxe folder. I have there four folders "Base", "EP2", "SP4" and "Support", see my screen shots. It also says I did some changes on Jan 23, 2017.

Have you seen folders like mine before?

EDIT: adding the screen shots

Attached File(s) Thumbnail(s)
       

0
#14 27-01-2017 
@nomi

Inside the SP4, Base and EP2 folders there will be a TSBin folder. Can you tell me what the Sims2EP numbers are in the SP4 and Base folders as well?

The likelihood is that we're going to have to put the graphic rules into one of these folder systems, I'm just trying to work out which one.

0
#15 27-01-2017 
@celebkiriedhel

Here's SP4 and Base screen shots. Hope it'll help you.

Attached File(s) Thumbnail(s)
       

0
#16 28-01-2017 
Hello! @celebkiriehhel

The crashing is fixed!! I've put it to all the folders so I don't know which one it has fixed, I also run it as administrator. Thank you very very much!!! Thanks to you I can play my fav game again! :-) you're very sweet to help all of us here.

I just found one error, I have those black boxes under my sims. Would the Intel texture fix from here: http://www.leefish.nl/mybb/showthread.php?tid=6888 fix the problem?

Thank you again.

- Nomi

Attached File(s)
.txt  NOMIPEPI-config-log.txt (Size: 10.34 KB / Downloads: 231)

1
#17 28-01-2017 
@nomi

Download this fix and install it in your downloads and that will fix the black box problem. Smile

Glad to hear that it's working.

0
#18 29-01-2017 
@celebkiriedhel yay it's gone! Thank you so much for your help again!!! :-)

2
#19 19-02-2017 
Hello @celebkiriedhel ! It's me again.

I can't play TS2 again because of Directx error. I'd downloaded couple of CC and wanted to play but the error showed up. Sad I've deleted the new CC which I'd downloaded because I thought it could be causing the problem but I still get the same error. Should I deleted all the CC? Even if it was not causing any problems before?

Would you look at it, please? I don't know why it is not working again. It was alright until today.

I've attached my config-log for you, and also DxDiag (don't know if you needed it). If you needed anything else, please let me know!

Thank you very much!!

Attached File(s)
.txt  NOMIPEPI-config-log.txt (Size: 10.33 KB / Downloads: 199)
.txt  DxDiag.txt (Size: 95.77 KB / Downloads: 372)

0
#20 20-02-2017 
@nomi

Try including this card everywhere you put your graphic rules - Video card.sgr - Intel - 1916

Also delete your caches in \My Documents\EA\The Sims2\

They tend to corrupt easily, and stop the game from running when they do. The game will regenerate them so they will be clean. It's good practice everytime you put or take out CC in your game to delete your caches.

Alternatively, you can make them read-only.

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option