Laggy and low fps in The Sims 2
#1 21-01-2017 
  • Registered
  • 2
  • 4
Hello,

I tried to post this two times by now, but it somehow got deleted the first time, and the second time. Nevermind.
I have a pretty stupid problem with the game. Back in the days, I had the Sims 2 with a few expansion packs. The game ran pretty good on my PC, it wasnt a killer machine but It got what it takes to run the game smooth, and at 60FPS /FPS=Frames per second.

I have Windows 7, the 64bit version to be precise, 8GB of RAM ( The Sims uses 4GB, i saw the method on this forum and used it to increase the amount the game could use, because it was locked at 1GB). My graphic card has 2GB, my CPU has 4 cores, each 1,9 Ghz, -but my CPU gets overclocked to 2,4Ghz when playing the game, i can set it to 2,8Ghz, but that doesnt change anything.

Now, I have a laptop, it is a pretty good one in my opinion, and it should handle The Sims 2 well, since it runs The Sims 3 and 4 without any problems at all. What bothers me is that the game runs at 20-30FPS when inside of a family (for example in the Goth family). If I switch to a heavily loaded community lot, or house, the game will drop to 20FPS (the more objects on the lot, the less FPS I get).

I dont have any CC (maybe a few, but it is under 30MB alltogether). I tried deleting everything. I am now going to write what I have tried.

I have tried:
- Reinstalling the game (I have The Sims 2 Ultimate Collection which I have gotten from Origin)
- No CC
- Changing the Graphics Rules and Video Cards file in both the CSConfig and Config folders
- Changing how much RAM the game uses
- Removing SECUROM and adding the noDVD crack
- Removing the *tm* from the registry
- Doing the thing with DEP (also saw this on the forum)
- Changing my resolution from FULLHD (1920*1080) to HD (1368x768)
- Disabeling smooth edges (also by default i have it on the max)
- Disabeling vsync, and also enabling it to see if it makes a difference
- Setting the compatibility mode to every possible OS
- Tried windowed mode
- Setting the CPU1 and 2, both, didnt work

The Sims 2 uses my better graphic card, because I do have two, I am not a noob when it comes to PCs and so on, so I dont think that the error is really obvious. So I am seeking for help.
I added EVERYTHING in the attachment that could be of any help.

Thanks in advance,
Prince

Attached File(s) Thumbnail(s)
           

.txt  MIRZA-PC-config-log.txt (Size: 10.36 KB / Downloads: 93)
.txt  Graphics Rules_copy.txt (Size: 33.62 KB / Downloads: 85)
.txt  Video Cards_copy.txt (Size: 25.94 KB / Downloads: 86)

0
#2 25-01-2017 
@Prince

Can you do a dxdiag for me please, and attach it to the thread. I've not seen a dual graphics card before, and I'm wondering if there's a problem with that and Sims 2. That's a text file, rather than the screen shots. I need it that way so I can compare it with another one I've got.

0
#3 27-01-2017 
  • Registered
  • 2
  • 4
Here you go @celebkiriedhel

Attached File(s)
.txt  DxDiag.txt (Size: 42.82 KB / Downloads: 153)

0
#4 31-01-2017 
  • Registered
  • 2
  • 4
You would need to open a new thread, please read the instructions.

1
#5 01-02-2017 
@Prince

Thanks. I've split their post off to it's own thread.

I'm doing a compare of your dxdiag to mine.

I have 4x3.5, but only 4620Mhz registers for the game with no CPU throttling.

The thing is, Sims 2 was invented prior to quad and octo cores and so doesn't know how to use them - unlike Sims3 and Sims4 which does. It really only just knows how to use dual cores.

This is the numbers that the game uses:

seti cpuLevelHigh 3000
seti cpuLevelMedium 2600
seti cpuLevelLow 2000

Your CPU in your config-log is 2654.399902Mhz, Name:AuthenticAMD, FPU:1, MMX:1 which means that the CPU AS USED BY THE GAME can't cope with high resolution, and the game will drop the fps to cope with what it perceives as lack of CPU power.

For Medium Resolution usage -

uintProp maxResWidth 1280
uintProp maxResHeight 1024
uintProp defaultResWidth 1024
uintProp defaultResHeight 768

So anything above 1280x1024 is going to be reducing the fps.

The problem is not that your notebook is not good enough, its that its good enough in ways that the game doesn't recognise. This is going to be a problem with all computer devices and legacy programs. Not that helps you now, but the next time you want to get a PC/laptop/notebook aim for one where a single core is 3.0MHz or more.

How to make you game less laggy.

1. Configure your game to medium resolution config - Screen Size no more than 1280x1024 - i.e. windowed mode probably will be better if that's not the same proportion as your actual screen.

2. Rather than use the Graphics Rules Maker Graphic Rules.sgr could you swap to this one: Graphic Rules - Radeon, putting it in
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\CsConfig\
MUST BE INSTALLED IN BOTH FOLDERS

I've made a few tweaks to the card, that may help with the lag.

3. Run the game as adminstrator from a shortcut, set the compatibility and so on from the compatibility tab on the shortcut - also set it up as administrator for all users there. For Windows 7, either leave it as Windows 7 or set it Windows XP Sp3. I have mine as Windows 7 nowadays because the updates to microsoft OS have coped with that.

4. Set your smooth edges to max, your vsync enabled - it's not your graphics card that's the problem.

5. Turn off - reflections, ceilings, special event camera, PIP, set shadows to low, or off. Reduce or turn off anything from neighborhood view that can be seen in lot view.

What we're looking for is things that will reduce CPU usage, rather than graphics work - the graphics card is fine.

I have no way of getting Sims 2 to use alll 4 cores. Sorry.

1
#6 05-02-2017 
  • Registered
  • 2
  • 4
Thank you so much for the help, I will try to do as you told me.
I find it aweful that Sims 2 uses mostyle the CPU instead of the GPU Sad
I am going try the things right now, and I will leave feedback Smile

1
#7 15-02-2017 
Thanks Prince. I look forward to hearing how you do.

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option