TS2 freezing up on Win 10 (Intel/Nvidia)
#1 27-01-2017 
  • Registered
  • 1
  • 2
Hello everybody,

Ok, I've been messing around with the .sgr files, graphics drivers and compatibility mode but i can't get the game to run properly. I'm on Windows 10 and my graphics card is a NVidia Geforce GT 540M (notebook), also the CPU can handle graphics as well (Intel HD Graphics 3000).

So, the problems:
1 - The game does not want to run on the NVidia card (although the GPU activity shows the game is using it and I think the game is using it's DLL as shown in the config-log, but despite all that, when I right click the Sims2EP9.exe it shows the graphical default is Intel, no matter how many times I try to change it)
[The DLL thing is confusing as it's seems to be using NVidia's driver but the "Vendor" and "Name" are still Intel... and I've already updated the drivers, the problem persists]
2 - Speaking of right clicking, I can't make the game run in compatibility mode from "Properties" -> "Compatibility" tab (it's missing), so i have to use the troubleshooter and I don't think it's working or it's not making any noticeable difference
3 - And more problematic, is that even if I run the game without the GPU the game will either: run with the texture problem, OR; run but after I load a neighborhood run with a black screen, OR; as it's happening now, run with no texture problem but with locked low resolution. The last two cases accompanied by stuttering and freezing my PC (in sometimes I even need to do a hard reset),
[I understand that the freezing problem might be hardware as I've encountered it before and have to underclock things to keep the system from overheating, but I can run heavier games without freezing that way, it doesn't seem to be working on TS2].

Anyway, sorry for the text wall, but I figure it's more helpful than giving pieces of information from time to time.

Hope someone can help, and any help will be greatly appreciated.

Thanks!

config-log:

.txt  zeplisson-config-log.txt (Size: 10.3 KB / Downloads: 60)

0
#2 27-01-2017 
@zeplisson

If you have a look at your texture memory in your config-log.txt you will notice that it says 32Mb. That means you have the texture memory problem.

If you use this card:

Graphic Rules - Intel - Texture Fix

That will fix your problem. Setting the compatibility, etc makes a difference but only once the game is out of low resolution.

0
#3 28-01-2017 
  • Registered
  • 1
  • 2
Oh, it worked!
I'm sure I tried those Graphic Rules before... I even had it on the download folder already.

No luck with the NVidia but well, I guess the game is light enough for the CPU to handle it alone.

Anyway, thanks for the help

Not running on any compatibility mode so I'll see if the game continues to run smoothly.

1
#4 28-01-2017 
@zeplisson

If you've run troubleshoot compatibilities - then you are running it in compatibility mode.Good luck!

Control of whether it uses NVidia or Intel is outside of the game - in the video control panel, and that's something I can't help you with. If you get it to use the NVidia card, feel free to come back and we'll deal with it then.

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option