EP compatibility problems
#1 16-03-2017 
I realize I had forgotten some stuffed animals in the teddy interactions enabled mod, so I went to add them. I wanted to test them in BG to see how the game would respond to having resources from objects that were introduced in FT, only to realize any version of the mod causes my BG-only-AGS to crash upon loading. At first I assumed it was the FT-teddies, but even with just the BG ones it crashes. I've tried everything I can think of, and nothing works, so I'm turning to you guys in hopes someone has ideas that might solve it.

There are four stuffed animals. Teddybear and plush bunny came with BG. The mod uses TTAB and TTAs, one version just enables interactions for teens-elder, one version makes new interactions with the same code and sets that one for teens-elders so that I could set it to 64 and prevent autonomy. Still causes game to crash when loading.

I set my SimPE to include only BG and CEP, and tried cloning the objects and extracting TTAB and TTAs that way. Same edits as above. No change, still crashes.

I deleted the AGS game and made a new one with BG only. No change, still crashes.

There is no other CC in my AGS game. With the mod package in downloads, crashes on the first step of loading. Without it, game opens fine. I don't get why it would crash from a pie menu from an object that is part of that game. Anyone have any ideas?
gummilutt, proud to be a member of LeeFish since Jun 2013.

#2 20-03-2017 
No ideas, but I used SimPE (with only BG and CEP enabled) to clone the teddy, gave it a new GUID (reused one of mine) and it loads fine into AGS BG only. Not sure if it helps, but you can download the clone from here

#3 22-03-2017 
Yes, that loads fine, but it's also set to private which means it can't be used to fix the maxis one. I did test cloning and extracting resources from clone rather than objects package and it still crashed. But I tried again and this time deleted surplus stuff instead of extracting, and now it's not crashing. So thank you whoward, looks like problem is solved for now.


Sorry, that is a members only option