TS2 UC Refuses to Run Properly on Win10
#1 18-03-2017 
  • Registered
  • 4
  • 8
Hello everyone, I am fairly new here.

So I have been playing The Sims 2 for years on Windows Vista and Windows 7. I just recently got a new computer with Windows 10 installed, and it did not have a disc drive. I contacted EA support and without any fuss I was able to download the UC. When it ran the first time, it made it to the neighborhood screen but I didn't test it further. I transferred my hoods, downloads, and other necessary file tweaks (lighting and cameras) over and reloaded, but the game crashed half way through loading. I tried different methods of troubleshooting, but it continued to crash, even on vanilla (which leads me to believe that the first load was just a stroke of luck, or it might have crashed later on if I had tried to get into CAS, etc).

I am attaching my log in hopes that I can be pointed to some fixes or workarounds that might be needed. Thank you so much for any and all help.


.txt  DESKTOP-D1B84DQ-config-log.txt (Size: 9.49 KB / Downloads: 89)
(This post was last modified: 18-03-2017 05:25 AM by PhoenixIsLost.)

0
#2 18-03-2017 
Can't help - but I've got the same problem... Waiting with bated-breath for a suggestion Wink

Have you read through these threads:
http://answers.ea.com/t5/The-Sims-2/Sims...-p/3204715
https://forums.thesims.com/en_us/discuss...ont-launch

I've done the paul.dll thing and am now stuck with the "Unable to open Languagefile "lang.ini"" problem...
I've repaired several times...
Wouldn't start before removing secuRom; won't start after removing it either. It just won't start. *sigh*

0
#3 18-03-2017 
  • Registered
  • 4
  • 8
Aaaaa, okay, I have an update from last night. I was too tired to report back until today. So I did more sleuthing and took the instructions from celebkiriedhel to update my graphicrules.sgr as well as my Video Cards files, and I believe that I did them correvtly, because my config log now looks like this:
.txt  DESKTOP-D1B84DQ-config-log.txt (Size: 10.18 KB / Downloads: 122)

And it did indeed give me options for different resolutions, as well as shadows and smooth edges again. I did have the black box problem and I ended up putting shadows to medium for the time being. (I did just find the fix by Nopke on MTS, and I will try that later). I was still getting crashes, though. When I went into the error logs, they were pretty consistently telling me that there was an access violation. I then ran in compatibility mode, Windows suggested Vista and I rolled with it because I had been able to run TS2 on Vista for four years without issue. That allowed me twenty minutes of smooth gameplay in one of my larger households before it inevitably crashed when opening the clothing catalog. The error that time was that I "ran out of video memory." So the game runs incredibly smooth when it's not crashing.

@CatherineTCJD, I haven't read those threads, so thank you for pointing me to them. And good luck finding a solution as well. If only official support for TS2 was still available. (But I mean, it's EA, so I guess that's too much to ask for, lol).

ETA: I went back in to try to run the game again, and this was the dialogue that popped when it crashed.    
(This post was last modified: 19-03-2017 12:26 AM by PhoenixIsLost.)

1
#4 20-03-2017 
@PhoenixIsLost

That sounds to me that the display memory is still wrong for you. We can fix that - it's just a matter of changing the texture memory to what your display memory actually is.

If you do a DxDiag, and post it up here, I can fix it for you - or alternatively I can tell you how you can fix it yourself.

To do DxDiag -

Press the Window Button + "R" to get up the Run Window
Type 'Dxdiag' into the Run dialog window and press enter will bring up the DxDiag Window.
Press 'Save all Information...' at the bottom of the DXDiag Window. It will create a Dxdiag.txt

Attach DxDiag.txt to this post.

Sorry I haven't been answering - I'm having another depressive episode and so it's problematic when I can answer and what I can do.

0
#5 20-03-2017 
  • Registered
  • 4
  • 8
@celebkiriedhel there's no need to apologize! I live with chronic depression myself, so I completely understand. Take your time.

I did as you asked and here is my DxDiag:
.txt  DxDiag.txt (Size: 81.14 KB / Downloads: 87)

Thank you so much for your help. I would be totally fine with just instructions on what to do. I'm not a tech genius but I am good at following directions. Smile

0
#6 20-03-2017 
If you go to your graphic rules.sgr that you installed in

In the Program folders:

\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\CsConfig\
MUST BE INSTALLED IN BOTH FOLDERS

In Graphic Rules.sgr search for 1744

it will bring up a line
# Kiri - manually setting texture memory
seti textureMemory 1744

Change the 1744 to the display memory in the dxdiag.txt
Display Memory: 8089 MB

so seti textureMemory 8089

save it in both.

Then try it again and let me know.

1
#7 20-03-2017 
  • Registered
  • 4
  • 8
That didn't seem to do the trick. I crashed just at the end of loading on the splash screen. :c

ETA: Because it crashed at the splash screen, the exception log didn't actually have any information on it. I tried again and the game allowed me all the way into one of my households and I pulled up the clothing catalog since that has been consistently crashing my game. The log this time is different from what I usually get (Access violation or Out of video memory). It's just the code and a dot.
.txt  Sims2Exception 2017.03.20 14.43.30.txt (Size: 13.64 KB / Downloads: 131)
(This post was last modified: 20-03-2017 07:48 PM by PhoenixIsLost.)

0
#8 22-03-2017 
@PhoenixIsLost OK. we're going to go through some other things as well.

1. Are you running it as admin?
2. Are you running it in compatibility mode - For Windows 10, it should be set to Windows 8.
3. Are you running it in windowed or full-screen mode?
4. Are you running it with CC?

Also, can you put up a new version of your config-log.txt - that will tell me if the texture memory change took.

0
#9 22-03-2017 
  • Registered
  • 4
  • 8
@celebkiriedhel here is the new log.
.txt  DESKTOP-D1B84DQ-config-log.txt (Size: 10.18 KB / Downloads: 106)

I have tested a lot of those things, but because I've gone through so many test runs, I honestly can't remember if I did them all at once, so I will try that. I play in full screen and full screen was working when I did a vanilla test originally. I flipped between the two when I did my other tests and they both crash on me once I get to a certain point (like the clothes catalog).

I've gone ahead and taken both my cc and my 'hood out to test on vanilla, I'll let you know what happens. Thank you so much for your patience with me.

ETA: I seemed to get the game to work fine on vanilla. The clothes catalog did not crash. I'm going to try again now with cc and my regular 'hood. I'm also trying windowed mode again to see what happens.

2nd ETA: I have a strong feeling that it's my cc. I made a little further into the clothing catalog than I did before, but it did ultimately crash, and this was with my cc installed.
(This post was last modified: 22-03-2017 08:20 PM by PhoenixIsLost.)

0
#10 23-03-2017 
@PhoenixIsLost

Do you know how to do a search on your CC for the one that is crashing your game? You need to do a split-search - that will help you find the one that is the problem.

Seeing as it is probably a CC problem at this point, lets talk about download hygiene.

Things that cause problems:

1. Corrupted CC - this has to be weeded out. Seeing as you know it's a clothing CC, the easiest way to find this is doing a half-and-half search.
a. In your vanilla game - put 1/2 of your CC.
b. Does it crash? No - Put that CC aside, it's ok and go to the other half. Yes - Split that CC in two.
c. Have you only one piece of CC left? No - take then next half and go back to A.

So for example - if you have 10 pieces of CC, and one of them is corrupt, the first half will be pieces 1-5.
1-5 goes into game. Does it crash?
Yes.
1-3 goes into game. Does it crash?
No.
4 goes into game. Does it crash?
Yes.
4 is corrupt.

This sort of search should work no matter how many you've got. It's called a Binary search in computer circles.

It's also probably a good idea to remove duplicates, empty packages, and non package files as they can cause problems as well.

Delphy's download organiser will help with the empty packages. http://www.modthesims.info/download.php?t=227925
Djfade's decrudlator will remove non package files. Alternative Download for Decrudulator
And Duplicate finder will remove duplicates. http://www.funduc.com/dupfiles.htm

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option