Related issue Windows 10 Graphics and Ram
#1 26-03-2017 
  • Registered
  • 2
  • 4
I have been stumped to figure out this one. I have a Windows 10 Home 64-bit system. I built this machine about 3 years ago, and at the time was middle of the road. I have 4 GB of RAM and an A6-6400K processor. That might be where this issue lies. It is a dual core, but the way AMD made the processor it acts as a single core. I have updated all my drivers for the processor and motherboard. I have gotten the Radeon fixes for graphics and have no problems with graphics - once it loads.

My problem is that I have 4GB of RAM and the Sims 2 refuses to see more than 1GB of RAM. This is causing the system to freeze on loading. Eventually it will start, but every time I change modes or in the neighborhood switch to lot mode, the system freezes for a minute or so, and then acts fine until I switch again. Shall we say house builds are not easy at all now. I have removed all custom content from my game and still have the problem.

I attached both my Log and DX info.

Attached File(s)
.txt  DxDiag.txt (Size: 68.24 KB / Downloads: 96)
.txt  GALLIFREY-config-log.txt (Size: 10.26 KB / Downloads: 80)

0
#2 27-03-2017 
@lala7dipiti

Looking at your config-log.txt and dxdiag - you have plenty of oomph for Sims2. The problem is going to be because of Windows 10, or the way you've done your graphic rules/video cards.

Go to this thread: 'LAG Issues - Possible Solutions'

Do Solutions 1 and 3. That will help with the lag and give you more RAM memory.

Apart from that - you have a problem with your card -
Name (driver): AMD Radeon HD 8470D
Name (database): Radeon HD 8470D

These two need to be the same.

Download this card Video Cards.sgr - Radeon - 9996 and install it where you've installed your up to date graphic rules. You don't mention if you have Ultimate Collection or the DVDs.

Also - check the compatibility setting, and if you are running it as admin.

Finally - is the smooth edges on Max.

0
#3 02-04-2017 
  • Registered
  • 2
  • 4
I ended up figuring out that the Sims 2 UC was not the only issue I was having with the system, so I wiped my drive and reinstalled everything. Apparently, without changing anything in settings, Sims 2 now sees 2 of the 4GB of RAM. I checked a couple of other programs and figured out it is because of the CPU I have using the RAM for graphics the system is automatically only showing only half the RAM to a program. The lag is still there, but I have a feeling it is because of Windows 10 and Sims 2 not playing well together. I did fix the database error when reinstalling so the graphics and shadows are acting normally.

1
#4 03-04-2017 
@lala7dipiti

Can you do me a new config-log.txt? That will let me know what's happening.

0
#5 10-04-2017 
  • Registered
  • 2
  • 4
Sorry I have been away from my computer for a few days. Here is the updated file.

I have gotten most of the issues worked out. Yes I have smooth edges on and also run as administrator. The compatibility wizard in Windows 10 hates me and crashes out every time I try to alter it, but I just made the shortcuts require to Run as admin. I did also try deleting thumbnails before playing and notice that that helps a huge amount, but still there is a delay.

Attached File(s)
.txt  MOM-config-log.txt (Size: 10.27 KB / Downloads: 72)

0
#6 15-04-2017 
@lala7dipiti

You can do the compatibility on the shortcut as well.

Have you got the more than 2G memory fix (CFF Explorer) in?

Cause the only other thing I can suggest is that you need to cut back on your CC.

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option