The Sims 2 UC Directx 9 error...
#1 28-04-2017 
ETA: improved the title of this thread!

Sorry, you must have answered this a thousand times already.. But since every computer is different, I thought I'd try to ask for individual help..

So I installed TS2 Ultimate Collection from Origin. I started the game in windowed mode and it started alright, but strangely it was forced to run at 800x600 res and on rather low graphic settings even though my PC has a much bigger res screen and should be able to run TS2 way better than that.

I decided to update my graphic card drivers, downloaded them from the appropriate website and let them install. I was then asked to restart the computer - done.

And now... The game won't start at all anymore, instead I get the very common error:

Quote:"Failed to Enumerate any DirectX 9 Compatible graphics adapters in the system!

Please make sure you have a DirectX9 compatible graphics adapter and have installed the latest maufacturer provided driver.

The Application will now terminate..."

What the...? So I unintentionally made the situation go from bad to worse, it seems. Although, well, if I had to play the game with such awful graphics, then I don't wanna play at all I guess...

Things I've tried:
- Start the game from Origin
- Start the game by "run as administrator"
- Start the game from the latest EP's TSBin

None of those work.

I've uploaded the config-log file here.. Hopefully it contains useful info for you.. I noticed that it says "<<NOT FOUND IN DATABASE!>>" at one point and that worries me...? But why did the game start at first..? A mystery.

My operating system is Windows 7 Professional 64-bit

Thanks in advance for any help!!

Attached File(s)
.txt  OMISTAJA-PC-config-log.txt (Size: 10.29 KB / Downloads: 195)
(This post was last modified: 29-04-2017 04:32 PM by sako.)

0
#2 30-04-2017 
I'm sorry for the double post, but I'm just trying to get this thread noticed.

I'm getting really desperate here Sad I just want to play TS2...

0
#3 01-05-2017 
@sako

Please Download these cards:

Graphic Rules - Intel - Texture Fix
Video Cards - Intel - 67ef

you will need to install them into these folders:
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\CsConfig\
MUST BE INSTALLED IN BOTH FOLDERS

That should fix your problem. Go into your game and have a look. If not, come back here with a new config-log.txt.

0
#4 01-05-2017 
First of all, thank you for trying to help me! Much appreciated Smile

I installed both of those files in both of the folders you mentioned, made sure that I followed the right folder paths and all.
But I'm still getting the same Directx 9 error.

I attached the config-log again, although it seems like it hasn't changed/updated at all, it still says "Log generated on 4/28/2017, 20:08"

Attached File(s)
.txt  OMISTAJA-PC-config-log.txt (Size: 10.29 KB / Downloads: 132)

0
#5 01-05-2017 
@sako That would be the wrong config-log.txt then - it should have changed the date in it.

What do you have in your logs folder - can you give me a screenshot? I'll have a look and see if there's a different problem.

Could you set up your compatibility on your Sims2EP9.exe to WinXP SP3, that *may* help. Although it does sound like it's not picking up the cards.

I'm assuming that you unzipped them and let them overwrite what was there?

0
#6 01-05-2017 
Tried the compatibility mode change - nope, didn't work.

Yes, I unzipped the files and let them overwrite the ones that were already in the folders.

I attached three screenshots to this post:
- The logs folder
- The config folder
- The CSConfig folder

It is strange that the config-log file did not update itself even though almost all of the other files there are now dated 1.5. (today)

My OS language is Finnish but I can translate stuff if needed Smile

           

0
#7 02-05-2017 
@sako

OK. I want you to try something for me. What I want you to do is rename your
\my documents\EA Games\The Sims™ 2 Ultimate Collection\ to
\my documents\EA Games\The Sims™ 2- SAVE\

Then rerun your game. That will regenerate a new game and hood. Then I want you to give me the config-log.txt from that one. It will make sure that there is nothing from the Custom Content that is interfering with the game.

I notice that you had two non-zero size files that had the old date, Custom Content Objects.txt as well as the log, and you had other zero size files that I would have expected to be non-zero.

Often times re-running in a new game and hood will show us where the problem is.

0
#8 02-05-2017 
Alright - done.

Here's what happened when I renamed the folder and rerun the game:

- The same error occurred again
- A new TS2 UC folder was generated
- ...But the only sub folder inside it is "logs"
- And that folder does not contain a new config-log file at all..
- The original config-log file inside the renamed folder remains unchanged

I attached a screenshot compilation of the folders.
Huh

Attached File(s) Thumbnail(s)
   

0
#9 03-05-2017 
@sako

Question....have you tried installing DirectX 9.0c on your computer? What I understood is that any later DirectX versions are backwards compatible, except for DirectX 9.0c. That 9.0c version is a special case. Try downloading it and install it.

EDIT: Here, try this link below from Microsoft
https://www.microsoft.com/en-us/download/details.aspx?id=8109

EDIT 2: You might be better off using their web installer so that the missing 9.0c components are installed to your system, rather than trying to install the entire library, since apparently Windows 7's Direct X11 has some, but not all, of the files from the DirectX 9.0c library. EDIT 3: It may also be cause you updated the drivers of your graphics adapter, but certain 9.0c files got corrupted? This web installer (hopefully) might be able to fix that:
https://www.microsoft.com/en-us/download...aspx?id=35
(This post was last modified: 03-05-2017 01:53 AM by d_dgjdhh.)

0
#10 03-05-2017 
Thank you for the suggestion, @d_dgjdhh !
I downloaded the installer and here's what it told me:

"DirectX Setup has determined that a newer or equivalent version of DirectX has been installed already. No installation is necessary."

And then the only option is to click OK.
Trying to open TS2 only gives me the same old error message .

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option