DirectX 9.0c Error
#1 11-05-2017 
  • Registered
  • 1
  • 3
Hello,

I've downloaded the Sims 2 Ultimate collection from origin and I've had problems with it crashing every time I've tried to create a family. So I tried your solution and I've been getting the DirectX 9.0c Error. The only time it will let me into the game is if i edit back the old Graphic Rules back instead of renaming it with old to the end. I also have Windows 8.1

Attached File(s)
.txt  MINNIEWALKER-config-log.txt (Size: 10.41 KB / Downloads: 30)
(This post was last modified: 11-05-2017 08:45 AM by tminnie98.)

0
#2 11-05-2017 
@tminnie98

What exactly did you use, and what did you do?

Looking at what you have in your config-log.txt you need to use these cards:

Graphic Rules - INTEL
Video Cards.sgr - INTEL - 0166

In these folders:
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\CsConfig\
MUST BE INSTALLED IN BOTH FOLDERS

Are they the ones you used?

Also, you need to set up your exe to run as admin, and troubleshoot compatibility to Windows 7.

Is that what you did?

0
#3 11-05-2017 
  • Registered
  • 1
  • 3
@celebkiriedhel

I only put the Graphic Rules, but have now but the Video Card as well. I know how to trouble shoot compatibility to Windows 7, but how do I set up my Exe to run as admin?

0
#4 11-05-2017 
  • Registered
  • 1
  • 3
@celebkiriedhel I figured out what I was doing wrong, I hadn't unzipped the .rar file. I guess I missed that step in your explanation. However, I would still like to know how to set up my Exe to run as admin

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option