Sims 2, Windows 10, & Brand new flickering
#1 16-05-2017 
  • Registered
  • 0
  • 2
Hello!

I've been playing The Sims 2 (Store Edition) on my current system configuration for about two years, but as of today, the game is slow to load the EA logo. When it does, it flickers, which continues persistently through the loading process up to the main menu and the neighborhood. I initially assumed that this was due to a driver update, so I made sure I had the NVidia driver (after trying the most recent from Lenovo and through Windows Device manager), but I'm totally stumped. Last time the game loaded successfully (and free of these relentless flickers), I noticed that the black boxes had reappeared beneath my sims, so I shifted Shadows back to off. Now, when it loads all flashy. "shadows" is greyed out and set to off. I haven't installed any new content before these flashy loads nor did I when I got the black box flash-free load. Would you please help me figure out what's going on?

I tried your NVidia texture fix (in the location in SE, since that's what I'm running), but it didn't work any better than the last modded that had been working just fine. Both times, I had my card in the Video Cards.sgr files. Would you please help me/ I'm totally stumped Sad

I'm running a NVidia Quadro 1000M (0dfa) on Windows 10 with the latest updates available for my Lenovo Thinkpad W520-4270.

Attached File(s)
.txt  PROTEA10-config-log.txt (Size: 10.4 KB / Downloads: 8)
.txt  Video Cards.txt (Size: 26.68 KB / Downloads: 7)

0
#2 16-05-2017 
@Starrytrek

Can you give me a dxdiag. I'll need that to compare with what you've got in the config-log.txt.

Your video cards set up is incorrect - the driver and the database need to have the same name.
Name (driver): NVIDIA Quadro 1000M
Name (database): Quadro 1000M

However the video cards.txt that you've posted doesn't have it in there - is that your current video cards.sgr?

Can you check that you are set up to run as admin, and you have smooth edges up to max? That's usually what the flickering is about.

0
#3 16-05-2017 
  • Registered
  • 0
  • 2
Thanks celebkiriedhel. Unfortunately, the problem's persisting.

I can confirm that I'm running as admin with "more" smooth edges, and I'm still flickering. However, now, instead of starting at the logo and intro, the flickering doesn't start until halfway through the loading screen (still continuing...everywhere).

I'm sorry for attaching the wrong file; I've got the right Video Card file as well as what I'd been using for graphics (I did try your Nvidia texture fix file before posting) and Dxdiag.

Thank you for your help.

Attached File(s)
.txt  Video Cards.txt (Size: 26.74 KB / Downloads: 4)
.txt  DxDiag.txt (Size: 89.93 KB / Downloads: 5)
.txt  Graphics Rules.txt (Size: 33.3 KB / Downloads: 4)

0
#4 Yesterday 
@Starrytrek

I'm going to make you up a new Video Cards and Graphic Rules - they both need changing.

Download Video and Graphic config cards

That *may* help, pop them in the right place - where you got the ones you've attached.

One of the things that was wrong is that your display memory is much higher than what the game is thinks you have. I've corrected that. The card name is fixed as well, and that may help as well.

Anyways, try that - and pop up the config-log.txt after you put them into the folders, and set up the game.

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option