Sims 2 won't start on NVIDIA card, E_INVALIDARG error message.
#1 18-06-2017 
  • Registered
  • 1
  • 4
Hello there! I get the E_INVALIDARG! message on my Windows 10 laptop and I tried various thing, including following this tuturial:
http://www.leefish.nl/mybb/showthread.php?tid=6881

Because my NVIDIA GeForce GT 750M graphic card wasn't in the list I used this tuturial:
http://www.leefish.nl/mybb/showthread.php?tid=6882
to add it to Video Cards.sgr

After all of this, it still won't start on the Geforce card. It will start on the intel card but it works slow and weird on that. Not sure what I did wrong or how to fix the E_INVALIDARG! message.
I included not only the config-log.txt from the Logs folder but the edited files too just so you can check if I actually did it right. They are all in the .zip file.

Thanks in advance!
Big Grin

PS, its awesome that there is a whole forum deticated to helping Sims 2 users to help start the game!

Attached File(s)
.zip  Sims 2.zip (Size: 25.28 KB / Downloads: 98)

1
#2 23-06-2017 
@Gambituser

You've done all the right things with your graphic rules, so we'll need to do a bit more troubleshooting:

I'd like you to do the following things:

1. Delete the groups.cache, cigen.package, Accessory.cache from your My Documents/EA Games/The Sims 2/ folder
2. Right Click your properties on your shortcut, and change your compatibility mode to Windows 7. Change to admin run, and for all users.
3. Remove all your collections and CC if you have them in there. (This will narrow down where the problem is - whether it's the game or the CC. This is just a temporary thing)
4. Attempt to go in the game.

Come back and let me know what happened.

1
#3 23-06-2017 
  • Registered
  • 1
  • 4
Thank you, celebkiriedhel for replying!

I have done the following things.
1. Deleted the groups.cache, cigen.package and Accessory.cache
2. changed compatibility to Windows 7 (before this, i tried it with Compatibility windows xp) and i already turned on Run as admin. What do you mean with "all users" though? Something on the Security tab?
3. Before i made this thread i freshly installed the game. I only even gonna think about CC once get the game running succesfully.
4. Restarted the game and sadly it still gives me the same error "E_INVALIDARG! message" and then it closes. Same as before Undecided

I hope we can solve it! I tried playing on the other intel card i have, and i actually got it running smooth on smaller lots, but once im on bigger lots, it becomes laggy especcially when i zoom out, obviously because the intel card is a piece of crap... It even proves this because it runs slightly less crappy on lower settings but still too crappy
(This post was last modified: 23-06-2017 03:00 PM by Gambituser.)

0
#4 24-06-2017 
@Gambituser

[Image: compatibility.jpg]

I'm talking about this button in the image. The compatibility tab *should* be there on the shortcut that you use to launch the game.

0
#5 24-06-2017 
  • Registered
  • 1
  • 4
@celebkiriedhel

I don't have that tab at all, not in my short cut on my game, not if i make a new shortcut of the .exe file, and not on the .exe file itself, i used the right mouse button to change compatibility and used "compatibiliteitsproblemen oplossen" which is dutch for Solving compatibility issues, which is how i got it the compatibility to Windows 7. Now my computer is in dutch so this is going to make it a little harder to show you, but im going to show you anyway.

This is my short cut settings if i right click it:
[Image: zke3nA0.png]

As you can see where the arrow points, this is where the compatibility should be but isn't. For other games it is. Now i don't really see how this is much of an issue with the "all users" thingy because i did the rest of the things anyway. Unless that "all users" thing is literally the problem, i also have the right compatiblity with using this:

[Image: Si8T9qK.png]

So i got the right compatiblity, I start it in admin mode just fine. And all the shortcuts in the world that i make of Sims 2 dont give me that compatiblity tab nor does the game itself as you can see here:

[Image: GMCmpQN.png]

0
#6 25-06-2017 
@Gambituser

Yup. OK.

Change settings for all users just makes sure that the compatibility and admin settings are set up no matter which account you go through. That was just to make sure the settings were being used.

You mentioned that you have an Intel card as well, but it has lag issues.

Can you do a DXDiag for me and upload it (as a text file), what I want to do is have a look at the graphics settings, and the system settings to see if I can work out what's happening.

0
#7 25-06-2017 
  • Registered
  • 1
  • 4
Ty for replying @celebkiriedhel !

Yes so i thought, I do have 2 users on my laptop, but I never use the other user for anything game related. I barely use it as it is...

Anyway here is the DXDiag as a text file!

Attached File(s)
.txt  DxDiag.txt (Size: 95.95 KB / Downloads: 100)

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option