Sims 2 W10 "The application has crashed" on start
#1 22-06-2017 
  • Registered
  • 2
  • 4
Hello,

I have arrived at this site after browsing the web for solutions to my game crash on Sims 2 for the past days. After seeing the good quality of contents and atmosphere here I thought I would try and explain my problem and hope that Kiri would be able to help me.

Problem: When I start the Sims 2 EP9, I get a purple screen where I can only see the cursor. Nothing can be clicked or done in there and it does not progress into anything else. If I Alt-Tab I can see that I have a little window with an error message that says: "The application has crashed. The application will now terminate" with a header that says "The Sims 2: Mansions & Gardens stuff (see attached image).

OS: Windows 10

I have tried several fixes suggest by other people who managed to make Sims 2 run on W10. I have downloaded the proper GraphicRules for my graphic card (NVIDIA) as you suggested in another topic, changed the maximum screen resolution to fit that of my screen (2560 x 1440 px), I downloaded and used your graphicsrulesmaker, I have also tried running the application with admin rights but I have not been able to fix the issue so far.

I attach a print screen of the error message (I cannot seem to capture the purple screen), my config log, the crash log (Sims2Exception) and my GraphicRules (converted to txt).

Thank you very much and please let me know if there is some other file that I should attach or information that I should provide that could help.

Marc

Attached File(s) Thumbnail(s)
   

.txt  DESKTOP-Marc-config-log.txt (Size: 9.39 KB / Downloads: 89)
.txt  Sims2Exception 2017.06.21 20.22.48.txt (Size: 16.38 KB / Downloads: 69)
.txt  Graphics Rules.txt (Size: 33.62 KB / Downloads: 95)
(This post was last modified: 22-06-2017 07:00 PM by Marc.)

0
#2 23-06-2017 
@Marc

Hi Marc - your graphic rules looks fine.

What compatibility are you running your game on?

I'd like you to do the following things:

1. Delete the groups.cache, cigen.package, Accessory.cache from your My Documents/EA Games/The Sims 2/ folder
2. Right Click your properties on your shortcut, and change your compatibility mode to Windows 7. Change to admin run, and for all users.
3. Remove all your collections and CC if you have them in there. (This will narrow down where the problem is - whether it's the game or the CC. This is just a temporary thing)
4. Attempt to go in the game.

Come back here and let me know what happened.

1
#3 23-06-2017 
  • Registered
  • 2
  • 4
@celebkiriedhel thank you for your message.

I have tried what you told me to do but I still get the same error.

I have removed the collections (the files in Collections folder), groups.cahce, cigen.package, and accessory.cache and ran the game on Windows 7 compatibility mode and admin mode (also tried Windows XP SP 3 compatibility mode and it does not change anything).

Also, I do not know if this could be relevant, but I was unable to patch some of the expansion packs (because the updater was crashing in the same way). I also had to force cancel the "now the installer will check if your game is up to date" at the end of each installation by restarting the computer, so that the game would actually install, since the updater would crash and abort the installation otherwise. But I have heard people who did this and are able to play anyway so I do not see why it would matter.

Any more ideas?

Thank you for your time and effort!
(This post was last modified: 23-06-2017 07:28 AM by Marc.)

1
#4 24-06-2017 
@Marc

Hmmm - OK. I think we need to reinstall your game, but in a different order to what you may be used to.

Start by taking everything in the My Documents folder, and save it somewhere else.
Then Uninstall all the Sims 2 and expansion packs.


Lets start with just installing the Base Game, and see if that works.

Also can you do me a DXDiag, and upload it? (Just as a text file please).

0
#5 24-06-2017 
  • Registered
  • 2
  • 4
@celebkiriedhel

I attach the DXDiag for now.

I have uninstalled the base game and all expansions. Then, I reinstalled the base game (it works), and with the expansion pack "Mansions and Gardens" and it also works.

Now the problem is that when I try to install the other EP, they are not being recognized as installed and I cannot use any of the neighborhoods or features contained in them (they show as greyed out in the main menu in-game). I have tried uninstalling "Mansions and Gardens" and installing it again but it still only recognizes the main game and "Mansions and Gardens" EP as installed, the others are as if they would not be installed. They are all in the same folder and most of them patched (University and Nightlife patch updater crashes every time and I cannot patch those EP).

Any suggestions on what to do?

Now I can play the base game but I would really like to have all the EPs since they bring the flavor I remember from Sims 2 and that I want to have in my gameplay.

Thanks a lot Kiri! Smile

Attached File(s)
.txt  DxDiag.txt (Size: 70.11 KB / Downloads: 89)
(This post was last modified: 24-06-2017 09:31 PM by Marc.)

0
#6 25-06-2017 
@Marc

I didn't ask you to install any except the base game, because I wanted to see what is happening with that. Can you uninstall the Mansion and Gardens please.

Eventually, I hope that you will have all your expansion packs, but right at this moment I'd like to see just the base game.

Also can I get a copy of your config-log.txt with just the base game installed.

0
#7 27-06-2017 
  • Registered
  • 2
  • 4
Hey @celebkiridhel,

I am happy to inform you that I was able to solve the problems. I managed to receive The Sims2 Ultimate Collection from EA and with a clean installation all the problems went away. Thank you for your help Smile

Marc

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option