Game lags when switching between sims
#1 09-07-2017 
Hi everyone!

I just want to say thank you to everyone on here. With your tips and help I am able to play The Sims 2 on my Windows 10 desktop. But unfortunately, after a long time of gameplay, I am hitting another issue. After only about 10-15 minutes of playing, the game lags when switching from one sims to another. I am not sure what is causing this. I have sorted out my CC a long time ago, the game works well for the most part, and I have no issues loading lots. This lag is getting to the point where it slows down gameplay and I do not even want to play anymore. The lag lasts anywhere from 5-10 seconds. This has been happening for the last few weeks. In that time, I have only downloaded a few things, and even taking those things out does not help. I have tried no CC, changing the graphics settings in -game, even using the Batbox to force errors on the lot. I have noticed this happened shortly after Windows 10 had a big giant update.

I have the Sims 2 game with all the expansion packs (not the UC) on a Windows 10 desktop.

Attached File(s)
.txt  SARRA-PC-config-log.txt (Size: 10.2 KB / Downloads: 26)
Spiky_Kitty, proud to be a member of LeeFish since Jan 2015.

0
#2 14-07-2017 
  • Registered
  • 3
  • 8
Your config log looked like there wasn't a large issue so I might not be a huge help, BUT, have you done the normal things? Clearing caches and such? If so, I would recommend checking your CPU usage. The only thing I can see in my own game is that with the new Windows 10 update, there is a program that is taking up about 99% CPU usage, which really damages a game, especially The Sims 2. (https://fossbytes.com/how-to-fix-high-ra...e-process/ , that article might help). I had a similar issue and doing this really helped my game out.

1
#3 14-07-2017 
Thanks I will check this article out. Did you do all the steps in the article ? I am not sure which ones I should try.

0
#4 16-07-2017 
Hi there, have you tried removing Securom from your game?

Here's the thread that tells you how to remove Securom and lists a few other causes of lag in case that's not your issue: http://www.leefish.nl/mybb/showthread.php?tid=7127
After removing Securom you can get the no-CD .exe here: https://m0001.gamecopyworld.com/games/pc...%20v1.0%20[MULTI16]%20No-DVD/Fixed%20EXE

1
#5 18-07-2017 
Will this work even though I do not have the ultimate Collection? I just have the regular sims 2 with the separate expansion packs, so I am not sure if they ever included Securom.

0
#6 19-07-2017 
It will still work, I have the discs also, installed on another system Smile From what I recall through reading about it, SecuRom was added with Seasons and every pack after it so if you have any of those then SecuRom is included, as far as I know anyway.

1
#7 22-07-2017 
  • Registered
  • 3
  • 8
Yes, you do have SecuROM. Actually, SecuROM is what made me switch over from my discs to the UC.

Here's a link that should be useful, from here as well Wink http://leefish.nl/mybb/showthread.php?tid=6688

1
#8 26-07-2017 
Thanks a ton for this info! I will try the steps to get rid of Securom and update Smile

0
#9 27-07-2017 
Update: So, I tried the Securom fix and the no CD crack...and it works perfectly! No more lag at all. It took me a couple of tries to get the game going...for some reason it would start up then have a blank screen even though i heard the loading music...but now it's ok. the game crashed after a couple hours of playing..which is normal for me when I do not play the game for a few days. Thanks everyone for your help.

0
#10 28-07-2017 
That's great, enjoy your simming!

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option