Sims 2 UC Crashing During/After CAS
#1 14-07-2017 
  • Registered
  • 3
  • 8
Hello! In a rather primary and upfront regard, I thank and really appreciate any help that is given to me towards this issue! Heart

OS: Windows 10
Explanation: I'm rather good at these things myself and I've figured out all of my other errors, yet, this one has me truly stumped. From my upgrade from Windows 7 to 10, I didn't bother with Sims 2 with SecuROM and whatnot... knew it wasn't a good idea, so I got the UC. It took about 6 months for me to get going and everything runs rather beautifully, but this does make the game unbearable to play because I cannot make any new families.

I will launch the game and it will take about fifteen minutes to load. Before loading up to the neighborhood screen, the loading screen will flash black for a moment before finally loading up. The neighborhood loads as normally, goes into CAS normally. No issues there. When I begin to make the sims/save the family & export into the neighbourhood, it will crash, saying "The Sims 2 Mansion & Garden Stuff: This application has crashed. It will now terminate." (perhaps not identical to that but certainly along those lines). Other than that, I have absolutely NO other issues I have experienced thus far, and if I did, I've gotten rid of them myself.
Now, I do have custom content, I'm a huge sucker for it. However, I have disabled it and uninstalled it, yet I cannot make this issue go away. I have also changed my graphics card to what Kiri has already recommended and added my own graphics card in there (HUGE THANK YOU to that, Kiri!). I've looked through into COUNTLESS things that I believe were the problem and nothing has come up and fixed it.

I know that I rambled a bit but if anyone could lend a helping hand, I would greatly appreciate it. I'll be sure to give that same amount of kindness in any way possible! x

.txt  LENOVO-PC-config-log.txt (Size: 10.41 KB / Downloads: 382)

#2 23-07-2017 
  • Registered
  • 3
  • 8
So, I have figured out some various issues and have fixed them. The game was working better, but the original issue with crashing hasn't stopped. It has started doing a black flash during loading screens then onto the choosing of a neighbourhood. Everything is fine and dandy whilst inside of a lot, but the CAS in itself still is a gigantic issue. Since I've been looking at my own log and really not finding anything worth mentioning again, I'm going to include my Exception and see what exactly can be found from there as well. I'm, unfortunately, awful at decoding and figuring out what Exceptions say, but I am prevailing!


I have done CFF Explorer, that truly works wonders for UC on Windows 10
- I have used Clean Installer to let me know of any corrupt downloads and have used Decrudulator to remove any duplicates/bad cc/etc.
- I am continuing to delete any caches I can. The typical ones with addition to the Thumbnails folder and Neighbourhood Manager.
- I have my CPUCount to 1, I tried 2 and the game tended to lag on 2 so I've went down to 1.
- My custom content folder is 9.90 GB. 27,546 items. I have it already organized but I have used Delphy's Organizer to make it even more organized. Can never have too much, am I right?!

I can't think of any more extra useful information to input... Confused

I'm going to run a clean game and see if it's CC at this point (although I have already done this, you can never have too much of this either!)

Attached File(s)
.txt  Sims2Exception 2017.07.23 16.01.03.txt (Size: 13.42 KB / Downloads: 362)


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option