Flickering Problem - Sims 2
#1 11-09-2017 
  • Registered
  • 2
  • 5
Hello, I need help with the flickering thing that's happening on my game. Every time I move the game it flickers, and it's super annoying >_<. I've been looking around the internet for the past few days, but nothing has helped my game. Below I have attached my Config Log. Also, I forgot to add that well the smooth edging is also grayed out, and I've tried many things, but I just can't ungray it.

Edit: My operating System is Windows 10 Home

Attached File(s)
.txt  DESKTOP-453I87O-config-log.txt (Size: 10.38 KB / Downloads: 70)

0
#2 13-02-2018 
  • Registered
  • 2
  • 5
If someone can still help with this, thank you Smile

0
#3 17-02-2018 
What many things have you tried? We can help but it helps us to know what you did already. Looks like you have some of Kiri's sgr files but the game is not finding your graphics card. Let's start with that. You need to modify your video cards sgr file and add your graphics card to it.

Can you also please post your dxdiag.txt file and your graphics rules and video cards sgr files? That will help us figure out what's up. You can get the dxdiag file by typing dxdiag in Windows search, then running dxdiag, the pressing Save All Info. You can find the sgr files in the locations below. Do you have Ultimate Collection or are you playing from disks?

DISKS
\Program Files (x86)\EA\The Sims 2 - <your most current expansion pack>\TSData\Res\Config\
\Program Files (x86)\EA\The Sims 2 - <your most current expansion pack>\TSData\Res\CSConfig\

ULTIMATE COLLECTION
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\CsConfig\

Finally, do you have a laptop with an integrated intel card and also an nvidia card? Try using the nvidia card instead. You'll need to select the nvidia card in nvidia panel (right click on the desktop). You will also need to use the sgr files for nvidia cards.

Couple more things

* play in windowed mode, not full screen
* make sure you run the game as administrator
* do NOT use compatibility mode!
* do NOT use -CPUCount:1 unless it helps you, sometimes there's lag due to multithreading not working right but try not using this first before you try using it
* if you are using Ultimate Collection, do NOT use the Origin exe, use the George noCD exe from Kiri instead
* find the line in your graphics rules sgr file that starts with "never", look at the line below and change false to true, we do want the card to manage its own memory

@BoilingOil - @gwynne - @Epi7 - @SomeRandoChick - Sorry for the mass reference but do any of you remember where that post was from the person with an Intel card who figured out how to correctly add it to video cards sgr? There was some finicky step they had to do that I'm not sure was in Kiri's directions.

0
#4 17-02-2018 
I don't need to go through all the recent posts -- most of which are gwynne's, epi7's or your own, by the way -- to find that kind of information, because it's dead simple. ALL the required data is in the config-log.txt

Look at the following sample:

Code:
=== Graphics device info ===
Number:          0
Name (driver):   Intel(R) HD Graphics 620
Name (database): Intel(R) HD Graphics 620 <<NOT FOUND IN DATABASE!>>
Vendor:          Intel
Chipset:         Vendor: 8086, Device: 5916, Board: 81ad103c, Chipset: 0002

It tells you that a card with device number 5916 identifies itself as an "Intel® HD Graphics 620", and that is all you need.
So you go to the section Intel in the Video Cards.sgr, and add a new line that looks like this:

Code:
card 0x5916 "Intel(R) HD Graphics 620"

That's all there is to it. You're done! And this works not only for Intel, but also for all other brands of graphics cards.

1
#5 19-02-2018 
@BoilingOil - Usually it is that simple, exactly as in Kiri's directions. I just remember I read a post from someone with an Intel card, can't remember which it was, who had to put something slightly different in the video cards sgr file, not exactly the same as what was in config. Or maybe it didn't quite match what was in the dxdiag. Some Intel 400 something card, I think? Of course I can't find the darn post now. :/

@jhendoo99 - Have you tried what BoilingOil explained in the post above?

0
#6 20-02-2018 
@CatOfEvilGeniu Ah, well, now you have some more time for your search, while they first try my method Smile Right? (lol)

0
#7 22-02-2018 
  • Registered
  • 2
  • 5
@BoilingOil It worked!!!! Thank you so much!!!

2
#8 23-02-2018 
@jhendoo99 GREAT! I'm happy for you.

0
#9 07-04-2018 
  • Registered
  • 2
  • 5
Hi okay update: So I did everything you said, even CatofEviliGuru's suggestions, but it's still a thing. It worked for a few seconds before it started doing it again, sorry for ocming back so late. But I managed to get it to where it doesn't say "NOT FOUND IN DATABASE" anymore, but it still does the glitching thing menioned in the original post

0
#10 08-04-2018 
  • Registered
  • 2
  • 5
Here is the updated Config Log

Attached File(s)
.txt  DESKTOP-453I87O-config-log.txt (Size: 10.37 KB / Downloads: 31)

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option