TS2 Ultimate Collection - Godawful lag
#1 22-09-2017 
  • Registered
  • 0
  • 1
Hello, guys

Today I downloaded The Sims 2 Ultimate Collection from Origin. Sadly, there is a terrible lag when you rotate the camera, when you move the camera across your house, and when you zoom out to see the whole house. The only moment where there is no lag is when you leave the camera still, and when you turn your back on the house.

I already tried:

-Graphic settings to "off" and "low".
-Retrocompatibility to Windows 7.
-Removed SecuROM and added the NoCD-file to prevent it from coming back.
-Affinity to 1 core
-Defragmented the hard drive
-Cleaned up disc space
-Uninstalled, downloaded and installed the game again
-Ran Razer Cortex: Game Booster

Nothing of this worked, for the lag is still there. What else can I try to fix it? There's 69.6 GB available out of 116 GB on my computer. TS2 UC is the only game installed on the system and the heaviest programs apart from it are Origin (329 MB) and Google Chrome (321 MB). There's also 500 MB of memes and 500 MB of university files. So basically I cleaned up everything for TS2 UC but it's still not working properly.

I attached my computer's specifications down below.

Thank you very much for your help.

Attached File(s) Thumbnail(s)
   

.txt  ANDRES-PC-config-log.txt (Size: 10.4 KB / Downloads: 35)
(This post was last modified: 23-09-2017 01:47 AM by AndresDashie.)

0
#2 21-10-2017 
  • Registered
  • 0
  • 1
Annecdotally, when I removed securom and did the registry fix thing it took away the lag from switching between sims. Are you also lagging when switching between live mode and build/buy? because if so, I'd say you should try removing securom again. You have to use a no-cd version of the executable or origin will just stick securom back on or something

0
#3 23-10-2017 
@AndresDashie

There's a reason you have god awful lag - You have almost no Texture Memory worth talking about.

CPU: You need to keep both cores - 2979 is not enough to run the game except in Low res, When you cut it back to 1 core you don't even have enough to low res.
RAM: 620MB - that's enough for very little CC - you should be playing the game vanilla. I'm pretty sure you're lagging because you're constantly paging. That is what happens when the RAM runs out of memory so it writes stuff to the paging file, which is on a hard disk, and therefore much slower.
GPU: 360MB - this is VERY low. what that means is that the game is struggling every time it refreshes the screen. Hence the reason why you're lagging.


Unfortunately - that means your machine is not up to running Sims2 - it IS very graphic intensive.

Things you can do -
1. Sims Life Stories was specifically done to run on weaker machines. If you can find a version of that, you shouldn't have any problems.
2. Uninstall Ultimate Collection and see if you can get just the base game - it puts less load on the computer.
3. Get a more RAM and a new graphics card.


OS version: Windows NT 6.0
CPU: 2979.199951Mhz, Name:GenuineIntel, FPU:1, MMX:1
Memory: 1024MB
Free memory: 620MB
User: andres
Computer: ANDRES-PC
=== Sound device info ===
Name: Unknown
Driver: Unknown
=== Graphics device info ===
Number: 0
Name (driver): Intel® G965 Express Chipset Family (Microsoft Corporation - WDDM 1.1)
Name (database): GMA 3000 (G965 Express Chipset Family)
Vendor: Intel
Chipset: Vendor: 8086, Device: 29a2, Board: 01dd1028, Chipset: 0002
Driver: igdumd32.dll, Version: 8.14.10.2697, GUID: D7B78E66-6AE2-11CF-1179-D721A3C2C535
Driver version: 2697
Monitor: \\.\DISPLAY1
Monitor aspect: 1.249169, 5:4
Screen mode: 1024x768x32BPP,75Hz
Texture memory: 360MB

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option