Sims 2 Ultimate Crashing - Tried most fixes
#1 09-11-2017 
  • Registered
  • 2
  • 5
Hello all. Long story short, I'm running Windows 10 and I've tried most fixes for my crashes:

Hack Conflict Removal
Got rid of all CC
Fresh Install
DEP
CFF
Securom Removal - Did not complete, but I hear it doesn't work on Win10, anyway

Crashes on save, intro, neighborhood, lot load... whatever it feels like, really. It's an old save game from another computer that wasn't running 10. If the general consensus is that I should export my most important sims and just start a new playthrough without CC, I will. Thank you for any assistance.

Attached File(s)
.txt  LOGIC-PC-config-log.txt (Size: 10.34 KB / Downloads: 12)

1
#2 09-11-2017 
OK, so I looked at your config-log.txt and the first thing I notice, is that your graphics card isn't recognized from the Database. That's not hard to fix, though:

Open the Video Cards.sgr file in Notepad or a similarly simple text editor, and find the NVIDIA section. In that section, insert a new line (near the top seems smart) that looks like this:

card 0x1c03 "GeForce GTX 1060 6GB" (that's including the quotation marks around the card name)

Now save the file, and you're done. Next time you start the game, the config-log.txt will be updated, and your video card is no longer unknown.

---

Secondly, I notice that you seem to have the 32MB Texture memory bug. There should be way more memory available than that, but the system currently sees only 32MB. Kiri knows way better than I how to fix that, but if you do the Video Cards.sgr thing first, this bug *might* solve itself automatically.

If there are still other issues that cause the crashing, other people (like Kiri, for example) are much more knowledgeable about how to find and fix them. I'm but a beginner in this area.

Either way, once you've done the Video Cards.sgr fix and run the game once, upload the new config-log.txt, so everyone who wants to help has the most recent version of your setup available, OK?

0
#3 09-11-2017 
  • Registered
  • 2
  • 5
So I uninstalled and reinstalled once more, did your suggested Video Card adjustments as well as doing the DEP and CFF again.
It seems to be running without crashes now, but I'm going to spend awhile stress-testing it just to be sure. Thank you so much for your help. Going to include the new log file just incase something is awry that hasn't presented itself, yet.

EDIT: It still reads as 32MB in the log, so I will try the force texture memory fix. Based on my dxdiag, what value would be most appropriate to set?

Attached File(s) Thumbnail(s)
   

.txt  LOGIC-PC-config-log.txt (Size: 9.47 KB / Downloads: 8)
(This post was last modified: 09-11-2017 09:06 PM by AngelicSavant.)

1
#4 09-11-2017 
Ah, so far so good, @AngelicSavant. Well done.

I wonder why you did the uninstall/reinstall all over again. It adds no value whatsoever. But what's done is done, and it shouldn't hurt, anyway. I would recommend, however, that you *do* get the appropriate no-CD.exe to run your game from. Saves a lot of hassle, even if it doesn't need to protect you from the no longer functional SecuROM crap.

The config-log.txt shows that the game now correctly recognizes your card in the Database. That's progress. Smile

However, you still have the 32MB texture memory issue. So I advise you to follow this link to
DOWNLOADS - GRAPHIC RULES and VIDEO CARDS
and download the file labeled "Graphic Rules - NVIDIA - Texture Fix - Max Screen size 1920x1080". Put that in the same folder as the "Video Cards.sgr" file, and another problem is fixed. After another test run repost the config-log.txt for verification, and if there are any other issues, Kiri will do her very best to find them.

Good luck with that Smile

1
#5 09-11-2017 
  • Registered
  • 2
  • 5
Added the file you mentioned, which bumped my texture memory to 1744MB. Thanks! Smile Would it be beneficial or advisable for me to force that higher?

Attached File(s) Thumbnail(s)
   

0
#6 12-11-2017 
Hi @AngelicSavant,

Could you do the following?
Right-click on your desktop, and select the NVIDIA Control Panel. In the bottom left corner of that screen, click "system information". Now it will show you a panel with your video card's details. In that window, find the line "Dedicated Video Memory" and write down the number you see there (I suspect it may be 6144 MB).

Now go to \Program Files (x86)\EA\The Sims 2 - <your most current expansion pack>\TSData\Res\Config\ and open the graphics rules.sgr
Find the line that reads "seti textureMemory 1744" and change the 1744 into the number that you just wrote down.
Save the file, and then make a copy of it in the \Program Files (x86)\EA\The Sims 2 - <your most current expansion pack>\TSData\Res\CSConfig\ folder.

Once that is done, your game will use all the texture memory your video card can provide!

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option