Flashing pink graphic problem (SOLVED)
#1 08-12-2017 
  • Registered
  • 3
  • 4
Hello,
I have come here from MTS where I was advised to check this thread
http://www.leefish.nl/mybb/showthread.php?tid=5446
as I suddenly got a problem with flashing pink textures in neighbourhood, and flashing red walls in CAS, the game became unplayable. I will post the detailed description of my problem which I had posted in MTS - see below, please.

I have Windows 10 and up to now, everything worked very well, my graphic card worked perfectly, even though it's a bit old now - ATI Radeon HD 4200 Series - now it seems the game does not recognize my graphic card.
I had big problems during the installation of Sims 2, about 2 years ago, when my Windows 10 was new and I installed the game. I had to use my old notebook to install the game there, and transfer the files from there to my PC. But since then, the game worked smoothly.

I am posting the Config log. I tried to follow the tutorial in this topic http://www.leefish.nl/mybb/showthread.php?tid=5446
but the problem is in the Config log itself - it shows that my graphic card is ": Microsoft Basic Render Driver <<NOT FOUND IN DATABASE!>>" - it does not show my ATI Radeon 4200 Series. So in the next step in the tutorial, I was not sure which package to download. I tried downloading the Radeon package and unzipped the files in those 2 locations but the game still flashed pink!
After that, I did not know what to do Sad please, could you try to help me? Is it possible to fix my game? I am afraid I won't be able to make it work again. The worst thing is that I did not change anything in my system. The graphic card should be ATI Radeon as I said but I don't understand why dxdiag and config log show that it's Microsoft Basic Render Driver. I'm very confused...

Also, in Device Manager (Windows 10) my graphic card is shown:
[Image: ati.png]
I wonder why dxdiag shows a different card, and the game too? I do hope there is a way to fix it

DESCRIPTION OF THE PROBLEM

http://www.modthesims.info/showthread.ph...ost5311663

Hello,
I beg you for some advice / help if possible...

I haven't played Sims 2 for quite a long time (I have been busy in life) but I wanted to play today. I launched the game but all I could see was the black screen. Of course I restarted the computer and hoped it would get fixed by itself... it did not. Next time there was blank screen again, so I waited for it to load the neighbourhoods - I guessed where to click and got to the neighbourhood. But the grass in the neighbourhood was flashing in pink colour.

I tried the usual things - deleted Groups.cache, Accessory.cache, I removed the Downloads folder, I even removed Neighbourhoods but nothing worked.

After some searching, I succeeded only in launching the game in a windowed mode. The loading looked normal (no black screen) - I thought the game would load with good graphics at last, but again the grass was flashing pink. I tried CAS and there the walls flashed in red colour (see pictures below)

I searched for this error via Google and found this video where it is recommended to download Graphics Rules Maker. So I immediately installed it, double-clicked the icon to launch the application but it didn't work - nothing happened!
https://www.youtube.com/watch?v=qLkmxAg7r3Y

I read somewhere that it doesn't help to reinstall the game with this glitch.
I suspect my graphic card to be responsible. I have Windows 10, graphic card ATI Radeon HD 4200 Series. It worked perfectly, my Sims 2 game always had beautiful graphics and I have not encountered any problems in this system (only with the installation but after that, the game worked well). Strange - I did not change any setting for the graphic card.
I checked in Device Manager and the graphic card appears there. However, in dxdiag it does not seem to appear. I'm confused as I do not understand technical issues with hardware much - I am not even able to buy a new graphic card so that it is compatible with the motherboard and the system, not to speak of putting it there myself and have noone who could help me with this.

I tried updating the driver but Windows 10 driver update program did not find any drivers for my card.

Here is the graphics info from dxdiag
--------------
Display Devices
---------------
Card name: Microsoft Basic Display Driver
Manufacturer: (Standard display types)
Chip type: ATI ATOMBIOS
DAC type: © 1988-2005, ATI Technologies
Device Type: Display-Only Device
Device Key: Enum\ROOT\BASICDISPLAY
Device Status: 4180000B [DN_ROOT_ENUMERATED|DN_DRIVER_LOADED|DN_STARTED|DN_NT_ENUMERATOR|DN_NT_DRIVER|DN_NO_SHOW_IN_DM]
Device Problem Code: No Problem
Driver Problem Code: Unknown
Display Memory: 3839 MB
Dedicated Memory: 0 MB
Shared Memory: 3839 MB
Current Mode: 1024 x 768 (32 bit) (64Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: Philips 150S


This is what the glitch looks like:

[Image: Untitled.png]

[Image: Untitled_bodyshop.png]

[Image: Untitled_windowed.png]

I also enclose the picture of graphic settings in the game - I used to play with the graphic settings on max level, reflections on - and as you can see, everything was reset to "low" automatically (I did not change anything) - and now even the 1024x768 resolution is not available here - it used to be there.

I will be grateful for any advice you can give me. As I do not understand HW technical issues, please be patient with me and explain in easy terms, if possible - sorry for this.

I feel very sad and helpless - I wanted to take part in a building contest (Christmas house)... I spent a lot of time downloading many Christmas decorations for my game Sad now I guess I won't be able to play for a very long time :cry:

Attached File(s)
.txt  A-PC-config-log.txt (Size: 10.21 KB / Downloads: 28)
.txt  DxDiag.txt (Size: 94.42 KB / Downloads: 29)
(This post was last modified: 09-12-2017 04:14 AM by Triamond.)

0
#2 09-12-2017 
In your "Device Manager" screenshot, under "Device status", it very clearly says "No drivers are installed for this device." Which, to me, means that your ATI Radeon HD 4200 Graphics card cannot be recognized by DXDiag and the Sims game, *because* you have not installed an appropriate driver for that card. And that, by extension, explains why they both assume the "Microsoft Basic Display Driver" or "Microsoft Basic Render Driver".

If you have no driver installed, Windows will just assume that you have a simple, basic VGA card. It will then use a DEFAULT driver, which is compatible with almost any graphics card, but does none of the specialized high level tricks the card knows. That is a so-called "generic" driver. So when DxDiag or your Sims game try to find out what graphics you use, they see that generic Microsoft driver. THAT is why they call it that.

So my tip to you is, to go to the Google page, and type "Radeon HD 4200 driver download" in the search bar. That will most certainly lead you to an ATI or AMD site where you can get the correct driver. When that driver has been installed on your system, things will suddenly go a lot smoother, because both DxDiag and your Sims game will be able to recognize your video card then.

0
#3 09-12-2017 
  • Registered
  • 3
  • 4
Thank you very much for your advice Smile I noticed the info about the drivers and already tried this yesterday in the evening.
I went to the site for my graphic card and it seems that "Driver support for these products under Windows® 8.1 and Windows® 10 is only available via Windows Update. Please enable Windows Update to allow it to automatically detect and install display driver version 8.970.100.9001".
http://support.amd.com/en-us/kb-art...der-Series.aspx

When I go to Device Manager in my Windows 10 and try the Windows Update, it searches for drivers but finds none, it says "The best drivers for your device are already installed. Windows has determined that the best driver for this device is already installed. There may be better drivers on Windows Update or on the device manufacturer's website."

So - in Windows Update they send me to the manufacturer's website and on the manufacturer's website they send me to Windows Update. I'm unsure what to do next.

But then I wonder why it worked so well until now? My ATI Radeon worked in Windows 10. I did not change anything in the system, did not update or uninstall any drivers by myself. Though I can't know if some apps did it behind my back or maybe Windows 10 was updated and made it incompatible? It had to be there - at least a few months ago because I played Sims 2 without any problem on this system. I am so disappointed and do not see a way to fix it.

Please, do you think that there is some way to find the driver or install it manually? I am not sure how it works with the automatic updating system in Windows 10, if this is possible.

1
#4 09-12-2017 
  • Registered
  • 3
  • 4
I tried the option "Roll back" for the driver - and it seems to work now! I tested the game now and the grass is green again - I am so happy that the solution was so simple!
[Image: Untitled.png]

Probably it was caused by some update of Windows 10 that my previous driver was disabled or overwritten by something else.

1
#5 09-12-2017 
Ah, so it *was* the driver, but you had to roll it back... That was something I could not have guessed. I'm glad, though, that you've figured it out, and mostly on your own, at that! Smile Well done.

0
#6 09-12-2017 
  • Registered
  • 3
  • 4
Not quite on my own, I got this advice from people on MTS :-) I didn't even know that there was an option to roll it back - hadn't played with the options of drivers in Win10 before as I was afraid to mess up my system. Thanks a lot for your advice too! :-)

1
#7 09-12-2017 
Hey, I *did* say "mostly", which isn't the same as "completely" Smile By the way, "roll back" isn't specifically a Win10 feature; it has existed for quite a while already.
Only on programs where it *really* matters (FireFox for example), the option isn't there. They just screw up your system, and you can't do anything about it. Sad

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option