SIMS 2 UC Crashes after Origin update
#1 25-12-2017 
  • Registered
  • 3
  • 5

.txt  OWNER-PC-config-log.txt (Size: 10.39 KB / Downloads: 59)

Good evening,

I have an Intel® Core™ i5 2450M CPU Windows 10 Home with a 64 bit operating system.
Sims 2 UC was working fine until the update through Origin. I would usually start the game through "run as administrator", but that option no longer works.
Now each time I attempt to load the game through Origin, I receive "the application has crashed" message when attempting to load one of the neighborhoods.
I assumed that because of the update I had to fix the video cards and graphic rules in Config and CSConfig folders, which I did, but this didn't resolve the crashing issues like before. Has anyone been able to resolve this issue since the update? If so are you able to help fix my issue?

Thanks in advance.

2
#2 02-01-2018 
@ibr3ath9

Yup - Origin updated the game to remove securom, and it caused more problems. The way to resolve this is to free the game from Origin.

What we're going to do is free the game from needing to be launched through Origin first -
1. Download No_CD version of Sims2EP9.exe .
This is the version I use so I know it doesn't have any viruses, and it works ok.

2. Then go to this folder:
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSBin\
and rename Sims2EP9.exe to Sims2EP9.old

3. Install the NoCD version into the folder

4. Run the game from this exe - Does it load? Does it ask for Origin?

If it loads, great. Create a shortcut from that exe and use that instead of Origin, and you should be good to go. Added Bonus, Origin phutzing around with the game will never cause you problems again.

If it doesn't load - come back, and we'll try something else.

2
#3 02-01-2018 
  • Registered
  • 0
  • 1
Helloes,

I got the same issue like ibr3ath9. I tried your solution but it did not work for me, so this is my last try to get my lovely game running again. Sad
I've tried a big list of so many possible things EA Support told me to, but it still does crash everytime i try to load a neighbourhood. Sad
Everything worked perfect for me before the latest origin update but now my game is totally screwed and after ea told me to fix smth in my bios (like I am the problem) i'm totally done with their support.

I hope there is someone nice in here who can help me out getting my game to work.
(Sorry for my english - I'm no native speaker)

Thanks in advance for trying!
Katja

Attached File(s)
.txt  config-log.txt (Size: 14.9 KB / Downloads: 45)

0
#4 19-02-2018 
  • Registered
  • 3
  • 5
Thanks so much for replying, but unfortunately this did not help at all. I guess whatever occurred during the Origin update already impacted or destroyed the game. So even if I bypass Origin to load the game it still crashes when loading a neighborhood.

0
#5 19-02-2018 
@ibr3ath9 - Double check a few things on your noCD shortcut.

1) Make sure you are NOT using compatibility mode. Several simmers have found during testing that the noCD exe appears to run much better when compatibility mode is NOT used.

2) Be sure the run as administrator box IS checked.

Something that helped me it to allow my graphics card to manage its own memory. I have an nvidia, not sure if this will help with Intel but worth trying.
If the above 2 steps did not help, try this next.

3) In your graphics rules sgr, look for "never". You will see a comment saying never let the card mange its own memory and under that there's a line setting memory management to false. Change the false to true. Copy your graphics rules sgr to both Config and CsConfig.

Try that and if it still not working, we have more things to try. Several of us have pulled our hair out for days but eventually got it to run again. Most of us have nvidia cards but we may be able to help with the intel card, hopefully.

[edit] I forgot to ask, did you clear caches beforehand?

0
#6 19-02-2018 
  • Registered
  • 3
  • 5
@CatOfEvilGeniu, I've tried everything that you suggested, but it still crashes.

0
#7 20-02-2018 
@Knotti the Odd - Your game is not recognizing your nvidia card, you need to add it to your video cards sgr and then copy that sgr file back to Config and CsConfig. If you looked at the pinned topics at the top, one of them is about editing your video cards sgr file. You also need to fix the 32 mb memory problem, that should help tremendously. Try one of Kiri's nivida sgr files, then edit the texture memory value to match the one from your dxdiag.txt. I can post more detailed directions tomorrow, time to read to the kiddo...

@ibr3ath9 - That's after you cleared caches, yes? I'll have more suggestions tomorrow or in a couple days, need to go read to the kiddo...

Both of you might try the following:

1) Try reinstalling your graphics driver. Do a clean manual reinstall. I can post directions for this later, need to read to the kiddo. I used guru3d DDU to reinstall my nvidia driver. I think that utility works for intel drivers too. Don't forget to turn off Window driver auto updates first.

2) Try removing your entire Neighborhoods folder. Don't delete it! Just move it somewhere safe, like your desktop. The game will regenerate fresh, unplayed neighborhoods. See if those crash. If it is still crashing, disable your cc. Does it still crash? The answer to these questions will give us some helpful info.

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option