Extreme TS2 neighborhood and lot lag! Help me :(
#1 25-12-2017 
  • Registered
  • 2
  • 3
Hi, guys. Let's get straight to the problem.

So, my neighborhood and lot have been lagging since 19th of December. On that day and two days before, I mainly downloaded lots of neighborhood decorations, skyboxes, skylines, a few poseboxes, a few mods, sun/moon default replacement, and a terrain replacement. The problem happened after I decorated my NH for hours and decided to press lot button. My NH deco were all gone except for my skyline, skybox, and animated skybox. Even the wall of my house was gone too when I look at it both from NH and within the lot. The lag wasn't that bad. But when I pressed NH deco button, all of my NH deco came back on the terrain and the lag was gone. When I visited Belladonna Cove, everything was normal. The similar pattern continued for a couple of days. I decorated my NH for hours before the lag happened. Sometimes all NH deco was gone, and the other times half of them were gone. Just when I thought I could live with that, it got worse around 22nd of December. Every NH was SUPER laggy and they all made weird static noise! When I made the closest zoomed in in NH, the lag was kinda gone, but when I zoomed out, the lag got worse. It was so bad that it became unplayable.

Here are the mods I'm having:
1. simNopke-skyFix2_1-EP6 (By "simNopke" on Tumblr)
2. GunMod's Camera Mod 3.1 (By "GunMod" on MTS) (I use this version: GCM-31-A.RAR)
3. BetterNightlife_win_V1 (By "Criquette Was Here" on Tumblr)

I also use Graphic Rule Maker version 1.1.0 since I'm playing on Window 10.

I have +35,000 CCs in my download folder, and I organized them into different 55 subfolders. Although many of them have high poly, I had no problem with the gameplay before I started downloading mods for the first time. My NH deco were made by either Criquette, Psychosim, greatcheesecakepersona (seasons ready skyline), or iCad (skyboxes). My terrain replacement was a recolor of CuriousB's by siletkasims on Tumblr.

I've tried disabled packages and deleted some suspicious packages that I downloaded throughout the days before the lag via Sims2Pack Clean Installer V1.6.22 but nothing was solved. Is it because I've too many CCs in my game? Or is it because I put way too much NH deco onto my NH?

P.S. Also I use the DVDs not the Ultimate Collection.

I don't wanna reinstall my game :'( Please somebody help meeee

Attached File(s) Thumbnail(s)
           

.txt  DESKTOP-V9GM226-config-log.txt (Size: 10.31 KB / Downloads: 57)

0
#2 26-12-2017 
One tip that now obviously comes too late: never install a large bulk of CC at once... Add new mods and stuff one or two at a time, and test the game before adding the next few. That way, you know exactly which item(s) is/are responsible the moment trouble starts. When you put a lot of stuff in at once, working on it for hours, it'll be VERY hard to figure out what went wrong!

How many MBs or GBs is your downloads folder? That is much more important than the number of files.

1
#3 26-12-2017 
  • Registered
  • 2
  • 3
My download folder's size is 9.39 GB.

Thank you for reminding me of that downloading tip! Smile It's really hard for me to not go back into downloading/installing spree. Sad At first, I made "NEW STUFF" subfolder in my download for screening any bad mod/CC in Sims2Pack Clean Installer. After I put a small amount of downloads into NEW STUFF, I started my game to see if there was any problem. If there was no problem, I would quit my game and assign those CCs into other subfolders that actually fit their categories (ex. [Buy] Chair & Sofa, [Build] Window, [CAS] Clothing, etc.). However, after awhile I became impatient and deleted NEW STUFF subfolder and assign my CCs to their matching subfolder right away because it took forever for my game to load each time I pressed play.

Luckily I made a backup on 14th of December before I download any mod, NH decor, and SC4. But if I had to unzip my backup, that would mean I had to start building and decorating my NH AGAIN. Is there anyway to solve lagging without unzipping my backup?

Attached File(s) Thumbnail(s)
   

0
#4 26-12-2017 
So you already knew the only way to do it right, with an intermediate folder for testing. You will not make the mistake of ignoring that again, I think.
Alas, if there *is* a way to fix this without unzipping the backup, then I must sadly admit that I do not know it. That doesn't mean that there *is* no way. Just that I don't know it.

So, either you wait for someone else to help you fix it, or you unzip that backup.
The first method means that you won't be enjoying your Sims for a few days.
The second method means that you CAN enjoy your Sims, but your decorations will be lost.
I know this is a tough choice, and I'm sorry.

1
#5 27-12-2017 
  • Registered
  • 2
  • 3
I think I'm gonna wait for awhile. I guess it's time for Minecraft marathon for now. If there are more people confirming that there's no solution to my NH and lot flickering + lagging, then I'll unzip my backup.

====

And also here are updates on my game's symptoms:

1. Yesterday I turned on TS2 just to check if it still had the same symptoms like the previous days. It turned out that the game ran surprisingly smooth! It was like nothing had happened. It went on smoothly for the entire afternoon and evening. That was until I exited the game. The screen went to black as usual but after a minute, there was a box appeared, saying that my TS2 didn't run properly or something like that and the application was shutting down. This was the first time that the box appeared.

2. Today I turned on TS2 again. It ran smoothly for hours until it my NH decors and the wall on the lot flickered (disappearing and appearing), and my NH lagged for a few minutes. It soon returned to a normal state for a short moment before crashing. And again, there was a box saying the same thing like yesterday. But this time it tried to find a solution/cause to the crashing but it couldn't figure out why.

====

Still, thank you for your advice. It was really kind of you. Smile This problem I'm having is a such a hard lesson for me. I'll try to be more careful on downloading and installing CC and mod from now on.

2
#6 02-01-2018 
@BoilingOil @dreamybluewhal

Looking at your RAM from your config-log.txt

Memory: 2048MB
Free memory: 1700MB

It looks like your system can't cope with 9.3Gb of CC.

Could you do me a dxdiag, and upload the dxdiag.txt please? That will tell me if your PC can cope or not. The config-log.txt doesn't tend to be accurate with reporting on RAM. If you have more than 2G of RAM in your system, we can do a fix that will increase how much RAM your game can access. But right now, it can only access 1.7G

What that means is that when you are using CC it has to swap it from RAM to the virtual paging file which is on your hard drive and back again. That's fine if it doesn't have to do it much - but if the amount of RAM swapping gets to be bigger than the 1.7G that it actually has, it gets confused and crashes.

This is likely to be the problem you have.

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option