SOLVED: prefer shadows and refresh boxed enabled, they're grey
#1 18-01-2018 
SHADOWS SOLVED: Duh, sim shadow control IS enabled, I just have to be in a lot, not in neighborhood view. I feel dopey.
Refresh rate is still greyed out in lot view too, but should I be concerned about that or not?
And my game is still crashing in community lots. I hope I can at least rule out graphics card causes.
I should probably start a separate thread about the crashing since this one was about shadows?

REFRESH SOLVED: My screen only supports one refresh rate for the resolution I was using so it makes sense for the refresh rate box to be grayed out.

--------------------------------------

Thank you in advance, Kiri, for any help you may provide and all your hard work on behalf of the community.

I have a Windows 10 system. My config log and both sgr files are attached. I used your nividia texture fix files (I think) with minor tweaks by me.
I changed the Shadows $High stuff to have simShadows be set to true. I want to be able to use Nopke's fix and manually turn shadows
off/medium/high in game. However, the box to do this is greyed out. How do I enable it? (Similar question about my refresh rate box)

[Image: 2znxvyb.png]

According to the config log, I am using Kiri's high settings, and those set shadows to high, right?
Yet when I look further in the log file and search for Shadows, I see a bunch of stuff set to 1 (low) instead of 3 (high).
Why is that? I looked in the config log at globals, options, and something else with options, network crashed when I was copying and pasting all that.
Bump mapping also seems to be off since heightMapShadows (not sure of spelling) was set to false or 1 or something (darn network crash).

I think at least the refresh rate box was not grayed out when using the EAxian sgr files. Maybe I need to do a diff on them? If only Win 10 still had windiff.

Thanks again for any help.

PS - maybe related??? my machine kept crashing when at a community lot (lots of sims, lots of objects, lots of textures) Jules suggested adding a database line to videocards.sgr
so I did that and according to the config log, it is finding the card in the database now. Not sure how that helps since when the game came out, they would not have had info about the card
so where is it getting any info about the card from? I assume Kiri's additions to graphics rules sgr deal with that, like setting texture memory to 1744. I haven't tested yet to see if that got
rid of the crashes. Could just be EA borking the hoods so I'm going to try fixed neighborhoods from meetme2theriver. Ugh, so much work to get Sims working, but worth it if I ever do.

My resolution is just fine, btw, thanks to Kiri and other fine folks at leefish and MTS! Yay, at least I have good resolution!
.zip  cat_sgr_and_log.zip (Size: 14.66 KB / Downloads: 18)

edit: I can't do Watch Topic on my own thread for some reason. It says 'this is a members only function' when I press Watch Topic. It wants me to log in but I am logged in. I'm very confused. Do I need to post more or be more active before that feature becomes available to me?

Attached File(s) Thumbnail(s)
   
CatOfEvilGeniu, proud to be a member of LeeFish since Mar 2017.
(This post was last modified: 20-01-2018 06:03 PM by CatOfEvilGeniu.)

0
#2 18-01-2018 
Here are the lines from the config log that puzzle me.

Name (driver): NVIDIA GeForce GTX 1060 6GB
Name (database): GeForce GTX 1060 6GB <-- this is ok, right, I added my card to video cards sgr

Cat: changed simShadows to true in option Shadows High <-- I changed simShadows to true for High Shadows
Kiri: memory hi cpu hi max vertex > 1 not force low not integrated <-- using Kiri's high settings, those use High Shadows, right?

Global properties
-----------------
boolProp simShadows true <-- this looks good so far but then...
uintProp optionShadows 1 <-- this. Shouldn't this be 3 high not 1 low???

Options
-------
uintProp Shadows 1 #default: 3 <-- again, shouldn't this be 3 if I want shadows to be high, not low?

Option properties
-----------------
boolProp simShadows false <-- what happened here? didn't I want this true so I can see sim shadows?
boolProp objectShadows false
boolProp guob false <-- what's a guob?
boolProp heightMapShadows false <--- Noooooo! I can't live without bump maps! Ok, maybe I can, but why would I want to?

uintProp optionShadows 1 <--- this again, is it different from the boolProp? does one override the other? and why isn't it 3?

Device properties
-----------------
boolProp useRenderTextures false <-- not sure this has anything to do with shadows but why is it false? should it be true? is this bad?

boolProp enumerateMultisampleLevels true <--- Yay smoothing! Nothing to do with shadows, but yay, something works right! Go Kiri!

0
#3 19-01-2018 
Sim shadow control IS enabled when I'm on a lot, just not in the neighborhood. I'm a doof.
Sim shadows high works beautifully with Nopke's fix. Black square begone! All hail Nopke!

Still not sure why refresh rate is greyed out, on sim lots too. Should I worry about that or not?

On a maybe related or not note, my game is crashing on neighborhood lots and I don't know if it's a graphics issue or the neighborhood got borked or what.
That should probably be a separate thread. I started one on MTS here about the crashing issue.
Can we rule out crashing due to graphics card issues based on the files I uploaded in my original post? Should I start another thread here about crashing?
I don't want to be spammy.

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option